pb gestion couleur gateway [Résolu]

Depuis que Domoticz intègre nativement la gateway Zigbee Xiaomi retrouvez ici un espace de discussion dedié
frtoto
Messages : 30
Enregistré le : 17 févr. 2018, 17:02

pb gestion couleur gateway [Résolu]

Message par frtoto » 05 juin 2018, 15:25

Bonjour,

j'ai créé un script blocky de sonnette, la passerelle sonne bien, par contre je voudrais qu'elle s'allume en rouge (par exemple) pendant 1 minute.

Avec ce script, elle s'allume bien mais avec la couleur par défaut (bleu très pâle actuellement) la commande qui suit "open URL" n'ayant aucun effet...
(http://192.168.0.20:8080/json.htm?type= ... hite=false)
j'ai bien mis l'ip de la passerelle mais dois-je mettre le port 8080 ou celui qui est défini dans mes paramètres (9898) ?

j'ai vu sur un autre post qu'il fallait mettre :code avant ou après l'ip ???

je suis perdu !

merci de votre aide
image.png
image.png (25.37 Kio) Vu 791 fois
Modifié en dernier par frtoto le 02 août 2018, 20:55, modifié 1 fois.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


christophe2836
Messages : 136
Enregistré le : 26 déc. 2017, 22:27

Re: pb gestion couleur gateway

Message par christophe2836 » 05 juin 2018, 15:35

Chez moi J’ai créé un scénario avec ma passerelle ou je lui ai défini la couleur ensuite dans blocky, A la place de open url, j’ai mis un set scène « nom de mon scénario «  = on
Capture.JPG
Capture.JPG (39.19 Kio) Vu 788 fois
Capture1.JPG
Capture1.JPG (21.59 Kio) Vu 788 fois
Envoyé de mon iPhone en utilisant Tapatalk

Jeff
Messages : 527
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: pb gestion couleur gateway

Message par Jeff » 05 juin 2018, 22:35

Quand j'en ai eu besoin j'ai utilisé cette fonction dans module.lua (issue Vil1driver). Je l'ai modifié, elle ne marchait pas et je l'ai décomposé.
Tu as aussi le os.execute dedans avec le lien url correspondant à ta question initiale.

Code : Tout sélectionner

function setColorAndBrightness(device, color, brightness)
	--local api = '/json.htm?type=command&param=setcolbrightnessvalue'
	local idx = '&idx='..otherdevices_idx[device]
	--print("Idx : "..idx)
	local color = '&hue='..color
	--print("color : "..color)
	local brightness = '&brightness='..brightness
	--print("brightness : "..brightness)
	local iswhite = '&iswhite=false'
	--api = api..idx..color..brightness..iswhite
	api = '/json.htm?param=setcolbrightnessvalue&type=command'..idx..color..brightness..iswhite
	print("api : "..api)
	os.execute(curl..'"'..domoticzURL..api..'" &')
	--os.execute('curl "192.168.1.208:8080/json.htm?type=command&param=setcolbrightnessvalue&idx=210&hue=20000&brightness=10&iswhite=false" ')
end

Code : Tout sélectionner

-- désactivation alarme
if (devicechanged[switchrond]=='Click') then
		updateVar(varmp3,sonact) -- choix du son : 10002 son alarme
		switchOn(volume,100)
		switchOnFor(sirene,3) -- son de prise en compte 3 sec
		switchOn(alarme, 0)
		--os.execute('curl "192.168.1.208:8080/json.htm?type=command&param=setcolbrightnessvalue&idx=1&hue=00100&brightness=10&iswhite=false" ') -- Anneau vert gateway Xiaomi
		setColorAndBrightness(gateway,00100,10)
		print ("Alarme desactivée")
Version: 3.81.53; KMTronic usb ; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...) DIO ; OREGON/4 THGN/PCR800; DIY/3 temp, Teleinfo usb; RFLink; MYSensors v2.0/GW Lan/Power meter/RGB 3D; ESPeasy Oled, Nextion...

frtoto
Messages : 30
Enregistré le : 17 févr. 2018, 17:02

Re: pb gestion couleur gateway

Message par frtoto » 07 juin 2018, 09:54

Merci à vous 2 !

Pour le script lua, trop compliqué pour l'instant je ne m'y suis pas encore penché dessus.

Pour le scénario j'ai testé, par contre tu mets quoi comme dispositif d'activation ? en mettant mon switch la sonnette sonne 3 fois au lieu d'une seule.
De plus la passerelle s'allume bien en rouge, mais j'ai beau mettre un délai d'extinction à 45 sec, elle s’éteint tout de suite...

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


christophe2836
Messages : 136
Enregistré le : 26 déc. 2017, 22:27

Re: pb gestion couleur gateway

Message par christophe2836 » 07 juin 2018, 10:14

frtoto a écrit :Merci à vous 2 !

Pour le script lua, trop compliqué pour l'instant je ne m'y suis pas encore penché dessus.

Pour le scénario j'ai testé, par contre tu mets quoi comme dispositif d'activation ? en mettant mon switch la sonnette sonne 3 fois au lieu d'une seule.
De plus la passerelle s'allume bien en rouge, mais j'ai beau mettre un délai d'extinction à 45 sec, elle s’éteint tout de suite...
Le délai d’extinction doit être dans le scénario et non dans les paramètres de la gateway.c’est ce que tu as fait ?


Envoyé de mon iPhone en utilisant Tapatalk

frtoto
Messages : 30
Enregistré le : 17 févr. 2018, 17:02

Re: pb gestion couleur gateway

Message par frtoto » 07 juin 2018, 16:26

oui, je te ferais une capture d'écran ce soir.
C'est comme si le scénario venait en conflit avec l’événement qui l'appelle..

Phebus06
Messages : 164
Enregistré le : 26 janv. 2017, 09:25

Re: pb gestion couleur gateway

Message par Phebus06 » 08 juin 2018, 09:16

Essai ça ;)

Code : Tout sélectionner

http://NOM:CODE@192.168.1.92:8080/json.htm?type=command&param=setcolbrightnessvalue&idx=63&hex=FF0000&brightness=5     
et l'intensité avec ça :
http://NOM:CODE@192.168.1.92:8080/json.htm?type=command&param=switchlight&idx=63&switchcmd=Set%20Level&level=5
Script Accueil.png
Script Accueil.png (30.23 Kio) Vu 679 fois

frtoto
Messages : 30
Enregistré le : 17 févr. 2018, 17:02

Re: pb gestion couleur gateway

Message par frtoto » 08 juin 2018, 09:36

merci mais ce qui me pose pb c'est "nom:code" car le code je peux mettre celui renseigné dans les paramètres mais le nom ???

Phebus06
Messages : 164
Enregistré le : 26 janv. 2017, 09:25

Re: pb gestion couleur gateway

Message par Phebus06 » 08 juin 2018, 10:12

c'est ton identifiant et le mot de passe qui te permettent de te connecter sur domoticz.
Dans Domoticz, Réglages, Paramètres, Système,
Code.png
Code.png (19.91 Kio) Vu 670 fois

frtoto
Messages : 30
Enregistré le : 17 févr. 2018, 17:02

Re: pb gestion couleur gateway

Message par frtoto » 08 juin 2018, 20:21

merci, je cherchais du côté de la passerelle !!<??? pff le nul !

edit : ça ne marche toujours pas, on est d'accord que l'ip est celle de la passerelle et que je laisse le port à 8080 ? (j'ai allumé la lampe pour vérifier que cela se lançait bien !)
domo1.jpg
domo1.jpg (26.48 Kio) Vu 632 fois

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre