Problème d'utilisation du plugin Broadlink

les autres capteurs : Sondes Météo, switches
DavidTrier
Messages : 32
Enregistré le : 07 nov. 2017, 20:05

Problème d'utilisation du plugin Broadlink

Message par DavidTrier » 20 mai 2018, 15:08

Bonjour à tous,

Tout d'abord, je vous précise que j'utilise Domoticz sur un Raspberry 3, qui tourne sous Raspbian Stretch dans sa version d'avril 2018. Et Domoticz est en version 3.8153.

Dans mon installation, j'ai deux appareils Broadlink : un RM Mini et un RM Pro. Depuis plusieurs mois, je les ai intégré dans Domoticz en utilisant cette procédure, un peu lourde et limitée en termes d'utilisation (par exemple, je n'arrive plus à lire la température renvoyée par le RM Pro): http://domo-attitude.fr/broadlink-rm-promini-domoticz/

Etant donné qu'un plugin a été mis "sur le marché", j'aimerais bien l'utiliser. Je l'ai donc installé en suivant les consignes d'ici : https://www.domoticz.com/wiki/Plugins/BroadlinkRM2.html

Rien à faire, ça ne marche pas! J'ai testé les deux méthodes : mise en mode "discovery" ou "configuration directe" via l'IP et l'adresse MAC de mes RM.**Voici ce que j'ai en LOG :
2018-05-20 15:05:30.908 Error: Broadlink hardware (11) thread seems to have ended unexpectedly
2018-05-20 15:06:00.914 Error: Broadlink hardware (11) thread seems to have ended unexpectedly
Comme j'avais des plantages de Domoticz, j'ai tout réinstallé hier, y compris Raspbian, donc je pense avoir une config à peu près propre. J'avoue que je sèche complètement!

Une idée sur la résolution de ce problème? Merci à tous ;-)

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


allstar71
Messages : 21
Enregistré le : 23 nov. 2016, 09:25

Re: Problème d'utilisation du plugin Broadlink

Message par allstar71 » 22 mai 2018, 10:22

Salut,

Je viens de réinstaller mon serveur domoticz et mon broadlink RM mini. J'ai utilisé cette méthode : http://domo-attitude.fr/broadlink-rm-promini-domoticz/

Cependant, le code a changé et il faut mintenant spécifier le device dans la commande broadlink.rm.

Pour la seconde méthode, je ne l'ai pas testée donc je ne pourrais pas t'aider. Quelle méthode veux-tu utiliser en priorité ?

DavidTrier
Messages : 32
Enregistré le : 07 nov. 2017, 20:05

Re: Problème d'utilisation du plugin Broadlink

Message par DavidTrier » 02 juin 2018, 12:06

Bonjour,

Merci de ta réponse et désolé du retour aussi lent, j'étais sous la vague!

J'ai aussi utilisé la méthode que tu indiques, mais j’aimerais bien pouvoir utiliser la seconde car le plugin a l'air plus complet et il permet d'aller lire la température de mon RM Pro par exemple. Cela peut se faire avec la première méthode, mais un jour ça a buggé et je n'ai plus jamais réussi à y accéder.

francklek
Messages : 62
Enregistré le : 08 janv. 2016, 19:54

Re: Problème d'utilisation du plugin Broadlink

Message par francklek » 03 juin 2018, 09:34

Hello, j'ai aussi un problème avec le plugin Broadlink.
Ma config : Rasp 2
Domoticz 3.9562
Broadlink RM mini
lorsque je transfert les fichier du plugin, je sélectionne dans matériel mon plugin, je le configure ou je le passe en discover (peu importe le résultat est le même). je redémarre domoticz et la gros plantage. Domoticz offline.
Si je supprime le fichier plugin.py je relance domoticz tout rentre dans l'ordre.
J'ai essayé de passer toutes les permissions en 777 mais j'ai toujours le même résultat.
C'est la même chose avec la version 4.0.1 et 4.0.0 du plugin.
Quelqu'un peu venir à mon secours....Denoo ???
Pi 2 / RFXtrx433E 251 / Stick Zwave Gen5 / Freebox V6 / Samsung S3 en panneau de contrôle / Domoticz V3.5...

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Jeff
Messages : 527
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: Problème d'utilisation du plugin Broadlink

Message par Jeff » 04 juin 2018, 21:25

allstar71 a écrit :Salut,

Je viens de réinstaller mon serveur domoticz et mon broadlink RM mini. J'ai utilisé cette méthode : http://domo-attitude.fr/broadlink-rm-promini-domoticz/

Cependant, le code a changé et il faut mintenant spécifier le device dans la commande broadlink.rm.

Pour la seconde méthode, je ne l'ai pas testée donc je ne pourrais pas t'aider. Quelle méthode veux-tu utiliser en priorité ?
Si tu veux bien préciser ce que tu as changé dans la commande broadlink.rm ?
Je rencontre le problème et comme le plugin ne marche sous mon ubuntu à cause de python 3.5, j'essaye cette méthode , ça me dépasse :(

Edit : je me suis relancé à l'assaut du plugin. J'ai enfin compris l'histoire du python3.6 pour moi, j'ai fait cela sur les conseils de Deennoo dans le wiki du plugin

Code : Tout sélectionner

sudo cp -r /usr/local/lib/python3.6/dist-packages/Crypto/ /usr/lib/python3.6/
and
sudo cp -r /usr/local/lib/python3.6/dist-packages/broadlink /usr/lib/python3.6/
Le plugin se lance mais me bloque domoticz :

Code : Tout sélectionner

2018-06-04 22:34:47.935 (Broadlink) Started.
2018-06-04 22:34:48.107 (Broadlink) Entering work loop.
2018-06-04 22:34:48.108 (Broadlink) Initialized version 4.1.0, author 'zak45'
Pas de switch de créé. Je ne suis pas sûr de la ligne de config ici :
Folder to store ini files (RM2/RM mini3):

Code : Tout sélectionner

/home/jeff/domoticz/plugins/BroadlinkRM2/
Version: 3.81.53; KMTronic usb ; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...) DIO ; OREGON/4 THGN/PCR800; DIY/3 temp, Teleinfo usb; RFLink; MYSensors v2.0/GW Lan/Power meter/RGB 3D; ESPeasy Oled, Nextion...

allstar71
Messages : 21
Enregistré le : 23 nov. 2016, 09:25

Re: Problème d'utilisation du plugin Broadlink

Message par allstar71 » 04 juin 2018, 22:44

Alors dans la commande rm.broadlink du script python il faut rajouter à la fin le type de device. Tu peux me trouver dans le fichier _init_ de la librairie broadlink.
Je t’envoi ça dès demain matin :)


Envoyé de mon iPhone en utilisant Tapatalk

Jeff
Messages : 527
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: Problème d'utilisation du plugin Broadlink

Message par Jeff » 04 juin 2018, 22:53

Trouver merci je test cela demain :D
Pour moi c'est devtype = 'RM Mini'
Dans learn.py et play.py il faut rajouter le devtype à la fin de cette ligne :

Code : Tout sélectionner

device = broadlink.rm(host=("192.168.xxx.xxx",80), mac=bytearray.fromhex("0000000000"), devtype = 'RM Mini')
Modifié en dernier par Jeff le 04 juin 2018, 23:31, modifié 2 fois.
Version: 3.81.53; KMTronic usb ; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...) DIO ; OREGON/4 THGN/PCR800; DIY/3 temp, Teleinfo usb; RFLink; MYSensors v2.0/GW Lan/Power meter/RGB 3D; ESPeasy Oled, Nextion...

Jeff
Messages : 527
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: Problème d'utilisation du plugin Broadlink

Message par Jeff » 04 juin 2018, 23:29

J'ai pas attendu demain, enfin, ca marche :D
Merci pour le coup de main, celui la il m'aura tellement résisté que j'avais déjà emballé la boite dans les cartons. :lol:

Je m'attaquerais au plugin maintenant :evil:
Version: 3.81.53; KMTronic usb ; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...) DIO ; OREGON/4 THGN/PCR800; DIY/3 temp, Teleinfo usb; RFLink; MYSensors v2.0/GW Lan/Power meter/RGB 3D; ESPeasy Oled, Nextion...

allstar71
Messages : 21
Enregistré le : 23 nov. 2016, 09:25

Re: Problème d'utilisation du plugin Broadlink

Message par allstar71 » 05 juin 2018, 09:19

Il me semble que moi j'avais mis devtype= et le code en hexa mais si ça marche avec un str c'est encore plus facile :)

Content d'avoir pu t'aider.

Bon courage pour l'utilisation du plugin, si il y a un intérêt à passer par le plugin et que tu arrives à le faire fonctionner je serais intéressé :)

Jeff
Messages : 527
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: Problème d'utilisation du plugin Broadlink

Message par Jeff » 05 juin 2018, 20:11

allstar71 a écrit :Il me semble que moi j'avais mis devtype= et le code en hexa mais si ça marche avec un str c'est encore plus facile :)

Content d'avoir pu t'aider.

Bon courage pour l'utilisation du plugin, si il y a un intérêt à passer par le plugin et que tu arrives à le faire fonctionner je serais intéressé :)
Effectivement j'ai mis le string et pas le code hexa et ca marche, bizarre quand même mais tant mieux.

Bon je m'attaque au plugin :x
Version: 3.81.53; KMTronic usb ; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...) DIO ; OREGON/4 THGN/PCR800; DIY/3 temp, Teleinfo usb; RFLink; MYSensors v2.0/GW Lan/Power meter/RGB 3D; ESPeasy Oled, Nextion...

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre