Probleme pour Executer une URL

Vous avez des questions concernant les scripts dans Domoticz, posez vos questions ici, quelque soit le langage nous tenterons des réponses pertinentes ...
Répondre
Rhum1x56
Messages : 40
Enregistré le : 05 nov. 2017, 18:05

Probleme pour Executer une URL

Message par Rhum1x56 » 13 sept. 2018, 11:58

Salut,
alors voila je me sert de pushingbox pour envoyer des notifications sur mon telephone. pour mon alarme, la surveillance du raspberry ...

mon probleme est que en utilisant cette commande :
os.execute('wget "http://api.pushingbox.com/pushingbox?devid=**********"')
j'ai un fichier qui se cree a chaque fois dans le dossier domoticz, nommer "pushingbox?devid=******", "pushingbox?devid=******2".
le soucis c'est que ca remplie la carte SD et que c'est super long de supprimer tout les fichiers chaque fois. 2000 fichier il y a quelque jours.

J'ai donc tester la commande suivante :
commandArray['OpenURL'] = 'http://api.pushingbox.com/pushingbox?devid=*****'
mais j'ai une erreur : Error: Error opening url: http://api.pushingbox.com/pushingbox?devid=*****

SVP; comment faire pour ne pas avoir d'erreur et ne pas avoir de fichier qui se cree a chaque fois.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


oredin
Messages : 21
Enregistré le : 31 août 2018, 19:13

Re: Probleme pour Executer une URL

Message par oredin » 13 sept. 2018, 12:17

Bonjour,

Deux solutions :
1. Utiliser "wget -O - http://api.pu...
2. Utiliser "curl" à la place de wget

Bon courage.
Domoticz Beta - ZStickGen5 - RFP1000 - Alexa
433 : Sondes Oregon - Prises Chacon - Sonnette Chacon - VR Somfy RTS
ZW : Modules Qubino - HRT4/ASR

Rhum1x56
Messages : 40
Enregistré le : 05 nov. 2017, 18:05

Re: Probleme pour Executer une URL

Message par Rhum1x56 » 13 sept. 2018, 12:40

merci je test tout de suite. le-O apres wget ca enleve la creation de fichier ?

vil1driver
Messages : 4546
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: Probleme pour Executer une URL

Message par vil1driver » 13 sept. 2018, 12:46


Domoticz v4.10078 (ubuntu server) OpenZwave v1.4-3000 (zwave+ sigma designs) rfxtrx433 fw1015T1

433mhz : thgn800, ms13e2, phenix, Di.O, zk1pa, creasol sender
868mhz : fgms-001, fgfs-101, dsd37-zweu, ZW098


modules.lua

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Rhum1x56
Messages : 40
Enregistré le : 05 nov. 2017, 18:05

Re: Probleme pour Executer une URL

Message par Rhum1x56 » 13 sept. 2018, 12:53

Pas mal la doc, merci.
du coup wget -O ca ne me cree pas de fichier donc nickel mais je n'est plus de notification sur mon telephone non plus.
j'ai donc utiliser curl et plus de probleme. pas de fichier et j'ai bien mes notification.
pourquoi autant d'option pour lancer une URL, dommage.

dommage il n'y a pas de point sur ce forum, sinon +1

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre