Blocky comportement bizarre

Vous avez des questions concernant les scripts dans Domoticz, posez vos questions ici, quelque soit le langage nous tenterons des réponses pertinentes ...
Répondre
xavier.jacquemont
Messages : 2
Enregistré le : 27 déc. 2017, 09:18

Blocky comportement bizarre

Message par xavier.jacquemont » 14 sept. 2018, 22:28

Bonjour

J'ai un schéma archi simple à faire dans blocky et ça ne marche pas (cf image):
La position temporisée ne change jamais état, qu'elle que soit la valeur de l'entree. (Qui elle, change bien :))

Contexte :
- position portail est une entrée gpio
- position portail temporisée est un Switch virtuel type interrupteur

Note : J'ai d'autres schémas qui tournent sans problème.

Est ce que ça vous inspire quelque chose?

Merci!Image

Envoyé de mon MI 5s en utilisant Tapatalk

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


vil1driver
Messages : 4546
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: Blocky comportement bizarre

Message par vil1driver » 14 sept. 2018, 22:50

Salut,

Déjà bravo pour la capture, on ne voit que trop rarement la partie droite ;)

A mon humble avis car pas du tout utilisateur blocky,
Le '00:02' ne doit pas convenir pour une valeur attendue en seconde.

Regarde s'il ne peu pas y avoir un bloc plus adapté (simple valeur)

Exemple (google image 'domoticz blocky after')

Image
Modifié en dernier par vil1driver le 14 sept. 2018, 22:56, modifié 1 fois.

Domoticz v4.10078 (ubuntu server) OpenZwave v1.4-3000 (zwave+ sigma designs) rfxtrx433 fw1015T1

433mhz : thgn800, ms13e2, phenix, Di.O, zk1pa, creasol sender
868mhz : fgms-001, fgfs-101, dsd37-zweu, ZW098


modules.lua

xavier.jacquemont
Messages : 2
Enregistré le : 27 déc. 2017, 09:18

Re: RE: Re: Blocky comportement bizarre

Message par xavier.jacquemont » 14 sept. 2018, 22:56

vil1driver a écrit :Salut,

Déjà bravo pour la capture, on ne voit que trop rarement la partie droite ;)

A mon humble avis car pas du tout utilisateur blocky,
Le '00:02' ne doit pas convenir pour une valeur attendue en seconde.

Regarde s'il ne peu pas y avoir un bloc plus adapté (simple valeur)

Exemple

https://www.google.fr/search?q=domoticz ... 60&bih=560
Ok je vais essayer avec simplement "2"
Par contre pour ne rien te cacher, j'ai aussi essayé de faire plus simple :
If ... = ...
Then ... = ...
Sans succès !
Je dois passer à côté de quelque chose...

Envoyé de mon MI 5s en utilisant Tapatalk

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre