ESPEASY et Domoticz problème de règles

les autres capteurs : Sondes Météo, switches
Répondre
MaveryQ
Messages : 11
Enregistré le : 11 déc. 2017, 21:58

ESPEASY et Domoticz problème de règles

Message par MaveryQ » 11 oct. 2018, 09:13

Bonjour,

Voici mon problème, je gère des interrupteurs SONOFF Basic flashés pour mes éclairages et VMC ...
Je souhaiterai avoir un retour de la part de ces équipements pour être sûr du fonctionnement.
J'ai trouvé la fonction sendtohttp mais voilà, l'interface de mon SONOFF en ESPEASY ne prend pas ma ligne !
Mon SONOFF est en 2.4.0 RC2 Build 147.
Il prend bien en compte séparemment les lignes suivantes
SendToHttp @IP,port,/json.htm?type=command
SendToHttp @IP,port,/json.htm?param=switchlight
SendToHttp @IP,port,/json.htm?idx=7
SendToHttp @IP,port,/json.htm?switchcmd=On
Mais dès que je mets la concaténation il ne la prend pas en compte et remet les règles précédentes avant modification !
SendToHttp @IP,port,/json.htm?type=command&param=switchlight&idx=7&switchcmd=On
La ligne ne reste pas affichée et il me remet le code précédent ...

Quelqu'un a-t-il une idée ?

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


tekkharibo
Messages : 238
Enregistré le : 28 déc. 2017, 09:51
Localisation : Albi

Re: ESPEASY et Domoticz problème de règles

Message par tekkharibo » 11 oct. 2018, 09:26

Je crois qu'il y a un système pour avoir les retour directement dans domoticz

Envoyé de mon SM-G935F en utilisant Tapatalk

Projet de domotique low-cost : Mon installation MAJ 01/12/2018
Dans le doute reboot !
Si vous êtes pas loin d'Albi on peut se rencontrer pour partager

MaveryQ
Messages : 11
Enregistré le : 11 déc. 2017, 21:58

Re: ESPEASY et Domoticz problème de règles

Message par MaveryQ » 11 oct. 2018, 09:32

De mon côté, je crée le Dummy, puis le capteur virtuel.
Dans le tableau des interrupteurs je crée avec en ligne de commande http://<espeasyip>/control?cmd=GPIO,12,1 dans la commande On et http://<espeasyip>/control?cmd=GPIO,12,0 dans la commande Off.

Donc dans mon Espeasy, je mets la règle
on event GPIO,12,1
sendtohttp
endon

Pour faire le test, je mets un timer dans mon espeasy qui allume tout seul la VMC et je veux voir l'état de l'interrupteur Domoticz se mettre ON.

Jeff
Messages : 575
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: ESPEASY et Domoticz problème de règles

Message par Jeff » 11 oct. 2018, 17:49

Oui problème connu, il faut inverser l'ordre des ordres param et command

Code : Tout sélectionner

On Pompe#Relais=0
sendtohttp 192.168.0.101,8080,/json.htm?param=switchlight&type=command&idx=11&&switchcmd=Off
endon
Version: 3.81.53; KMTronic usb ; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...) DIO ; OREGON/4 THGN/PCR800; DIY/3 temp, Teleinfo usb; RFLink; MYSensors v2.0/GW Lan/Power meter/RGB 3D; ESPeasy Oled, Nextion...

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


MaveryQ
Messages : 11
Enregistré le : 11 déc. 2017, 21:58

Re: ESPEASY et Domoticz problème de règles

Message par MaveryQ » 11 oct. 2018, 20:01

Ben sans résultat ...
Ce qui me gène c'est que lorsque j'appuie sur la touche SUBMIT, il revient immédiatement aux règles validées avant !

Jeff
Messages : 575
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: ESPEASY et Domoticz problème de règles

Message par Jeff » 11 oct. 2018, 20:43

Jeff a écrit :
11 oct. 2018, 17:49
Oui problème connu, il faut inverser l'ordre des ordres param et command

Code : Tout sélectionner

On Pompe#Relais=0
sendtohttp 192.168.0.101,8080,/json.htm?param=switchlight&type=command&idx=11&&switchcmd=Off
endon
Ca ne marche car tout simplement que ma commande était remplie de faute (manque le do et 2 && après mon idx) :?

Code : Tout sélectionner

On eventname=0 do
sendtohttp 192.168.0.xxx,8080,/json.htm?param=switchlight&type=command&idx=325&switchcmd=Off
endon
A tester comme ceci :

Code : Tout sélectionner

http://192.168.0.ipESP/control?cmd=event,eventname=0
Edit :

Dans la doc des rules à SendToHTTP, tu as ceci ICI
Many users have reported problems with commands being truncated, particularly when trying to send commands to domoticz. It seems to be a parsing error. There is the following workaround

SendToHTTP 192.168.0.243,8080,/json.htm?type=param=switchlight&command&idx=174&switchcmd=On
Version: 3.81.53; KMTronic usb ; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...) DIO ; OREGON/4 THGN/PCR800; DIY/3 temp, Teleinfo usb; RFLink; MYSensors v2.0/GW Lan/Power meter/RGB 3D; ESPeasy Oled, Nextion...

DreamL
Messages : 56
Enregistré le : 20 janv. 2017, 20:03

Re: ESPEASY et Domoticz problème de règles

Message par DreamL » 11 oct. 2018, 21:33

Salut
Essaie voir d'agrandir la zone de texte avec le coin en bas a droite pour faire en sorte que ta commande tiens sur 1 ligne.
ensuite enregistre.

J'avais le meme comportement et j'ai trouvé la parade comme cela
Domoticz 3.7115, raspberry pi3, (raspbian jessie).
rfx433 (Rfxcom) : sonde innovaley, 1wire (DS9490R) : DS2406 & DS18B20, Zwave (Stick G5) : fgms-001,fgsd-002,zw080.

MaveryQ
Messages : 11
Enregistré le : 11 déc. 2017, 21:58

Re: ESPEASY et Domoticz problème de règles

Message par MaveryQ » 12 oct. 2018, 14:01

J'avoue avoir déjà fait tout ce que vous dites.

L'agrandissement, le changement d'ordre des paramètres ... :(
C'est dommage ...

Il me reste à faire :
agrandir la fenêtre, changer l'ordre et après je n'ai plus d'idées ...

Merci

Neutrino
Messages : 1078
Enregistré le : 10 juil. 2015, 15:42
Localisation : Challans (85)

Re: ESPEASY et Domoticz problème de règles

Message par Neutrino » 12 oct. 2018, 20:19

Bonjour,
Vous avez essayé de passer sur une version mega ? https://github.com/letscontrolit/ESPEasy/releases
Ma maison à plein d'IP ! :mrgreen:

Jeff
Messages : 575
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: ESPEASY et Domoticz problème de règles

Message par Jeff » 12 oct. 2018, 20:28

MaveryQ a écrit :
12 oct. 2018, 14:01
J'avoue avoir déjà fait tout ce que vous dites.

L'agrandissement, le changement d'ordre des paramètres ... :(
C'est dommage ...

Il me reste à faire :
agrandir la fenêtre, changer l'ordre et après je n'ai plus d'idées ...

Merci
Il n'y a pas plus frustrant de passer du temps à tester et mettre en oeuvre pour aider et montrer que cela marche :x
Maintenant as tu bien lu mon dernier post avant de poster que cela ne marche pas ? Si c'est le cas et comme le dis Neutrino, passe sur la dernière Mega (C'est la config que j'ai utilisé pour tester et poster mes commandes...
Tiens nous au courant ;)
Version: 3.81.53; KMTronic usb ; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...) DIO ; OREGON/4 THGN/PCR800; DIY/3 temp, Teleinfo usb; RFLink; MYSensors v2.0/GW Lan/Power meter/RGB 3D; ESPeasy Oled, Nextion...

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre