SOnde BME280 et raspberry

les autres capteurs : Sondes Météo, switches
Répondre
samourai47
Messages : 2
Enregistré le : 04 déc. 2018, 19:44

SOnde BME280 et raspberry

Message par samourai47 » 04 déc. 2018, 19:51

Bonjour à tous.
1Er msg car je galère vraiment...
En résumé un raspberry pi 2 sur lequel je tente de monter un peu de domotique. Une carte relai qui fonctionne et une sonde ds1820 egalement

J'ai achete un module bme280. Je le connecte en i2c sur le raspberry et il semble apparaitre en adresse 77. Du coup je tente direct de l'installer sur domoticz mais rien n'apparait en sélectionnant ce module....

Et la je coince.... j'y ai passé la journée sans solution.
Dois je ajouter une script, programme, driver librairie???? sur le raspberry avant de l'inclure dans domoticz?
Si oui lequel et ou trouver de l'aide car je débute aussi en linux.... Bref c'est pas gagné

Merci pour votre aide
samourai47

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


samourai47
Messages : 2
Enregistré le : 04 déc. 2018, 19:44

Re: SOnde BME280 et raspberry

Message par samourai47 » 05 déc. 2018, 09:12

Pour avancer un peu dans la reflexion, mais je sèche toujours... En recopiant des lignes de commande j’obtiens

pi@raspberrypi:~ $ i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- 77

pi@raspberrypi:~ $ dmesg|grep i2c
[ 4.034352] i2c /dev entries driver

Alors que lui fait a priori charger les modules suivant
i2c-dev
i2c-bcm2835
i2c-bcm2708


pi@raspberrypi:~ $ ls /dev/i2c*
/dev/i2c-1

pi@raspberrypi:~ $ ls /dev/i2c-
ls: impossible d'accéder à '/dev/i2c-': Aucun fichier ou dossier de ce type

Là il semble y avoir un truc bizarre non?

Merci pour votre aide

Répondre