Python plugin, pont deCONZ (passelle universelle Zigbee)

L'intégration des autres protocoles dans Domoticz
Thorgal
Messages : 24
Enregistré le : 16 août 2018, 20:02

Re: Python plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal » 13 janv. 2019, 19:26

Yep, c'est mon plugin. Une habitude que j'ai de changer de pseudo a chaque fois.

Error: (DECONZ): Socket Shutdown Error: 9, Bad file descriptor > n'est pas mechant effectivement, vous pouvez l'ignorer.

Par contre votre switch, la je comprend pas. C'est quoi que vous appellez variables ? Il y a vraiment quelques chose qui s'apelle comme ca, et je vois pas le rapport avec votre switch ( Reglages/ plus d'options / Variables utilisateurs).
Les selecteurs peuvent avoir plusieurs valeurs "Niveau"/"Nom du niveau", pour un inter cree avec le plugin, ces valeurs sont B1,B2,B3, ect...
Mais je ne vois pas ce pourrait modifier ces reglages ... Rien qui s'apelle "sound2" dans votre instal ? Un autre plugin qui gererait de l'audio ?

Si c'est un switch cree par le plugin, il te suffit de supprimer le device, et de redemarrer le plugin, il sera recree a neuf. Mais je vois pas ou tu as vu "on" ?

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


omega
Messages : 14
Enregistré le : 04 janv. 2019, 09:55

Re: Python plugin, pont deCONZ (passelle universelle Zigbee)

Message par omega » 13 janv. 2019, 21:06

et bien Bravo Thorgal pour le travail accompli ! et merci
mon interrupteur est déclaré en
DECONZ - Switch 4
type interrupteur :on/off
dans les logs je trouve ces identifiants de position off et sound 2 , va t ' en savoir pourquoi ?
2019-01-13 20:39:44 Off
2019-01-13 20:39:37 Sound 2
2019-01-13 20:39:37 Off
2019-01-13 20:39:35 Sound 2
2019-01-13 20:39:34 Off
2019-01-13 20:39:34 Off
2019-01-13 20:39:31 Sound 2
mais si je comprends bien il faudrait peut être le déclarer en sélecteur ?

Une autre question , lors du démarrage du raspberry il faut attendre un bon moment pour que les fonctions des capteurs soient opérationnelles
deconfz est démarré de façon automatique au lancement de raspbian , par contre le démarrage par défaut est sur le module Raspbee , n 'est ce pas cela qui provoque la lenteur ? , n ' y aurait il un moyen de paramétrer le démarrage sur la clé conbee , celle que je possède , passage des paramètres dans deConz.desktop ? malgré cela le démarrage sur Raspbee semble fonctionner
Bonne Soirée
Bruno

Thorgal
Messages : 24
Enregistré le : 16 août 2018, 20:02

Re: Python plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal » 14 janv. 2019, 16:59

Merci ^^.

Sinon ton inter est vraiment bizarre, ca vient d'ou ca ?
En fait pour eviter de me faire chier avec tout les modeles d'inter possible, je cree un switch generique, c'est toujours le meme, et il a rien avoir avec le tiens.
Pareil tout les logs venant de deconz devrait avoir un truc en plus a cote du timestamps. Ca ne ressemble pas aux logs du plugin.
2019-01-14 16:43:05.556 (deCONZ) ### Update device (deCONZ - lampe ikea) : {'sValue': 'on', 'nValue': 1}
Je suis pas sur que cet inter vienne du plugin (mais avec "DECONZ - Switch 4" comme nom, il est forcement a moi). Tu pourrais pas faire passer les lignes qui apparaissent au demarrage du plugin, au moment de l'initialisation, concernant cet inter. Parce que la je ne vois pas du tout ce que c'est ( Y a un scan des lampes/sensors/groups).
Apres tu as peut etre un autre device avec exactement le meme nom, deCONZ genere parfois plusieurs device pour un seul reel, et celui la serait par exemple l'image de la lampe.

Sinon pour ta seconde question, j'ai rien trouve sur la doc a ce sujet, rien non plus dans les commandes en ligne, donc je ne pense pas que ce soit possible, mais perso a cote du temps que met le raspberry a demarrer, perdre 2/3s au demarrage de deconz, je suis pas sur que ce soit visible, ca met tant de temps que ca a basculer de ton cote ?

Cote plugin, au demarrage, j'attend un "heartbeat", 10s, donc il y a un freeze de 10s avant que le plugin demarre, c'est peut etre plutot ca ton blocage.

omega
Messages : 14
Enregistré le : 04 janv. 2019, 09:55

Re: Python plugin, pont deCONZ (passelle universelle Zigbee)

Message par omega » 15 janv. 2019, 20:13

Bonsoir Thorgal
Pareil tout les logs venant de deconz devrait avoir un truc en plus a cote du timestamps. Ca ne ressemble pas aux logs du plugin.
le log que je montre c 'est celui du menu Interrupteur.
le log du menu réglage est plus complet
2019-01-15 19:53:55.156 (DECONZ) ### Update device (DECONZ - Switch 4) : {'nValue': 0, 'sValue': 'Off'}
Cote plugin, au demarrage, j'attend un "heartbeat", 10s, donc il y a un freeze de 10s avant que le plugin demarre, c'est peut etre plutot ca ton blocage.
le démarrage du raspberry se fait en 35 secondes drconz est également lancé , par contre les actions sur l 'inter ne peuvent se faire qu 'au bout de 8 minutes (l 'inter ne fonctionne qu 'au bout de 8 minutes)
en regardant le log de démarrage j 'ai des erreurs que je vais essayer de résoudre , le problème vient surement de la.
Quand j 'ai acheté la clé conbee je pensai que mon systeme aurait été autonome je ne voulais pas passer par le wifi/Ethernet , hormis pour paramétrer domoticz
mais je m ' aperçois que si je débranche le cable réseau , je n 'ai plus accès aux fonctions des inters
je pensai que le dialogue se faisait directement entre la clef et les capteurs une fois le tout paramétré / apairé.
Peux tu me confirmer qu il faut bien la connexion réseau pour que cela fonctionne ?

Bonne soirée
Bruno

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Thorgal
Messages : 24
Enregistré le : 16 août 2018, 20:02

Re: Python plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal » 16 janv. 2019, 18:38

Nope, ca fonctionne en local, c'est le but du systeme.
Mais il y a un truc louche sur ton inter.
- 8 mn c'est trop long
- C'est pas le modele de swich crée par le plugin
- Pas de sound 2
- Pas besoin du reseau, je viens de restester, ca fonctionne cable debranche et sans wifi.

Tu es sur de ne pas avoir un reliquat d'une ancienne bidouille qui traine sur phoscon ou domoticz ?

Normalement l'inter devrait ressembler a ca.
inter.jpg
inter.jpg (18.62 Kio) Vu 28 fois

omega
Messages : 14
Enregistré le : 04 janv. 2019, 09:55

Re: Python plugin, pont deCONZ (passelle universelle Zigbee)

Message par omega » 16 janv. 2019, 19:46

bonsoir ,
tu me rassures sur le fait que le système peut être autonome , j 'ai du cocher une option genre mise à l 'heure automatique qui appelle le réseau
je vais chercher...
je vais recompiler une installation "propre" , maintenant que je comprend un peu mieux le fonctionnement de Domoticz et deconz
pour cela je vais attendre le weekend car en semaine le travail me prend beaucoup de temps.
d 'ici la j 'espère que j 'aurai reçu mon ampoule ikea et son inter
je te tiendrai informé de mon avancé.
bonne soirée
Bruno

Thorgal
Messages : 24
Enregistré le : 16 août 2018, 20:02

Re: Python plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal » 16 janv. 2019, 22:07

Lol, pas de soucis, je quitte pas le pays non plus.
Perso moi je prefere chercher le pourquoi du comment que tout reinstaller (mes cartes SD sont de vrais poubelles). Enfin bon du coup on ne saura jamais ce qui c'est passe avec cet inter. Et la je t'avoue ca me rend curieux. Tu peux le supprimer dans domoticz, il sera refait a neuf au prochain demarrage du plugin, mais il y a vraiment un truc bizarre qui "vient d'ailleurs", deja rien que le terme "sound 2" ...

Enfin bon, dans tout les cas bne soirée ^^.

omega
Messages : 14
Enregistré le : 04 janv. 2019, 09:55

Re: Python plugin, pont deCONZ (passelle universelle Zigbee)

Message par omega » 17 janv. 2019, 20:56

Bonsoir Thorgal
j 'ai supprimé l 'inter dans Phoscon et domoticz, redémarrer le raspberry , fait une nouvelle recherche de l 'inter dans Phoscom et redémarrer Domoticz
et par merveille l 'inter est reconnu comme dans ton post précédent B1/B2/B3.....
son identité est maintenant B1
en débranchant le câble réseau , l 'inter devient inopérant , il faut que je trouve la solution pourquoi cela coupe le système
au fait , pour poster une image sur le site est on obligé de l ' avoir mis sur un espace dédié de stockage ? j 'ai essayé un copier coller ça ne marche pas !
bonne fin de semaine

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre