Quelle action a déclenché mon device

Vous avez des questions concernant les scripts dans Domoticz, posez vos questions ici, quelque soit le langage nous tenterons des réponses pertinentes ...
Répondre
jpr105
Messages : 8
Enregistré le : 07 juin 2019, 10:59

Quelle action a déclenché mon device

Message par jpr105 »

Bonjour,

Pour mon arrosage automatique j'ai 4 électrovannes correspondant à mes 4 zones d'arrosage.
Chaque électrovanne peut être commandée soit :
  • manuellement via le smartphone
  • pour une durée déterminée via un scénario
  • dans le cadre d'une planification hebdomadaire
Ma question est la suivante :
En procédure dZVents, est-il possible de savoir COMMENT mon électrovanne a été activée ?
Merci d'avance pour votre aide
Cordialement - Jean-Paul

Chrominator
Messages : 692
Enregistré le : 19 déc. 2015, 07:29
Localisation : France

Re: Quelle action a déclenché mon device

Message par Chrominator »

On a maintenant dans l'historique des actionneurs (comme ton électrovanne) l'origine du déclenchement.

exemple :
Screenshot_2021-04-07 Domoticz.png
Screenshot_2021-04-07 Domoticz.png (32.99 Kio) Vu 199 fois
Partir, c’est pourrir un pneu.

Ubuntu 20.04 LTS - Domoticz v2020.2
rfxcom RFXtrx433 USB Version: Pro1/1043
Z-Stick GEN5 Version: 1.6-1136-g07ea22bb
Rtl433 RTL-SDR receiver
RFLink Gateway with LAN interface 48.4

Keros
Messages : 1522
Enregistré le : 23 juil. 2019, 20:57

Re: Quelle action a déclenché mon device

Message par Keros »

Comment est commandée ton électrovanne ? Toutes les commandes passent par DomoticZ ?

Si tu as un script DzVents qui "transforme" les actions en commande, tu peux mettre l'origine de l'action dans un widget texte en même temps que tu passes la commande aux électrovannes. Tu aurais ainsi la dernière action visible et l'historique du widget devrait te lister les différentes actions qui ont été enregistrées (je n'ai pas vérifié qu'il y avait un log pour les widgets texte car je n'ai n'utilise pas).

f-d-m
Messages : 68
Enregistré le : 25 juin 2019, 21:36

Re: Quelle action a déclenché mon device

Message par f-d-m »

Bonjour,

Je vous raconte une expérience vécue avec un Sonoff 4ch Pro dans ma cabane de jardin.
J'avais des allumages intempestifs, toujours le même canal n° 3, à une heure plus ou moins variable, mais heureusement c'était une lampe de jardin et non une vanne d'eau.
J'ai flashé le Sonoff avec Tasmota à la place de ESPeasy.
Ca a continué !
En surveillant en logguant tout ce qui passe au niveau d'un mosquitto_client , il m'a semblé que ce n'était pas Domoticz qui commandait le Sonoff mais le Sonoff qui informait Domoticz du changement d'état.
J'ai fini par mettre en cause la réception RF433 (que je n'utilise pas) où le Sonoff a probablement dû être laissé un jour en mode appairage, et le premier voisin qui a ouvert ses volets ou sa banne s'est appairé avec mon Sonoff.
Il a fallu ouvrir la bête et appuyer sur le bouton ad-hoc.
Le problème est enfin résolu. Sans en avoir la preuve, ça doit être ça...
---
Bruxelles

RPi 3B, Domoticz 2020.2, SSD, PiZigate
IPX-800 V3
multiples Sonoff et similaires (Tasmota, ESPeasy), multiples appareils Zigbee
SMA Sunny Boy 3.6

jpr105
Messages : 8
Enregistré le : 07 juin 2019, 10:59

Re: Quelle action a déclenché mon device

Message par jpr105 »

Keros a écrit : 07 avr. 2021, 18:52 Comment est commandée ton électrovanne ? Toutes les commandes passent par DomoticZ ?

Si tu as un script DzVents qui "transforme" les actions en commande, tu peux mettre l'origine de l'action dans un widget texte en même temps que tu passes la commande aux électrovannes. Tu aurais ainsi la dernière action visible et l'historique du widget devrait te lister les différentes actions qui ont été enregistrées (je n'ai pas vérifié qu'il y avait un log pour les widgets texte car je n'ai n'utilise pas).
Les électrovannes sont pilotées par le GPIO du Raspberry. Elles sont déclarées et gérées dans l'interface Domoticz
Donc 1) déclarées dans scénarios 2) déclarées dans plannings 3) utilisables manuellement

Et en aval je voudrais écrire du code en fonction du type de déclenchement

https://www.dropbox.com/s/sxztob7vxs6b5 ... reenIQ.png

garycooper
Messages : 287
Enregistré le : 07 août 2017, 23:58

Re: Quelle action a déclenché mon device

Message par garycooper »

J'ai également un problème similaire. J'ai réussi à faire le lien, mais je n'arrive pas à comprendre pourquoi ni comment corriger ... J'ai également une ouverture intempestive d'une électrovanne de mon circuit d'arrosage, du coup c'est plutôt emmerdant ... Vu les heures où l'électrovanne s'est ouverte, j'ai pu trouver d'où ça venait.
J'ai un module H801 flashé avec tasmota pour gérér l'éclairage d'un ruban LED derrière ma TV. Pour mon arrosage, j'ai un sonoff 4CH pro flashé avec tasmota qui gère indépendemmant 4 électrovannes. Je me suis rendu compte que lorsque j'allume mon H801, j'ai la première électrovanne qui s'ouvre. Lorsque j'éteinds le H801, l'électrovanne se referme. A l'inverse, lorsque j'actionne l'électrovanne il ne se passe rien sur mon H801. J'ai vérifié les IDX dans la configuration Domoticz de Tasmota des 2 modules et je n'ai pas d'erreur. Je pense à un problème via mosquitto mais pourtant mes 2 modules tasmota ont bien un nom de client différent ... Je suis en version 9.3.1 et il ne me semble pas que j'avais le même problème avec les versions précédentes.

Keros
Messages : 1522
Enregistré le : 23 juil. 2019, 20:57

Re: Quelle action a déclenché mon device

Message par Keros »

En hébergeant les images / documents à l'extérieur du forum, il y a de fort risques qu'ils ne soient plus disponible dans quelque temps comme ici, ou encore .
Merci d'éditer votre message et utiliser l'onglet Fichiers joints en dessous de la zone d'écriture des messages pour enregistrer les éléments sur le serveur du forum.

garycooper
Messages : 287
Enregistré le : 07 août 2017, 23:58

Re: Quelle action a déclenché mon device

Message par garycooper »

En poussant la recherche, je vois que ce n'est que quand j'utilise le bouton On/off du H801 sous domoticz que j'ai ce comportement-là. Lorsque je passe par l'interface web tasmota du H801, ça n'a pas d'effet sur l'électrovanne. Si j'allume le H801 en utilisant la barre de pourcentage, ça n'ouvre pas non plus l'électrovanne.

EDIT : J'ai trouvé, mes deux modules tasmota avaient le même nom de topic MQTT "tasmota" dans la page "configuration MQTT". J'ai mis un nom différent et ça a l'air de fonctionner

Répondre