MyDomoAtHome - ImperiHome

Vous connaissez des applis Android ou Apple sympa, vous avez un problème de config, postez ici
coolplay54
Messages : 85
Enregistré le : 19 juil. 2016, 21:47

Re: MyDomoAtHome - ImperiHome

Message par coolplay54 » 03 oct. 2019, 21:45

j'ai installé HomeHabit, c'est en bêta mais il me convient pour l'instant..
Domoticz sur Pi3B + Rflink gateway

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


samourai47
Messages : 39
Enregistré le : 04 déc. 2018, 19:44

Re: MyDomoAtHome - ImperiHome

Message par samourai47 » 04 oct. 2019, 18:07

en effet pas mal
Simple a installer....

epierre
Messages : 543
Enregistré le : 27 mai 2015, 09:32
Contact :

Re: MyDomoAtHome - ImperiHome

Message par epierre » 06 oct. 2019, 22:24

ok pour buster:

sudo apt-get install nodejs npm

et ça marche très bien ! malgré les :

npm WARN npm npm does not support Node.js v10.15.2
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
npm WARN npm You can find the latest version at https://nodejs.org/
Imperihome & Domoticz: MyDomoAtHome !
eedomus+ - Domoticz - MySensors
zigbee zwave nrf24l rfx

samourai47
Messages : 39
Enregistré le : 04 déc. 2018, 19:44

Re: MyDomoAtHome - ImperiHome

Message par samourai47 » 07 oct. 2019, 08:58

donc je tape ta commande puis je reprends l'install de mdha suivant le tuto sur wiki domoticz?
Par exemple dois je installer ceci?

The following commands install npm and then upgrade it to the latest 2.x version.

sudo npm install -g npm@2.x

Merci

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


epierre
Messages : 543
Enregistré le : 27 mai 2015, 09:32
Contact :

Re: MyDomoAtHome - ImperiHome

Message par epierre » 07 oct. 2019, 09:19

non plus simple, j'ai rajouté une section dans le guide:

On Debian buster :

sudo apt-get install nodejs npm


tu prendras ainsi la dernière disponible de npm, un warning mais ça marche ensuite !

et tu finis par relancer l'install:

sudo apt-get install MyDomoAtHome
Imperihome & Domoticz: MyDomoAtHome !
eedomus+ - Domoticz - MySensors
zigbee zwave nrf24l rfx

samourai47
Messages : 39
Enregistré le : 04 déc. 2018, 19:44

Re: MyDomoAtHome - ImperiHome

Message par samourai47 » 07 oct. 2019, 12:10

Bon moi j'ai beaucoup plus d'errreur. Par contre effectivement domoticz semble s'installer. Mais il ne fonctionne pas. J'ai bien remis le config.json

Je testerai sur une version propre peut etre car sur celle que j'ai j'ai beaucoup bidouille?

pi@raspberrypi:~ $ sudo apt-get install MyDomoAtHome
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Note : sélection de « mydomoathome » au lieu de « MyDomoAtHome »
Les NOUVEAUX paquets suivants seront installés :
mydomoathome
0 mis à jour, 1 nouvellement installés, 0 à enlever et 7 non mis à jour.
Il est nécessaire de prendre 0 o/6 235 ko dans les archives.
Après cette opération, 35,8 Mo d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 144246 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mydomoathome_0.2.39_all.deb ...
/usr/local/bin/forever -> /usr/local/lib/node_modules/forever/bin/forever
+ forever@1.0.0
added 254 packages from 160 contributors in 185.177s
/usr/local/bin/pm2 -> /usr/local/lib/node_modules/pm2/bin/pm2
/usr/local/bin/pm2-dev -> /usr/local/lib/node_modules/pm2/bin/pm2-dev
/usr/local/bin/pm2-docker -> /usr/local/lib/node_modules/pm2/bin/pm2-docker
/usr/local/bin/pm2-runtime -> /usr/local/lib/node_modules/pm2/bin/pm2-runtime
+ pm2@3.5.1
added 318 packages from 231 contributors in 507.329s
Dépaquetage de mydomoathome (0.2.39) ...
Paramétrage de mydomoathome (0.2.39) ...
npm ERR! Linux 4.19.66-v7+
npm ERR! argv "/usr/bin/node" "/usr/local/bin/npm" "rebuild"
npm ERR! node v10.15.2
npm ERR! npm v2.15.12
npm ERR! path /usr/share/mydomoathome/app/node_modules/express/node_modules/send/node_modules/.bi n
npm ERR! code ENOSPC
npm ERR! errno -28
npm ERR! syscall mkdir

npm ERR! nospc ENOSPC: no space left on device, mkdir '/usr/share/mydomoathome/app/node_modules/e xpress/node_modules/send/node_modules/.bin'
npm ERR! nospc This is most likely not a problem with npm itself
npm ERR! nospc and is related to insufficient space on your system.
npm ERR! Linux 4.19.66-v7+
npm ERR! argv "/usr/bin/node" "/usr/local/bin/npm" "rebuild"
npm ERR! node v10.15.2
npm ERR! npm v2.15.12
npm ERR! code ENOSPC
npm ERR! errno -28
npm ERR! syscall write

npm ERR! nospc ENOSPC: no space left on device, write
npm ERR! nospc This is most likely not a problem with npm itself
npm ERR! nospc and is related to insufficient space on your system.
npm ERR! Linux 4.19.66-v7+
npm ERR! argv "/usr/bin/node" "/usr/local/bin/npm" "rebuild"
npm ERR! node v10.15.2
npm ERR! npm v2.15.12
npm ERR! path npm-debug.log.3423083413
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! syscall rename

npm ERR! enoent ENOENT: no such file or directory, rename 'npm-debug.log.3423083413' -> 'npm-debu g.log'
npm ERR! enoent This is most likely not a problem with npm itself
npm ERR! enoent and is related to npm not being able to find a file.
npm ERR! enoent

npm ERR! Please include the following file with any support request:
npm ERR! /usr/share/mydomoathome/app/npm-debug.log
dpkg: erreur de traitement du paquet mydomoathome (--configure) :
installed mydomoathome package post-installation script subprocess returned error exit status 22 8
Traitement des actions différées (« triggers ») pour systemd (241-7~deb10u1+rpi1) ...
Des erreurs ont été rencontrées pendant l'exécution :
mydomoathome
Erreur : Le délai d’attente est dépassé
W: Sources disagree on hashes for supposely identical version '0.2.39' of 'mydomoathome:armhf'.
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@raspberrypi:~ $

epierre
Messages : 543
Enregistré le : 27 mai 2015, 09:32
Contact :

Re: MyDomoAtHome - ImperiHome

Message par epierre » 07 oct. 2019, 13:29

oui tu as un problème: no space left on device

as-tu resizé la carte après installation ?

raspi-config tu as une option pour le faire
Imperihome & Domoticz: MyDomoAtHome !
eedomus+ - Domoticz - MySensors
zigbee zwave nrf24l rfx

samourai47
Messages : 39
Enregistré le : 04 déc. 2018, 19:44

Re: MyDomoAtHome - ImperiHome

Message par samourai47 » 07 oct. 2019, 17:57

Merci pour le coup de main.
Il me semble que j'avais ait cette manip d'extension sur la carte sd
Du coup j'ai relancé l'install, il a mis a jour mdha
et

CA MARCHE!!!!!!!!

Merci beaucoup

coolplay54
Messages : 85
Enregistré le : 19 juil. 2016, 21:47

Re: MyDomoAtHome - ImperiHome

Message par coolplay54 » 07 oct. 2019, 18:41

epierre a écrit :
06 oct. 2019, 22:24
ok pour buster:

sudo apt-get install nodejs npm

et ça marche très bien ! malgré les :

npm WARN npm npm does not support Node.js v10.15.2
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
npm WARN npm You can find the latest version at https://nodejs.org/
Un grand merci, ça refonctionne!!!
Domoticz sur Pi3B + Rflink gateway

epierre
Messages : 543
Enregistré le : 27 mai 2015, 09:32
Contact :

Re: MyDomoAtHome - ImperiHome

Message par epierre » 08 oct. 2019, 09:42

great news !

j'espère que l'on va passer sur un mode stable de nodejs, car certaines distri on node+npm dans le même package, d'autres non c'est encore le bazar... si tout le monde a un buster bien propre je modifierai les dépendances du package !
Imperihome & Domoticz: MyDomoAtHome !
eedomus+ - Domoticz - MySensors
zigbee zwave nrf24l rfx

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre