Jai tout cassé !

Routage de ports, récupération de météo, accès depuis votre smartphone bref tout ce qui permet à Domoticz d'être conecté à Internet se passe ici.
Répondre
freulon9292
Messages : 18
Enregistré le : 03 nov. 2018, 22:53

Jai tout cassé !

Message par freulon9292 » 05 sept. 2019, 22:11

Bonjour,

j'avais une install domoticz qui fonctionnait sur raspbian ... je faisais des petits tests ...
J'ai eu quelques soucis sur mon raspberry (perte d'un disque) .. puis les vacances et le boulot sont passés par là ..

Je reprends aujourd'hui, et je n'accède pas à domoticz. Mon navigateur (en local, ou distant) me renvoi un time out ERR_TIMED_OUT.

pourtant, vu du serveur ...

Code : Tout sélectionner

● domoticz.service - LSB: Home Automation System
   Loaded: loaded (/etc/init.d/domoticz.sh; generated)
   Active: active (running) since Thu 2019-09-05 21:44:54 CEST; 20min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 2784 ExecReload=/etc/init.d/domoticz.sh reload (code=exited, status=0/SUCCESS)
    Tasks: 17 (limit: 2319)
   Memory: 12.5M
   CGroup: /system.slice/domoticz.service
           └─875 /home/pi/domoticz/domoticz -daemon -www 0 -sslwww 9090 -log /tmp/domoticz.txt

sept. 05 21:44:54 raspberrypi domoticz.sh[868]: 2019-09-05 21:44:54.151  Status: Domoticz V4.10717 (c)2012-201
sept. 05 21:44:54 raspberrypi domoticz.sh[868]: 2019-09-05 21:44:54.152  Status: Build Hash: b38b49e5, Date: 2
sept. 05 21:44:54 raspberrypi domoticz.sh[868]: 2019-09-05 21:44:54.152  Status: Startup Path: /home/pi/domoti
sept. 05 21:44:54 raspberrypi domoticz.sh[868]: domoticz: Domoticz is starting up....
sept. 05 21:44:54 raspberrypi domoticz[874]: Domoticz is starting up....
sept. 05 21:44:54 raspberrypi domoticz[875]: Domoticz running...
sept. 05 21:44:54 raspberrypi systemd[1]: Started LSB: Home Automation System.
sept. 05 21:50:37 raspberrypi systemd[1]: Reloading LSB: Home Automation System.
sept. 05 21:50:37 raspberrypi domoticz.sh[2784]: Reloading Domoticz Home Automation System: domoticz.
sept. 05 21:50:37 raspberrypi systemd[1]: Reloaded LSB: Home Automation System.

Code : Tout sélectionner

 netstat -lpt |grep ":9090"
tcp6      37      0 [::]:9090               [::]:*                  LISTEN      875/domoticz    
je tappe bien sur https://192.168.1.3:9090/

et le plus zarb, c'est que je n'ai aucune trace "d'impact" dans mes logs. ni ceux de domoticz, ni syslog, ni apache ... rien.

c'est certainement un truc con, mais je sèche.
Et réinstaller domoticz risque de ne pas solutionner le problème.

Je prends toutes les bonnes idées (et les autre aussi).

Merci.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


frenchyyii
Messages : 294
Enregistré le : 16 oct. 2015, 06:29

Re: Jai tout cassé !

Message par frenchyyii » 05 sept. 2019, 23:40

Mise à jour en ligne de commande, vider le cache du navigateur avant d'aller plus loin.

freulon9292
Messages : 18
Enregistré le : 03 nov. 2018, 22:53

Re: Jai tout cassé !

Message par freulon9292 » 06 sept. 2019, 05:50

:-)

J'ai déjà essayé.
En ligne de commande, je n'ai trouvé que la mise à jour de possible (pas comme un owncloud que l'on peut mettre en maintenance, etc ...)
Et entre les pc local et client, et les navigateurs (ie, mozilla, etc ...) j'ai vidé 5 ou 6 caches différents, et essayé en navigation privée.

Par ailleurs, apache semble fonctionner correctement sur mon raspy (avec owncloud en module, donc, et webtrees en répertoire de /var/www/http) sur :80 et :443

Et pour être complet, j'ai un miniDLNA qui se porte bien également

lost
Messages : 386
Enregistré le : 12 nov. 2016, 11:01

Re: Jai tout cassé !

Message par lost » 06 sept. 2019, 08:39

freulon9292 a écrit :
06 sept. 2019, 05:50

Et entre les pc local et client, et les navigateurs (ie, mozilla, etc ...) j'ai vidé 5 ou 6 caches différents, et essayé en navigation privée.
Ton netstat, s'il est complet, ne montre qu'un listen sur le port (a priori modifié 9090) de Domoticz en IPV6. Et tu te connectes avec une adresse LAN en IPV4.

Un (/sbin/)ifconfig te donnera les deux. Attention, pas dit que ton IPV6 ne soit pas accessible de l'extérieur (attention à la sécurité, mieux vaudrait réserver cela au https) et certains opérateurs ne font pas de loopback (Orange, pour ne pas le nommer, impossible chez eux de tester facilement un site auto-hébergé: Utiliser son mobile, ou connection temporaire via son hotspot wifi et son compte comme si on était dehors).

Voir à tester aussi avec des outils de ping IPV4 et IPV6.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


freulon9292
Messages : 18
Enregistré le : 03 nov. 2018, 22:53

Re: Jai tout cassé !

Message par freulon9292 » 06 sept. 2019, 21:21

Bien vu !!!
le port 90, c'est pour être tranquille.

J'ai suivi les instructions là pour désactiver IPV6...
https://tutox.fr/2017/11/24/desactiver-ipv6-raspberry/


ça marche :

Code : Tout sélectionner

 netstat -lpt |grep ":9090"
tcp        4      0 0.0.0.0:9090            0.0.0.0:*               LISTEN      14582/domoticz      

et hop !
bon, je suis toujours en vrac, avec un écran bleu et/ou domoticz offline

je vois toujours rien apparaître dans les logs quand j'essaie de me connecter.
pourtant, je me donne à fond sur le CTRL+F5
j'ai même vidé le cache complètement.


Code : Tout sélectionner

● domoticz.service - LSB: Home Automation System
   Loaded: loaded (/etc/init.d/domoticz.sh; generated)
   Active: active (running) since Fri 2019-09-06 21:16:25 CEST; 35s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 19130 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/SUCCESS)
    Tasks: 17 (limit: 2319)
   Memory: 15.6M
   CGroup: /system.slice/domoticz.service
           └─19137 /home/pi/domoticz/domoticz -daemon -www 0 -sslwww 9090 -log /tmp/domoticz.txt

sept. 06 21:16:24 raspberrypi systemd[1]: Starting LSB: Home Automation System...
sept. 06 21:16:25 raspberrypi domoticz.sh[19130]: 2019-09-06 21:16:25.145  Status: Domoticz V4.10717 (c)2012-2019 GizMoCuz
sept. 06 21:16:25 raspberrypi domoticz.sh[19130]: 2019-09-06 21:16:25.150  Status: Build Hash: b38b49e5, Date: 2019-05-09 13:04:08
sept. 06 21:16:25 raspberrypi domoticz.sh[19130]: 2019-09-06 21:16:25.152  Status: Startup Path: /home/pi/domoticz/
sept. 06 21:16:25 raspberrypi domoticz.sh[19130]: domoticz: Domoticz is starting up....
sept. 06 21:16:25 raspberrypi domoticz[19136]: Domoticz is starting up....
sept. 06 21:16:25 raspberrypi domoticz[19137]: Domoticz running...
sept. 06 21:16:25 raspberrypi systemd[1]: Started LSB: Home Automation System.

Code : Tout sélectionner

root@raspberrypi:/home/pi# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.3  netmask 255.255.255.0  broadcast 192.168.1.255
        ether b8:27:eb:07:f5:e7  txqueuelen 1000  (Ethernet)
        RX packets 13735335  bytes 1644588585 (1.5 GiB)
        RX errors 30  dropped 1  overruns 0  frame 30
        TX packets 6704704  bytes 501019968 (477.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 711  bytes 314676 (307.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 711  bytes 314676 (307.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

root@raspberrypi:/home/pi# netstat -lptp
Connexions Internet actives (seulement serveurs)
Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat        PID/Program name    
tcp        0      0 0.0.0.0:6144            0.0.0.0:*               LISTEN      19137/domoticz      
tcp        0      0 0.0.0.0:imaps           0.0.0.0:*               LISTEN      404/dovecot         
tcp        3      0 0.0.0.0:9090            0.0.0.0:*               LISTEN      19137/domoticz      
tcp        0      0 localhost:mysql         0.0.0.0:*               LISTEN      583/mysqld          
tcp        0      0 0.0.0.0:5900            0.0.0.0:*               LISTEN      417/vncserver-x11-c 
tcp        0      0 0.0.0.0:imap2           0.0.0.0:*               LISTEN      404/dovecot         
tcp        0      0 0.0.0.0:ssh             0.0.0.0:*               LISTEN      535/sshd            
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      404/dovecot         
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      404/dovecot         
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      535/sshd            
root@raspberrypi:/home/pi# 

les logs :

Code : Tout sélectionner

2019-09-06 21:16:29.293  (zigate) Lost connection, reConn Transport.reConn: Name: 'ZiGate', Transport: 'Serial', Protocol: 'None', Address: '/dev/ttyUSB0', Port: '', Baud: 115200, Bytes: 0, Connected: False, Last Seen: 1970-01-01 01:00:00, Parent: 'None'
2019-09-06 21:16:29.293  Status: (zigate) Connection Name: Zigate, Transport: Serial, Address: /dev/ttyUSB0
2019-09-06 21:16:29.293  (zigate) Connect directive received, action initiation failed.
2019-09-06 21:16:29.294  Error: (zigate) Failed to connect (-1)
2019-09-06 21:16:29.294  (zigate) Transport.reConn: Name: 'ZiGate', Transport: 'Serial', Protocol: 'None', Address: '/dev/ttyUSB0', Port: '', Baud: 115200, Bytes: 0, Connected: False, Last Seen: 1970-01-01 01:00:00, Parent: 'None'
2019-09-06 21:16:29.294  (zigate) Lost connection, reConn Transport.reConn: Name: 'ZiGate', Transport: 'Serial', Protocol: 'None', Address: '/dev/ttyUSB0', Port: '', Baud: 115200, Bytes: 0, Connected: False, Last Seen: 1970-01-01 01:00:00, Parent: 'None'
2019-09-06 21:16:29.294  Status: (zigate) Connection Name: Zigate, Transport: Serial, Address: /dev/ttyUSB0
2019-09-06 21:16:29.295  Error: PluginSystem: Exception processing message.
2019-09-06 21:16:48.450  Error: OpenZWave: Driver Failed!!
2019-09-06 21:17:36.004  Error: zigate hardware (6) thread seems to have ended unexpectedly
2019-09-06 21:17:50.008  Error: zigate hardware (6) thread seems to have ended unexpectedly
-> pas beau, mais aucune trace de trame HTTP.

freulon9292
Messages : 18
Enregistré le : 03 nov. 2018, 22:53

Re: Jai tout cassé ! [résolu]

Message par freulon9292 » 07 sept. 2019, 20:58

Je me répond, et je me dépanne.

J'ai supprimé manuellement la DB, puis relancé domoticz.
Oh ! il démarre et répond en https !

restauration de DB
ça retombe.
Les logs me renvoie des erreurs sur les drivers zigate et zwave.
je resupprime les DB, je relance, je joue la vitesse, je désactive les plugins ...
au 3eme essai, c'est bon.

j'ai pu qu'à refaire mes paramétrages.

Merci pour votre aide.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre