Passer DOMOTICZ en HTTPS

Routage de ports, récupération de météo, accès depuis votre smartphone bref tout ce qui permet à Domoticz d'être conecté à Internet se passe ici.
KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Passer DOMOTICZ en HTTPS

Message par KyloRen » 18 juil. 2018, 13:32

Bonjour à tous,

Je me permets de vous écrire à propos de mon installation DOMOTICZ sur un Raspberry PI 3B.
Tout fonctionne correctement lorsque je me connecte en HTTP://monadresseipdelabox:port_utilisé
Je voudrais à présent établir des connexions en HTTPS...malheureusement, je ne sais pas trop où ça se paramètre dans DOMOTICZ. Quelqu'un de vous l'a-t'il déjà fait ? Si oui, pourriez-vous m'éclairer un peu ? Pour le certificat, je pense passer par letsencrypt.

Merci par avance pour votre aide.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Chrominator
Messages : 409
Enregistré le : 19 déc. 2015, 07:29

Re: Passer DOMOTICZ en HTTPS

Message par Chrominator » 18 juil. 2018, 19:40

Normalement c'est actif par défaut, il faut juste accéder à https://monadresseipdelabox
Le port est implicite avec le protocole https, c'est 443 et par conséquent ce n'est pas la peine de l'indiquer.
Et encore par défaut, Domoticz utilise un certificat auto-signé.

Tu peux utiliser Let'sEncrypt si tu bénéficies d'un nom de domaine pas trop utilisé ; sinon en .free.fr ou .orange.fr ou autrefai.fr, Let'sEncrypt ne te délivrera pas de certificat.

Utilise la recherche ici, il y a tuto sur comment obtenir un certificat signé par Let'sEncrypt.

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 18 juil. 2018, 23:37

Bonsoir,

Merci pour ta réponse. Malheureusement, en https la connexion ne passe pas (en faisant https://ipdemabox) que ce soit depuis un navigateur ou depuis l'appli mobile Domoticz.
N'est-il pas possible que ce soit lié au fait que le protocole HTTPS ne soit pas activé sur mon Domoticz ? Il me semble qu'à l'install de Domoticz on peut dire si on autorise ou non le https.

Merci pour ton aide.

vil1driver
Messages : 5122
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: Passer DOMOTICZ en HTTPS

Message par vil1driver » 18 juil. 2018, 23:52

Salut

Tester déjà en local (ip du raspberry)

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


higgins91
Messages : 384
Enregistré le : 17 nov. 2016, 11:06

Re: Passer DOMOTICZ en HTTPS

Message par higgins91 » 19 juil. 2018, 07:16

vérifie les redirections de port également !

Et détail un peu ton installation (box, routeur, fai...)

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 19 juil. 2018, 12:15

Bonjour à tous,

Merci pour vos réponses.

Voici mon installation :
- Domticz installé sur un raspberry pi 3B
- Un rfxcom est branché sur le raspberry
- Au niveau de ma box, j'ai effectué une redirection de port (le port 443 de ma box est redirigé vers le port 8080 du raspberry)

En vous écrivant, je me demande si c'est pas ma redirection qui est mauvaise...

Merci de me dire ce que vous en pensez !

KyloRen

Chrominator
Messages : 409
Enregistré le : 19 déc. 2015, 07:29

Re: Passer DOMOTICZ en HTTPS

Message par Chrominator » 20 juil. 2018, 00:19

Tu as trouvé, ta redirection n'est pas bonne, tu rediriges un flux https vers le port qui reçoit le flux http non crypté ;
ta redirection entrante sur le port 443 de la box doit impérativement rediriger vers le port correspondant au flux crypté de Domoticz, soit 443 si tu n'as rien changé.

higgins91
Messages : 384
Enregistré le : 17 nov. 2016, 11:06

Re: Passer DOMOTICZ en HTTPS

Message par higgins91 » 20 juil. 2018, 07:53

KyloRen a écrit :Bonjour à tous,

Merci pour vos réponses.

Voici mon installation :
- Domticz installé sur un raspberry pi 3B
- Un rfxcom est branché sur le raspberry
- Au niveau de ma box, j'ai effectué une redirection de port (le port 443 de ma box est redirigé vers le port 8080 du raspberry)

En vous écrivant, je me demande si c'est pas ma redirection qui est mauvaise...

Merci de me dire ce que vous en pensez !

KyloRen
Et tu ne précise pas ton FAI ;) (la config change d'un FAI à l'autre)
Donc la redirection n'est pas bonne comme l'a dit Chrominator!
Un bon conseil, change de suite ton port d'entrée de ton domoticz depuis l'extérieur. Choisi un port "farfelu" du genre 2497 qui est redirigé vers le Pi sur le port 443 en interne. Déjà tu sécurise (un peu) ton installation, les robots scan en permanence les IP sur les ports classiques (80,443,8080...) et cela permet d'avoir plusieurs redirections sur des IP différentes avec le port 443 (si tu as 2Pi avec domoticz par exemple)
tu n'as qu'a rentrer comme adresse par exemple: https://88.45.120.176:2497 pour accéder à domoticz (cette IP est totalement aléatoire :) )

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 20 juil. 2018, 22:49

Bonsoir à tous,

Pour commencer, merci pour vos conseils et réponses.
J'ai fait les modifs nécessaires mais malheureusement ça ne marche pas :( :( :(

Mon install :
- Domoticz sur raspberry pi 3b
- rfxcom branché sur raspberry
- FAI : Orange
- Au niveau de ma box, j'ai effectué une redirection de port : le port 443 de ma box est redirigé vers le port 443 du raspberry (J'ai aussi essayé sur d'autres ports "farfelus" de la box).

Comme je vous l'indiquais, cela ne marche pas. Chose qui est bizarre, lorsque je tape https://adresselocaleduraspberry:443 je n'ai accès à rien.
Est-ce possible que le port 443 du raspberry ne soit pas ouvert ?

Merci à tous pour vos réponses et votre aide.

Cordialement,

KyloRen.

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 26 juil. 2018, 14:11

Bonjour à tous,

Je me permets de relancer le sujet car je suis toujours bloqué avec mes connexions https !
Quelqu'un saurait-il ce qui bloque ?

Même en local, https://iplocale duraspberry ou https://iplocale duraspberry:443 , rien ne fonctionne !
En http, tout est OK.

Merci par avance pour votre aide.

KyloRen.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre