Passer DOMOTICZ en HTTPS

Routage de ports, récupération de météo, accès depuis votre smartphone bref tout ce qui permet à Domoticz d'être conecté à Internet se passe ici.
vil1driver
Messages : 5120
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: Passer DOMOTICZ en HTTPS

Message par vil1driver » 26 juil. 2018, 15:23

C'est bien root qui lance domoticz ?

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


jackslayter
Messages : 941
Enregistré le : 30 sept. 2014, 14:40
Localisation : Isère (38)

Re: Passer DOMOTICZ en HTTPS

Message par jackslayter » 26 juil. 2018, 15:26

dans

Code : Tout sélectionner

/etc/init.d/domoticz.sh
as tu cette ligne

Code : Tout sélectionner

DAEMON_ARGS="$DAEMON_ARGS -sslwww 443"
EXACTEMENT cette phrase !!!

au démarrage de domoticz dans le log as tu "https ssl ..." activé en vert ?
Raspberry Pi + RFLink + Domoticz Beta
Oregon - 3x Thgr122Nx / Chacon - micromodule 200w, télécommande 3b et 16b, 2x module 1000w, détecteur de fumée, contact de porte, 2x prise 3500w / OWL - CM180 / TRC02 v2 RGB 3M / Cheap - PIR, contact de porte

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 26 juil. 2018, 22:06

Bonsoir à tous !

Ci-dessous, mon domoticz.sh :
DAEMON_ARGS="$DAEMON_ARGS -www 8080"
DAEMON_ARGS="$DAEMON_ARGS -sslwww 443"

Au niveau des logs, je ne vois rien du tout sur le HTTPS...

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 26 juil. 2018, 22:29

Ci-dessous, le log au démarrage :
2018-07-26 22:27:02.752 Status: WebServer(HTTP) started on address: :: with port 8080

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 26 juil. 2018, 22:36

Jackslayter, merci je viens de trouver !
Je ne regardais pas le bon domoticz.sh (je n'étais pas dans /etc/init.d/domoticz.sh)

Je vais essayer de le modifier !

Merci encore

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 26 juil. 2018, 22:54

Nouveau problème :( :( :( :( :( :(
Je n'arrive pas à modifier ce domoticz.sh via winscp (problème de droit !!!)

jackslayter
Messages : 941
Enregistré le : 30 sept. 2014, 14:40
Localisation : Isère (38)

Re: Passer DOMOTICZ en HTTPS

Message par jackslayter » 27 juil. 2018, 08:03

il faut le modifier en ssh avec sudo
Raspberry Pi + RFLink + Domoticz Beta
Oregon - 3x Thgr122Nx / Chacon - micromodule 200w, télécommande 3b et 16b, 2x module 1000w, détecteur de fumée, contact de porte, 2x prise 3500w / OWL - CM180 / TRC02 v2 RGB 3M / Cheap - PIR, contact de porte

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 27 juil. 2018, 22:29

Bonsoir,

Bon j'ai fait la modif via sudo nano...
J'ai ensuite redémarrer mon raspberry...et là c'est le drame ! Quand je veux me connecter, j'ai un joli message "DOMOTICZ OFFLINE".

J'avoue que là je suis totalement perdu...

Merci pour votre aide.

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 27 juil. 2018, 22:42

Re,

J'ai trouvé, j'avais fait une boulette !
Maintenant tout marche.

Un grand merci à vous tous pour votre aide.

KyloRen.

KyloRen
Messages : 19
Enregistré le : 14 nov. 2017, 20:27

Re: Passer DOMOTICZ en HTTPS

Message par KyloRen » 27 juil. 2018, 22:48

Bonsoir,

Pour rappel (pour ceux qui tomberont sur ce sujet), il faut modifier le domoticz.sh qui se trouve dans /etc/init.d/

Encore merci à tous !!!

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre