NAT TP Link

Routage de ports, récupération de météo, accès depuis votre smartphone bref tout ce qui permet à Domoticz d'être conecté à Internet se passe ici.
bartras
Messages : 52
Enregistré le : 17 mars 2017, 17:44
Localisation : Saint Etienne (42)

NAT TP Link

Message par bartras » 30 sept. 2018, 09:53

Bonjour à tous,

J'avais une box redbysfr que j'ai remplacé par un routeur 4G TP Link.

J'ai reconfiguré tous mes relais sonoff. Tout fonctionne en local.

Maintenant j'essaye de configurer l'accès via l'application pour pouvoir contrôler depuis l'extérieur.

Quand je rentre l'adresse local tout fonctionne dans l'appli.

Par contre quand je rentre l'IP du routeur avec un port configuré (223) il ne redirige pas vers le port interne (8080)

J'ai pourtant bien configuré le TP Link virtual servers...

Image
Domoticz Version 4.9700
RFXtrx433 ; Sonoff basic ; Sonoff RF ; DANIU 433MHz ; OWL Micro+

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Doume
Messages : 516
Enregistré le : 28 déc. 2014, 10:27
Localisation : Nord (59)
Contact :

Re: NAT TP Link

Message par Doume » 30 sept. 2018, 10:48

Tu essaies de te connecter depuis l'extérieur, ou bien tu essaies d'appeler l'IP publique depuis ton réseau interne ?
Car dans le 2è cas, ça ne peut pas fonctionner....

bartras
Messages : 52
Enregistré le : 17 mars 2017, 17:44
Localisation : Saint Etienne (42)

Re: NAT TP Link

Message par bartras » 30 sept. 2018, 11:14

J'essaye depuis l'extérieur avec mon smartphone et l'appli domoticz.

Je rentre l'adresse IP de mon routeur 4G + le port 223.

Et logiquement je devrais être redirigé vers le raspberry + 8080 = domoticz ?
Domoticz Version 4.9700
RFXtrx433 ; Sonoff basic ; Sonoff RF ; DANIU 433MHz ; OWL Micro+

vil1driver
Messages : 5116
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: NAT TP Link

Message par vil1driver » 30 sept. 2018, 11:28

Salut,

Essai avec un port supérieur à 1024

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


bartras
Messages : 52
Enregistré le : 17 mars 2017, 17:44
Localisation : Saint Etienne (42)

Re: NAT TP Link

Message par bartras » 30 sept. 2018, 12:25

Pas mieux.

J'ai essayé en mettant 1024 et 1040.
Domoticz Version 4.9700
RFXtrx433 ; Sonoff basic ; Sonoff RF ; DANIU 433MHz ; OWL Micro+

Doume
Messages : 516
Enregistré le : 28 déc. 2014, 10:27
Localisation : Nord (59)
Contact :

Re: NAT TP Link

Message par Doume » 30 sept. 2018, 12:43

Il est possible que ton opérateur ne laisse pas passer des ports "exotiques"
Essaie d'utiliser le port 80 (standard HTTP ) redirigé vers 8080 sur le RPi

D'autre part, quand Domoticz détecte que la requête arrive d'une IP non locale (donc autre que 192.168..... ) il attend une authentification (login / password) : As-tu configuré tout cela ?

bartras
Messages : 52
Enregistré le : 17 mars 2017, 17:44
Localisation : Saint Etienne (42)

Re: NAT TP Link

Message par bartras » 30 sept. 2018, 12:54

Je viens d'essayer mais pas mieux...

Voila ce que j'ai quand j'essaye de paramétrer le NAT :

Image

J'avais un mdp et identifiant, je l'ai supprimé dans le doute mais ça ne fonctionne pas mieux.
Domoticz Version 4.9700
RFXtrx433 ; Sonoff basic ; Sonoff RF ; DANIU 433MHz ; OWL Micro+

oredin
Messages : 46
Enregistré le : 31 août 2018, 19:13

Re: NAT TP Link

Message par oredin » 30 sept. 2018, 12:56

Bonjour,

Comment avez-vous déterminer l'adresse public de votre routeur ? Vous avez utilisez un site du type "myip.com" ?

Habituellement, en 4G, les routeurs ne sont pas visibles directement d'Internet. En effet, si vous vérifiez l'@IP de votre routeur (via l'interface d'admin), vous devriez voir qu'il a une adresse privée.
L'@IP publique qui est vue, correspond en fait au routeur du fournisseur d'accès (btel, free, orange, sfr) par lequel transite votre connexion.

J'ai été confronté au même problème lorsque j'ai voulu installé un routeur 4G chez moi. De ce que j'ai pu trouvé, il n'y a pas bcp de solutions.
Soit vous essayez de voir avec votre fournisseur s'il peut vous octroyer une @IP publique mais cela semble compliqué.
Soit vous montez un VPN entre votre routeur et un serveur externe ce qui vous permettra d'accéder à votre routeur 4G via le tunnel VPN.

Bon courage.
Domoticz Beta - ZStickGen5 - RFP1000 - Alexa
433 : Sondes Oregon - Prises Chacon - Sonnette Chacon - VR Somfy RTS
ZW : Modules Qubino - HRT4/ASR

bartras
Messages : 52
Enregistré le : 17 mars 2017, 17:44
Localisation : Saint Etienne (42)

Re: NAT TP Link

Message par bartras » 30 sept. 2018, 13:03

Merci pour les informations, ça me paraît cohérent.

J'ai bien pris sur monip.com...

Sachant que c'est un forfait téléphonique (red 60Go) que j'utilise je ne suis pas certain qu'ils soient enclin à me donner une @ip ?

Peux tu m'en dire plus sur la méthode VPN ? stp
Domoticz Version 4.9700
RFXtrx433 ; Sonoff basic ; Sonoff RF ; DANIU 433MHz ; OWL Micro+

vil1driver
Messages : 5116
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: NAT TP Link

Message par vil1driver » 30 sept. 2018, 13:09

Si Oredin a vu juste, le plus simple est probablement mydomoticz.com

https://www.domoticz.com/wiki/MyDomoticz
(Jamais testé pour ma part)

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre