Configuration port sécurisé

Routage de ports, récupération de météo, accès depuis votre smartphone bref tout ce qui permet à Domoticz d'être conecté à Internet se passe ici.
Répondre
Mimic14
Messages : 1
Enregistré le : 23 nov. 2018, 14:39

Configuration port sécurisé

Message par Mimic14 » 23 nov. 2018, 14:58

Bonjour,

Je suis un petit nouveau dans l'utilisation de domoticz, j'ai fait une petite installation pour gérer mes radiateurs et je pense y ajouter des détecteurs de portes ouvertes etc.

Le système fonctionne bien, ma config est la suivante. Une 4 g Box Bouygues , utilisation de NOIP afin d'avoir une IP fixe , un raspberry , domoticz et un module rflink en 433mhz.

Mon souci est le suivant quand je vais dans le fichier --> etc/init.d/domotiz et/ou le script de /home/pi/domoticz/domoticz.sh
J'ai bien le port 8080 et 443 en sécurisé, j'ai réussi à les changer. Seulement dès que je me connecte avec le 443 mon navigateur (connecté sur le même réseau wifi) me dit qu'il n'est pas sécurisé. De l'extérieur je n'arrive pas à me connecter sur le port 443.

Avant d'aller plus loin dans mon système je voudrais faire quelque chose de sécuriser un peu. Donc quelqu'un peut-il m'aider à comprendre le système de port sécuriser.

Un autre problème, quand je suis chez moi avec mon téléphone je ne peux pas me connecter sur le réseau wifi en passant pas 192.168.1.adresse_ip_rasp:8080 . Sur le pc ça marche mais pas sur le téléphone, je dois me déconnecter du wifi et utiliser l'IP publique (pas pratique quand on ne capte pas).

Si certains souhaitent m'aider merci à eux.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


oredin
Messages : 45
Enregistré le : 31 août 2018, 19:13

Re: Configuration port sécurisé

Message par oredin » 23 nov. 2018, 20:01

Bonjour,

Votre navigateur vous dit que le site n'est pas sécurisé car le certificat SSL par défaut est autosigné, ce qui signifie que, pour votre navigateur, il ne provient pas d'une source fiable.
Si vous ne voulez plus avoir cette alerte, je vous invite à lire ce tutorial (et en particulier la partie 3 traitant du certificat SSL) : https://easydomoticz.com/forum/viewtopic.php?t=4702.

Par contre, il y a une chose que je ne comprends pas très bien. Vous dites ne pas avoir accès à votre DZ depuis l'extérieur mais vous dites être obligé de déconnecter votre téléphone du wifi pour avoir accès à votre DZ. C'est contradictoire.

Avez-vous bien fait la redirection de port sur votre box vers votre serveur DZ ?
Pour ce qui est du problème avec votre téléphone en wifi, aujourd'hui, les box proposent le wifi sur 2 fréquences : 2.4GHz et 5GHz. C'est sensé être transparent mais il arrive que ça pose des problèmes. Quelques pistes :
- Est-ce que votre Pi et votre téléphone sont sur les mêmes fréquences ?
- Est-ce que votre box dispose de paramètres particuliers pour la gestion des fréquences wifi ?
- Lorsque votre téléphone est connecté au wifi, a-t-il une IP sur le même réseau que votre Pi (192.168.1.X) ?

Bon courage !
Domoticz Beta - ZStickGen5 - RFP1000 - Alexa
433 : Sondes Oregon - Prises Chacon - Sonnette Chacon - VR Somfy RTS
ZW : Modules Qubino - HRT4/ASR

Répondre