Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

L'intégration des autres protocoles dans Domoticz
Jasper
Messages : 73
Enregistré le : 20 janv. 2018, 12:14

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Jasper »

Thorgal a écrit :
06 nov. 2019, 18:09
Super exactement ce que je voulais, ça marche. Merci

Jasper
Messages : 73
Enregistré le : 20 janv. 2018, 12:14

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Jasper »

Bonjour
J'ai encore une question précédée d'une remarque. J'ai l'impression que la portée de la Clé ConBee est assez faible. En clair j'ai déporté dans une autre pièce à un autre étage (maison ancienne, murs épais) un Plug Ikea et la couleur du lien a changé vers le jaune dans DeCONZ, le plug ne fonctionnant qu'une fois sur 2 à une demande domoticz. J'ai fait un autre essai avec une led Ikea et son switch remote et la le lien a changé entre le switch et la ConBee pour passer par la led. Mais le switch ne change plus d'état dans domoticz. Donc ma question : Est ce que les leds servent de relais ? et les Plugs ? Sinon comment faire pour étendre son réseau Zigbee, d'autres ConBee ?

Thorgal
Messages : 293
Enregistré le : 16 août 2018, 20:02
Contact :

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal »

Alors pour le probleme de portée, deja le plus simple, c'est de tester le cordon USB pour eloigner la clé. Franchement y en a qui sont passé d'une install qui ne marchait pas du tout a une install sans probleme juste avec ca.

Il y a des appareils qui sont de gros routeurs, a monter sois meme > https://www.zigbee2mqtt.io/how_tos/how_ ... outer.html

Et tout simplement le maillage, tout les appareils alimentés font routeurs (donc lampes et plug oui) , apres certains sont de mauvais routeurs. Pour eux, c'est le top, tu les deplaces, et apres un certains temps le routage se refait tout seul. Pour les appareils a piles, c'est un peu plus dur, il est conseillé de les appairer a l'endroit ou tu as prévu de le mettre.

Par contre je comprend pas
"le lien a changé entre le switch et la ConBee pour passer par la led. Mais le switch ne change plus d'état dans domoticz"

Donc tu as la telecommande qui passe par la lampe pour arriver a la conbee, les connexion sont en vert, mais quand tu appuis dessus rien n'apparait sur domoticz (en activant les logs au pire) ?

Jasper
Messages : 73
Enregistré le : 20 janv. 2018, 12:14

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Jasper »

Thorgal a écrit :
07 nov. 2019, 16:53

Donc tu as la telecommande qui passe par la lampe pour arriver a la conbee, les connexion sont en vert, mais quand tu appuis dessus rien n'apparait sur domoticz (en activant les logs au pire) ?
Oui c'est ça, la télécommande avait une action sur le lampe mais rien sur domoticz. Je dis "avait" car j'ai changé ma config en mettant le raspberry ConBee en wifi et en le plaçant au centre de la maison. J'ai toujours la télécommande reliée à la lampe mais c'est normal car j'ai fait un groupe entre télécommande et lampe, et maintenant quand j'appuie sur télécommande je vois l'état changer dans domoticz. Donc ça me va.
J'ai même essayé de mettre un motion sensor Ikea dehors (pas très loin quand même) et ça marche. C'était le but de tous les changements car je souhaitais mettre un motion sensor IP44 pas cher, Zigbee à piles, et c'est le seul que j'ai trouvé
J’essaierai la rallonge USB pour voir
Merci

Thorgal
Messages : 293
Enregistré le : 16 août 2018, 20:02
Contact :

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal »

Jasper a écrit :
07 nov. 2019, 17:49
Alors j'ai pas suivi ^^.
Je sais pas quand tu dis "relié" si ça veut dire avec une connexion dans deconz, ou "agissant sur". Si tu parles de l'etat de la lampe, ou de la telecommande, ....

Les retours peuvent changer selon le mode d'association de la telecommande, mais dans tout les cas si tu actives les logs, il doit y avoir un truc qui remonte en te servant de la telecommande.

Tu peux avoir la telecommande relié a une prise sur le graphique de deconz, mais agissant sur une lampe. Le graphique de deconz montre juste les connexions reseaux.

Moi j'ai une rallonge USB aussi (50cm), m'en suis encore jamais servi, petit maillage mais qui couvre bien, mais ca a changé la vie de beaucoup de monde pour pas cher.

Thorgal
Messages : 293
Enregistré le : 16 août 2018, 20:02
Contact :

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal »

Ok, so nouvelle version en ligne, avec entre autre

- Meilleur support pour les vannes thermostatique (thx a lot to @salopette) qui est encore en train de tester le code.
- Meilleur support pour les volets roulants
- Pression longue sur telecommande ikea (thx to @bitjeverkeerd)
- Meilleur support pour le materiel legrand (And here I had so much users to help me, @xmillies, @gaz and a big thx to @pipiche again)

Alors pour legrand, pas mal d'informations a lire avant.

- Pour pouvoir les utiliser vous devez avoir au moins la version de deconz > 70, mais cette version est franchement pas terrible, c'est pour ca qu'elle n'apparait pas sur la branche stable, donc pour le moment il vaut mieux attendre sa validation ou meme la V71
- Si vous avez l'interrupteur filaire legrand SANS mise a jour du firmware, il ya une option caché pour desactiver le dimmer, rajoutez juste "NO DIMMER" dans la description du device.
- Ne pas utilser les groupes Zigbee pour les VR pour le moment, mais plutot les scenario dans domoticz (@gaz est dessus en ce moment)
- Legrand ne marche que sur le canal 11.
- La centrale legrand est necessaire pour les MAJ de firmware pour avoir toute les fonctionnalitées.

vince10
Messages : 6
Enregistré le : 17 nov. 2019, 15:15

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par vince10 »

Bonjour sur le plugin deconz j'ai un probleme le log domoticz Error: (deconz) Connexion problem (3) with Gateway, check your API key, or Use Request lib > V2.4.2

j'ai fait la procedure avec le api_key.py et voici le message erreur
avez vous une idée?
merci d'avance

Traceback (most recent call last):
File "/usr/local/lib/python3.5/urllib/request.py", line 1254, in do_open
h.request(req.get_method(), req.selector, req.data, headers)
File "/usr/local/lib/python3.5/http/client.py", line 1106, in request
self._send_request(method, url, body, headers)
File "/usr/local/lib/python3.5/http/client.py", line 1151, in _send_request
self.endheaders(body)
File "/usr/local/lib/python3.5/http/client.py", line 1102, in endheaders
self._send_output(message_body)
File "/usr/local/lib/python3.5/http/client.py", line 934, in _send_output
self.send(msg)
File "/usr/local/lib/python3.5/http/client.py", line 877, in send
self.connect()
File "/usr/local/lib/python3.5/http/client.py", line 849, in connect
(self.host,self.port), self.timeout, self.source_address)
File "/usr/local/lib/python3.5/socket.py", line 711, in create_connection
raise err
File "/usr/local/lib/python3.5/socket.py", line 702, in create_connection
sock.connect(sa)
ConnectionRefusedError: [Errno 111] Connection refused

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "API_KEY.py", line 25, in <module>
response = request.urlopen(req,timeout=3).read()
File "/usr/local/lib/python3.5/urllib/request.py", line 163, in urlopen
return opener.open(url, data, timeout)
File "/usr/local/lib/python3.5/urllib/request.py", line 466, in open
response = self._open(req, data)
File "/usr/local/lib/python3.5/urllib/request.py", line 484, in _open
'_open', req)
File "/usr/local/lib/python3.5/urllib/request.py", line 444, in _call_chain
result = func(*args)
File "/usr/local/lib/python3.5/urllib/request.py", line 1282, in http_open
return self.do_open(http.client.HTTPConnection, req)
File "/usr/local/lib/python3.5/urllib/request.py", line 1256, in do_open
raise URLError(err)
urllib.error.URLError: <urlopen error [Errno 111] Connection refused>

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "API_KEY.py", line 33, in <module>
elif e.code == 403:
AttributeError: 'URLError' object has no attribute 'code'

Thorgal
Messages : 293
Enregistré le : 16 août 2018, 20:02
Contact :

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal »

Salut,

"Connection refused"

Tu utilises quoi comme adresse IP ?
Tu aurais l'url que tu obtiens quand tu es sur phoscon ?

Sinon es tu sur que deconz est en route ?

vince10
Messages : 6
Enregistré le : 17 nov. 2019, 15:15

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par vince10 »

Bnsoir Thorgal

j'ai essayé avec l'adresse ip local du rapsberry ainsi que 127.0.0.1 sur le port 80 meme resultat
J'ai aussi essayé avec et sans le logiciel deconz installé sur le raspberry je vois la passerelle avec le sensor d'associés
mais impossible de faire fonctionné le plugins sous domoticz
loger en root meme resultat
je seche la

Thorgal
Messages : 293
Enregistré le : 16 août 2018, 20:02
Contact :

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal »

Tu es sur d'avoir deconz qui tourne ? Tu dis avoir essayé avec et sans le logiciel deconz, ca ne peut pas fonctionner sans.
Tu as 2 mode possible, le mode avec interface et le mode headless, pour les debutant je conseille le premier mode.

Quand tu lanceras deconz, en haut, a droite, tu vas trouver un bouton "Phoscon app", cliques dessus, ça va t'ouvrir ton navigateur web sur la bonne url et le bon port (en fait c'est l'appli Phoscon, mais c'est presque pareil)

Si tu as domoticz et deconz sur la meme machine, oui, il vaut mieux utiliser 127.0.0.1 comme ip (fonctionne sans routeur).

Pour savoir si deconz fonctionne, dans la console

Code : Tout sélectionner

ps ax | grep deCONZ

Répondre