Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

L'intégration des autres protocoles dans Domoticz
Thierry_06
Messages : 132
Enregistré le : 02 janv. 2017, 11:02
Localisation : Alpes maritimes

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thierry_06 »

Non je n'ai pas changé de version .... je ne sais pas comment on fait

Pour faire tout ce que tu me demandes il faut au moins une journée.
Donc je ferais ca tranquillement la semaine prochaine

Question : Je peux le faire en arrêtant le PI3+ et mettant la clef CONBEE sur un PC ?

Je n'ai pas le GUI . Je communique avec le PI3+ en ligne de commande Putty ou WinSCP

A+
Mon installation Pi3+ OS Raspbian
Zwave, Conbee II, Rfxcom, Sonoff + Esp12, Bluetooth

Thorgal
Messages : 440
Enregistré le : 16 août 2018, 20:02
Contact :

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal »

Question : Je peux le faire en arrêtant le PI3+ et mettant la clef CONBEE sur un PC ?
Ben justement, je me demandais si tu n'avais pas deja fais ca ^^

Alors "oui et non", la configuration n'est pas sur la clé, mais sur la machine. Donc si tu fais ca il te te faut passer par phoscon et sa fonction backup/restauration pour transferer ta database zigbee du raspberry au PC.

Si tu ne tournes pas avec une version headless tu peux aussi utiliser VNC pour avoir accés au GUI.

Sinon, relancer deconz en mode debug avec dbg-error=2 et dbg-info=2 et refaire une inclusion d'une des prises.
Si tu n'as pas modifié ta version de deconz, il n'y a pas de raison pour que les capteurs ne soient pas crées. https://github.com/dresden-elektronik/d ... ebug-flags

Thierry_06
Messages : 132
Enregistré le : 02 janv. 2017, 11:02
Localisation : Alpes maritimes

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thierry_06 »

Jai mis la conbee2 sur un pc au debut mais depuis que j'ai installé ma clef sur mon pi3+ je ne l'ai plus bougé et j'ai installé les prises quand la clef etait sur le pi3+
Mon installation Pi3+ OS Raspbian
Zwave, Conbee II, Rfxcom, Sonoff + Esp12, Bluetooth

Thorgal
Messages : 440
Enregistré le : 16 août 2018, 20:02
Contact :

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal »

Ca m'inquiete ton truc, mais comme je ne vois pas d'issue avec le meme probleme, me dit que ca doit bien avoir une explication.

Edit:
Peut etre un truc du genre a https://github.com/dresden-elektronik/d ... ssues/3788

Thierry_06
Messages : 132
Enregistré le : 02 janv. 2017, 11:02
Localisation : Alpes maritimes

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thierry_06 »

bonsoir

j'ai essayé de sauvegarder et de mettre ma cle conbee2 sur un Pc
J'ia bien tout vu le réseau sur le logiciel deconz . j'ai essayé ré inclure les prises mais rien n'y fait .
je n'ai pas les W et les kWh . Après les 6 prises je les ai supprimées sur deconz , sur domoticz et sur phocon . Réinitialisées et ré incluses . Pas mieux que les prises dans Light et rien dans Capteurs . Il n'y aurait pas un paramètre sur la clé Conbee II qui sélectionnerait les devices à transmettre . 6 fois le même défaut je n'y crois pas.
C'est pas grave les prises étaient là pour remplacer des sonoff qui n'indiquent pas la consommation.
Mon installation Pi3+ OS Raspbian
Zwave, Conbee II, Rfxcom, Sonoff + Esp12, Bluetooth

Thorgal
Messages : 440
Enregistré le : 16 août 2018, 20:02
Contact :

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal »

Ben mon soucis c'est qu'elles aient marchées avant.
La fonction on/off est native, donc le plug apparaitra directement, pour la fonction consommation, l'appareil doit être "whitelisté".
Mais c'est en place dans le code depuis juin, par contre je viens de lire ça dans les issues.
If you have no corresponding sensors in the API, enter sensor search in Phoscon, apply a load to the plug and switch the plug on. That should do the trick.
Peut être ici https://github.com/dresden-elektronik/d ... ssues/3788 , il y en aurait d'autres qui auraient ça. Pour le dernier qui a testé, ça ne marche que la première fois, impossible d'avoir le capteur apres une modification.

Thierry_06
Messages : 132
Enregistré le : 02 janv. 2017, 11:02
Localisation : Alpes maritimes

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thierry_06 »

Je viens d'essayer une reconnaissance de la prise en charge . Non pas de capteur de puissance ni de consommation .
Quand j'aurai le temps je ferai plus de test .

Mais je me rappelle que les 3 premières ont fonctionnés normalement( switch kW et kWh) et après n'ont plus fonctionnés ( uniquement switch ) après les avoir éjectées et réincluse . Donc celles là je veux bien qu'elles soient whitelisées . Mais après j'ai inclus une nouvelle toute neuve sortie de la boite et je n'ai pas pu avoir le kW et kWh . Donc c'est ce qui me fait dire que la passerelle CONBEE II y est peut être pour qq chose .

Peut être la solution faire une sauvegarde de la clef . La réinitialiser et faire un backup de la sauvegarde .
Mon installation Pi3+ OS Raspbian
Zwave, Conbee II, Rfxcom, Sonoff + Esp12, Bluetooth

Thorgal
Messages : 440
Enregistré le : 16 août 2018, 20:02
Contact :

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thorgal »

Non, je ne crois pas, la reinitialisation ne fait pas grand chose, les problemes viennent plutot des bases de données justements. Mais tu as fais les tests sur une machine neuve, donc base de donnée vierge, et meme soucis de mémoire ?

Ca concerne plus deconz que le plugin, mais tu veux vraiment chercher le soucis, il faudrait etre sur du model id et du manufacture number, mais par rapport a tes captures ca a l'air bon.
Le log durant l'inclusion (en demarrant juste avant) serait utile, avec les flags "info" "info_l2" "error" et "error_l2", mais tu vas ete oblige de demarrer deconz en mode debug, il y aura trop de données pour que ce soit lisible directement dans deconz.

Mais manup a commandé du matos tuya pour faire des tests (il y a 9 jours, dans la meme issue), c'est le big boss du projet, franchement si il s y penche, ce sera corrigé, je pense que c'est pour ca que l'issue est en attente.

samourai47
Messages : 183
Enregistré le : 04 déc. 2018, 19:44

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par samourai47 »

Hello
Acheté ce jour une prise connectée Lidl
Integration sous phoscon immediate
Reconnue dans domoticz idem
Ras donc pour le moment
9€99 avec bouton. Mieux que ikea
Merci pour la conbee....

Thierry_06
Messages : 132
Enregistré le : 02 janv. 2017, 11:02
Localisation : Alpes maritimes

Re: Zigbee plugin, pont deCONZ (passelle universelle Zigbee)

Message par Thierry_06 »

Bonsoir

J'ai fait une sauvegarde de la clef Conbee 2
J'ai mis à jour à la dernière version 2.09.01
J'ai rechargé la sauvegarde sur la clef et je n'ai plus rien qui marche.
J'ai toute les 10 secondes le message
2021-02-01 19:58:41.708 Error: (Clef USB Deconz) Wrong startup, retrying !!
2021-02-01 19:58:51.701 Error: (Clef USB Deconz) Wrong startup, retrying !!
:shock:

C'est grave docteur ? ;) Comment puis je m'en dépatouiller .
Mon installation Pi3+ OS Raspbian
Zwave, Conbee II, Rfxcom, Sonoff + Esp12, Bluetooth

Répondre