[Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Vous avez crée un script lua dont vous êtes fier, un .sh génial, un programme python hors du commun, un tuto , c'est ici que vous pouvez les partager.
Soyez précis quant aux prérequis, les manips à faire pour que votre bijou fonctionne (des chmod ?, un apt-get à faire ...)
Décrivez précisément son fonctionnement
Placez votre code entre [Quote] et {/Quote]
mulot35
Messages : 199
Enregistré le : 20 déc. 2014, 00:27

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par mulot35 » 08 févr. 2019, 09:50

Darkneo a écrit :
06 févr. 2019, 20:23
Hello all,

J'ai effectivement l'impression que les statuts du robot sont requêtés via le serveur (hébergé au Canada à priori).

Par contre, j'ai installé le plugin, ajouter le matériel.. Et ça ne fonctionne pas.... (je suis en domoticz 4.9700)

Sur les interrupteurs j'ai un champ alakhon à la place du on/off... J'ai regardé ton plugin.py, mais je ne comprends pas pourquoi la GUI est complètement vautrée... On dirait que c'est la partie

Code : Tout sélectionner

    modeOptions = {
        "LevelActions": "|||",
        "LevelNames": "Off|Auto|Area|Edge|Zigzag",
        "LevelOffHidden": "true",
        "SelectorStyle": "0"
    }
Qui ne s'affiche pas correctement.. J'ai comparé avec un autre plugin que j'utilise (le broadlink), et la synthaxe semble être la même:

Code : Tout sélectionner

            Options =   {   "LevelActions"  :"||||" , 
                            "LevelNames"    :"Off|Learn|Test|Save|Reset" ,
                            "LevelOffHidden":"true",
                            "SelectorStyle" :"0"
                         }   
Mais pas la création de l'interrupteur:
Chez toi:

Code : Tout sélectionner

Domoticz.Device(Name='Mode', Unit=self.modeUnit, TypeName='Selector Switch', Image=iconID, Options=self.modeOptions).Create()
Chez broadlink:

Code : Tout sélectionner

Domoticz.Device(Name="Command",  Unit=1, TypeName="Selector Switch", Switchtype=18, Image=12, Options=Options, Used=1).Create()
Ecart: Switchtype et Used, + double quote versus simple quote. J'essaierai de corriger les valeurs pour voir si cela corrige l'affichage...

Et comme un message dans le fil de discussion, quand je clique sur les boutons (enfin ceux qui sont là), ca ne fait rien... Est ce qu'il faut ajouter autre chose que Python 3.5 pour que ca fonctionne (d'ailleurs est ce que c'est bien python 3.5 qu'il faut)?

Je suis en train de regarder ta trace Wireshark. En gros il y a un protocole de communication TCP qui se fait entre nos robots et le server 47.91.67.181 (j'ai la même requête qui part vers cette ip chez moi)
Les PSH et ACK sont des informations d'envoi/réception d'informations (en gros l'un te dit qu'il l'a bien reçu, l'autre lui qu'il va en renvoyer). le FIN étant la fin de l'échange...

Perso, ca confirme que les différents statuts (batterie etc) ne sont gérés que via des infos TCP qui sont balancées au serveur (en gros le serveur balance une authent à ton robot, et derrière ton robot lui file "régulièrement" les infos).

J'ai pu recontruire (je pense) la communication complète de ton Wireshark. Je peux te dire, par exeple que quand tu as fait ton test, la batterie était à 100% mais qu'elle est tombée à 99%.

Par contre je vais avoir du mal à comparer les trames avec les miennes, j'ai l'impression qu'on n'a pas le même robot (j'ai un 790T). Les versions des firmwares sont différentes (2.4.139(500) chez toi, 1.8.2614(828) chez moi.

Mais je pense que plusieurs éléments dans la trame TCP sont importantes (et don il faudrait limiter la comm'...):
authCode
targetId

Idem ce qui est étrange dans ta trame, c'est que tu n'as ni IP, ni port de configurer dans la trame qui part... Alors que moi j'ai IP et Port...

Edit: Je modifie les infos car je me suis trompé dans le flux de comm'. En vrai ce qu'il "faudrait" faire, c'est balancer un paquet TCP au robot, contenant la même synthaxe que ce que le server canadien lui envoie. Un truc dans ce style là:

Code : Tout sélectionner

{"cmd":0,"control":{"authCode":"authcodedurobot","deviceIp":"","devicePort":"","targetId":"IDdu robot","targetType":"jesaispascequecest"},"seq":0,"value":{"transitCmd":"100"}}
Mon inquiétude, c'est que je pense que l'ip à laquelle les statuts du robots sont renvoyés est "hardcodée" dans le robot (donc les statuts sont renvoyés à 47.91.67.181). Il faudrait faire le test d'envoyer la trame TCP à partir d'une autre IP pour voir si le robot renvoie les infos à l'ip qui a initié la connexion (mais si ca fonctionne, c'est franchement pas du tout sécurisé!!)

Pour le reste du Plugin, si on arrive à débugguer le paquet TCP, ca veut dire qu'on arrivera aussi très certainement à récupérer la cartographie (et donc potentiellement à la stocker pour la réutiliser pour faire du nettoyage de zone). Mais on va pas s'enflammer tout de suite :)
Oui j'arrive aussi a voir l'état de la batterie etc...
1-
Mais je n'arrive pas a extraire ou voir les ordres que le gars du github a trouvé et il parle de protocol udp:
https://github.com/oskarn97/fhem-Prosce ... oscenic.pm
MODE_AUTO => 'AA55A55A09FDE20906000100020500000000', {"clearName":"Auto","clearSign":"clearModel_1"}
MODE_AREA (SPOT)=> 'AA55A55A0AFDE20906000100020400000000', {"clearName":"Spot","clearSign":"clearModel_5"}
MODE_EDGE => 'AA55A55A0BFDE20906000100020300000000', {"clearName":"Edge","clearSign":"clearModel_4"}]
MODE_ZIGZAG => 'AA55A55A0CFDE20906000100020200000000', {"clearName":"Zig-Zag","clearSign":"clearModel_2"}

STOP => 'AA55A55A0DFDE20906000100030000000000',
RUN => 'AA55A55A0DFDE20906000100020000000100',
DOCK => 'AA55A55A0FFDE20906000100010000000000'

Je peut refaire des tests mais il faudrai m'aiguiller sur quoi chercher (=> retrouvé les valeurs si dessus serai un bon debut) sous wireshark. (je suis sur le 811gb et les ordres si dessus fonctionnent par envoie via un sh (page 1))
je peut faire un session "run" puis "mode auto" puis "mode area" puis "mode edge" puis "mode zig zag" puis "dock" voir si on retrouve les fameux codes.
puis je vais essayer ca https://www.domoticz.com/forum/viewtopi ... ks#p113448

2-
Alexa arrive a avoir le status du robot via la skill
"Alexa, demande à clean bot de commencer à nettoyer."
"Alexa, demande à clean bot d'arrêter le nettoyage."
"Alexa, demande à clean bot de commencer à charger."
"Alexa, demande à clean bot de commencer le nettoyage des bords"
"Alexa, demande à clean bot de commencer le nettoyage de la zone"
"Alexa, demande à clean bot le statut"
Modifié en dernier par mulot35 le 11 févr. 2019, 22:37, modifié 1 fois.
Raspi B+ avec Domoticz ,6 Chacon 2300W , 6 Sondes Oregon, 1 Sonde DIY Oregon ds18b20, Téléinfo sur photovoltaique, script backup ftp & anti offline.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Darkneo
Messages : 23
Enregistré le : 16 déc. 2018, 08:50

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par Darkneo » 08 févr. 2019, 11:10

mulot35 a écrit :
08 févr. 2019, 09:50
puis je vais essayer ca https://www.domoticz.com/forum/viewtopi ... ks#p113448
Attention, sur le xiaomi (piste que j'ai aussi essayer de creuser), j'ai l'impression que le comportement est complètement différent (il faut extraire une clé dans la base de données de l'application, utilise la lib python Miio etc). Je ne suis pas sur que ce soit "transposable" pour le Proscenic...

Concernant les commande dans le SH, idem j'ai chercher comment le mec avait récupérer ça, mais j'ai rien trouvé dans wireshark... Il faudrait lui poser la question :)
Mais sur le même principe, dans les trace wireshark, je vois aucun échange de données en UDP vers ton ip....

Dans les fichiers sh de la page 1, tu as changé la valeur To je suppose, mais comment tu l'as récupérer? dnas le targetid de wireshark?

Code : Tout sélectionner

To="01801930aea421f164"
Perso, plus je regarde les trames Wireshark, plus je me dis que la meilleure solution serait du json... en construisant une url de ce type:
http://domoticz-ip<:port>/json.htm?type=command&param=control&authCode="xxx"&deviceIp="yyy"&devicePort="zzz"&targetId="qqq"&targetType="1"

Et pour tes débits d'eau, je pense que l'attribut c'est waterTank :
"60" pour faible
"40" pour moyen
"20" pour fort

qui est passé en seq, et pas en cmd:
seq":0,"value":{"transitCmd":"145","waterTank":"40"}

Je pense que le mode auto c'est :
seq":0,"value":{"transitCmd":"100"}

A Voir si en mode zig zag etc, la valeur de transitCmd change dans la trame wireshark

EDIT: OMG!!! Mais dans le lien que tu m'a filé, on l'a la procédure!!! Installe Packet Sender et balance l'hexa:

Code : Tout sélectionner

30aea4bdfa9488532e2cf2780800450000da469e4000330643c22f5b43b5c0a889054e28b0c53c27c0cd0000219450188600ff1e0000b2000000fa00c8000000000019270000000000007b22636f6e74726f6c223a7b2261757468436f6465223a22353237353331383737222c226465766963654970223a22222c22646576696365506f7274223a22222c227461726765744964223a2234396666663539343465616334336365222c2274617267657454797065223a2233227d2c2276616c7565223a7b227472616e736974436d64223a22313030227d2c2276657273696f6e223a6e756c6c7d0a
sur l'ip port de ton robot en TCP. Si jamais ton robot démarre ca serait chouette (mais c'est pas indutrialisable pour tout le monde)

mulot35
Messages : 199
Enregistré le : 20 déc. 2014, 00:27

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par mulot35 » 11 févr. 2019, 21:08

bon j'arrive pas a trouver meme le run!!!!
pour le To je le sort de la : https://homematic-forum.de/forum/viewtopic.php?t=42845

je regarde avec tPacketCapture (appli mobile sur playstore) ca donne pas mal de truc.

Avec "tPacketCapture" j'ai chopé authcode, appkey, devideid, token, userID,
Raspi B+ avec Domoticz ,6 Chacon 2300W , 6 Sondes Oregon, 1 Sonde DIY Oregon ds18b20, Téléinfo sur photovoltaique, script backup ftp & anti offline.

Darkneo
Messages : 23
Enregistré le : 16 déc. 2018, 08:50

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par Darkneo » 12 févr. 2019, 14:33

mulot35 a écrit :
11 févr. 2019, 21:08
bon j'arrive pas a trouver meme le run!!!!
pour le To je le sort de la : https://homematic-forum.de/forum/viewtopic.php?t=42845

je regarde avec tPacketCapture (appli mobile sur playstore) ca donne pas mal de truc.

Avec "tPacketCapture" j'ai chopé authcode, appkey, devideid, token, userID,
Perso je l'ai fait avec NetCapture sur mon téléphone. Je te confirme qu'au démarrage, il y a 2 trames envoyées. Une certainement pour l'authent dans ce style (sur mon 790T):

Code : Tout sélectionner

{"cmd":0,"control":{"authCode":"xxxx","targetId":"yyyy","targetType":"1"},"seq":0,"value":{"appKey":"12345","deviceId":"09876","deviceType":"3","token":"blabla","userId":"blibli"}}
Le robot répond (avec pas grand chose), puis une autre requête est balancée dans la foulée vers le robot (je suppose pour l'allumer en mode normal):

Code : Tout sélectionner

{"cmd":0,"control":{"authCode":"xxxx","deviceIp":"192.168.1.X","devicePort":"8888","targetId":"yyyy","targetType":"1"},"seq":0,"value":{"transitCmd":"100"}}
Ca coïncide avec les trames de changements de débit serpillère, synthaxées avec des valeurs différentes pour le transitCmd:
"seq":0,"value":{"transitCmd":"145","waterTank":"60"} ==> Modification serpillère débit d'eau faible
"seq":0,"value":{"transitCmd":"145","waterTank":"40"} ==> Modification serpillère débit d'eau moyen
"seq":0,"value":{"transitCmd":"145","waterTank":"20"} ==> Modification serpillère débit d'eau fort

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


mulot35
Messages : 199
Enregistré le : 20 déc. 2014, 00:27

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par mulot35 » 12 févr. 2019, 16:26

Et du coup tu arrive a rebalancer la structure que tu as trouvé ?
Raspi B+ avec Domoticz ,6 Chacon 2300W , 6 Sondes Oregon, 1 Sonde DIY Oregon ds18b20, Téléinfo sur photovoltaique, script backup ftp & anti offline.

Darkneo
Messages : 23
Enregistré le : 16 déc. 2018, 08:50

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par Darkneo » 12 févr. 2019, 21:32

Pour le moment je tatonne... j'essaye avec les commandes json de domoticz mais ca répond pas des masses...

Code : Tout sélectionner

{
   "status" : "ERR"
}
En désespoir de cause j'ai tenté les scripts .sh de la page 1, marche po non plus chez moi (790t pour rappel)

mulot35
Messages : 199
Enregistré le : 20 déc. 2014, 00:27

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par mulot35 » 13 févr. 2019, 08:12

chez moi les scripts fonctionnent bien en modifiant juste l'ip.
Sous windows sous raspberry et sous linux.
Raspi B+ avec Domoticz ,6 Chacon 2300W , 6 Sondes Oregon, 1 Sonde DIY Oregon ds18b20, Téléinfo sur photovoltaique, script backup ftp & anti offline.

Darkneo
Messages : 23
Enregistré le : 16 déc. 2018, 08:50

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par Darkneo » 13 févr. 2019, 09:15

Hello,

oui mais sur le topic initial (trouvé sur Home Assistant), il semble que le nouveau firmware bloque ces fonctions... Les codes avaient été récupérés directement en décompilant l'application (l'ancienne). Je me demande si il ne faudrait pas faire pareil avec la nouvelle...

Et le problème c'est que je ne suis même pas sur de l'ip de mon robot (sur ma box il est indiqué en 192.168.1.1, mais ca me parait bizarre.. Pourtant ca ping bien.

EDIT: J'ai décompilé l'application Proscenic Robotic. Malheureusement, je pense que toutes les informations sont stockées dans des fichiers *.so et *.dll... Donc pas moyen de mettre la main sur le coeur de l'appli... :x

EDIT#2: JE creuse avec les mecs qui avaient fait les DEVs. Il s'étaient basés sur l'ancienne version de l'appli, et confirme que ca ne fonctionne plus avec les nouveaux firmware. Donc on a pas mal galéré, mais on avance plutôt bien. En fait, tout (TOUT!!) est récupéré depuis le serveur maintenant, même les icones! Donc on balance des grands coups de POST HTTP sur le serveur Proscenic, et je pense que j'ai (enfin) réussi à récupérer le statut de mon robot... Mais c'est la super merde!!

Pour faire court: Quand on démarre l'appli, elle envoie en http une requête au serveur http://bl-app-eu.robotbona.com pour s’authentifier. le serveur lui file un cookie (durée de vie de 2 jours) qui lui permet de pouvoir balancer des requêtes à d'autres services sur ce serveur (notamment http://bl-app-eu.robotbona.com/baole-we ... botInfo.do).
Les informations super importantes pour pouvoir s'autenthifier, c'est
nonce_str
appKey
channel
deviceId
deviceType
version=1.5.2 (chez moi)
Une fois qu'on a le cookie (et le session ID), on peut balancer du POST HTTP sur le serveur, en mettant en body:
deviceId
nonce_str
sign

Sign, on le récupère aussi dans les trames http, mais attention il y en a plusieurs, il faut récupérer celle ou la réponse contient les info du robot sur des derniers nettoyages etc...

Comme mon robot esst Offline je peux pas plus avancer pour le moment, mis si certains se sentent de faire le developpement... Car moi je sens que tout va finir en dur dans un .sh aussi :P

mulot35
Messages : 199
Enregistré le : 20 déc. 2014, 00:27

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par mulot35 » 13 févr. 2019, 20:09

Fonctionne et verifier chez moi 811gb provient du github oskarn97

Verif visuel ok
mulot35 a écrit :
12 sept. 2018, 14:50

Stop.sh: AA55A55A0DFDE20906000100030000000000 (oskarn97 https://github.com/oskarn97/fhem-Prosce ... oscenic.pm)

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBERkRFMjA5MDYwMDAxMDAwMzAwMDAwMDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.99/10684
run.sh: AA55A55A0DFDE20906000100020000000100 (oskarn97 https://github.com/oskarn97/fhem-Prosce ... oscenic.pm)

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBERkRFMjA5MDYwMDAxMDAwMjAwMDAwMDAxMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.99/10684
dock.sh: AA55A55A0FFDE20906000100010000000000 (oskarn97 https://github.com/oskarn97/fhem-Prosce ... oscenic.pm)

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBGRkRFMjA5MDYwMDAxMDAwMTAwMDAwMDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.99/10684
Verif via appli:
mode_auto.sh: AA55A55A09FDE20906000100020500000000 (oskarn97 https://github.com/oskarn97/fhem-Prosce ... oscenic.pm)

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTA5RkRFMjA5MDYwMDAxMDAwMjA1MDAwMDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.99/10684
mode_area.sh (Spot): AA55A55A0AFDE20906000100020400000000 (oskarn97 https://github.com/oskarn97/fhem-Prosce ... oscenic.pm)

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBBRkRFMjA5MDYwMDAxMDAwMjA0MDAwMDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.99/10684
mode_edge.sh: AA55A55A0BFDE20906000100020300000000 (oskarn97 https://github.com/oskarn97/fhem-Prosce ... oscenic.pm)

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBCRkRFMjA5MDYwMDAxMDAwMjAzMDAwMDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.99/10684
mode_zigzag.sh: AA55A55A0CFDE20906000100020200000000 (oskarn97 https://github.com/oskarn97/fhem-Prosce ... oscenic.pm)

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBDRkRFMjA5MDYwMDAxMDAwMjAyMDAwMDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.99/10684

Test du Py de ton lien: https://community.home-assistant.io/t/p ... tion/82969 via http://hristoatanasov.com/proscenic.py

Les 7 commandes suivante fonctionne sur mon 811GB

'MOVE_BACKWARD': "AA55A55A0BFDE20906000100030000020000",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBCRkRFMjA5MDYwMDAxMDAwMzAwMDAwMjAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
'MOVE_FORWARD': "AA55A55A0CFDE20906000100030000010000",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBDRkRFMjA5MDYwMDAxMDAwMzAwMDAwMTAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
'MOVE_LEFT': "AA55A55A0AFDE20906000100030000030000",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBBRkRFMjA5MDYwMDAxMDAwMzAwMDAwMzAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
'MOVE_RIGHT': "AA55A55A09FDE20906000100030000040000",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTA5RkRFMjA5MDYwMDAxMDAwMzAwMDAwNDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
'MOVE_STOP': "AA55A55A08FDE20906000100030000050000",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTA4RkRFMjA5MDYwMDAxMDAwMzAwMDAwNTAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
'VOICE_OFF': "AA55A55A0BFDE20906000100040000000001",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBCRkRFMjA5MDYwMDAxMDAwNDAwMDAwMDAwMDE8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
'VOICE_ON': "AA55A55A0AFDE20906000100040000000002",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBBRkRFMjA5MDYwMDAxMDAwNDAwMDAwMDAwMDI8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
LES 3 WIND éteignent mon aspi:

'WIND_HIGH': "AA55A55A0AFDE20906000100030003000000",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBBRkRFMjA5MDYwMDAxMDAwMzAwMDMwMDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
'WIND_NORMAL': "AA55A55A0BFDE20906000100030002000000",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBCRkRFMjA5MDYwMDAxMDAwMzAwMDIwMDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
'WIND_OFF': "AA55A55A0CFDE20906000100030001000000",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTBDRkRFMjA5MDYwMDAxMDAwMzAwMDEwMDAwMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
LES 2 QUERY ne font rien sous l'utilisation standard

'QUERY_ORDER': "AA55A55A28FDD20700000100",

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTI4RkREMjA3MDAwMDAxMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
'QUERY_STATE': "AA55A55A17FDE10900000100"

Code : Tout sélectionner

#!/bin/bash

echo "<HEADER MsgType="MSG_TRANSIT_SHAS_REQ" MsgSeq="1" From="02000000000000000" To="01801930aea421f164" Keep="1"/><BODY>PFRSQU5TSVRfSU5GTz48Q09NTUFORD5ST0JPVF9DTUQ8L0NPTU1BTkQ+PFJUVT5BQTU1QTU1QTE3RkRFMTA5MDAwMDAxMDA8L1JUVT48L1RSQU5TSVRfSU5GTz4=</BODY></MESSAGE>\r\n\r\n" >/dev/udp/192.168.1.69/10684
Raspi B+ avec Domoticz ,6 Chacon 2300W , 6 Sondes Oregon, 1 Sonde DIY Oregon ds18b20, Téléinfo sur photovoltaique, script backup ftp & anti offline.

Darkneo
Messages : 23
Enregistré le : 16 déc. 2018, 08:50

Re: [Inclusion]Robot Aspi/laveur Proscenic 811gb 790T demande aide pour Wireshark en cours

Message par Darkneo » 14 févr. 2019, 08:41

Ben les area devraient fonctionner aussi alors... Moi c'est mort, aucune commande de ne passe.... :(

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre