Problème remonte my sensors (résolu)

Un forum dédie à vos questions concernant l'intégration à Domoticz des capteurs et gateway mysensors.org
Répondre
cedpic
Messages : 5
Enregistré le : 17 déc. 2018, 22:42
Localisation : 95400

Problème remonte my sensors (résolu)

Message par cedpic » 17 déc. 2018, 23:05

Bonjour ,

Amateur d électronique , travaillant dans les milieux de la sécurité électronique je suis parti sur une phase qui devait être uniquement un test et qui se développe en durable ,après avoir essayer les capteurs sur un ESP8266 j ai décidé de passer par le principe de my sensors qui s intégrera plus facilement à mon projet gestion du chauffeur ,des ouvrants (remonte fenêtre /porte ouverte ) pour stopper le chauffage etc.....

Je suis sur un serveur ubunut 18.04 avec Domoticz (la bdd sera migrer sur un Raspberry quand tout sera ok ) une passerelle my sensors wifi
.

Ma passerelle est composé d un ESP8266 mode ncu 1.0 , un nrf24l01 avec Condo de 10 micro farad,version my sensors 2.3.1 toute librairie en derniers version compilation ok et reconnu dans Domoticz
Le sensors sur un nano nrf24l01 avec Condo de 10 micro farad,version my sensors 2.3.1, sonde D18b20

J utilise pour la gateway et le sensors le sketch de my sensors avec la modification pour la déclaration du nrf24

Le noeud ne remonte pas sauf si je le déclare manuellement dans le sketchs
Le sensor ne remonte pas du tout même après avoir tourné 24h y a t il dés modifications faire ou dés rajout dans le sketch.

Dans le moniteur serial je vois bien un discutions entre la gateway et le sensors mais j ai l impression que la déclaration du sensors ne ce fait pas .


Avec vous des pistes à suivre ou des modifications à faire afin d avances
Modifié en dernier par cedpic le 19 déc. 2018, 01:56, modifié 1 fois.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


digdogger
Messages : 213
Enregistré le : 16 juil. 2017, 09:21

Re: Problème remonte my sensors

Message par digdogger » 18 déc. 2018, 19:13

Salut,
tu as activé les logs Mysensors?
Ta température, tu peux l'envoyer sur le port série et l'afficher?

Voici la procédure de dépannage Mysensors si çà peut aider:

Image
Raspberry Pi 3 + Raspbian Jessie Lite + Domoticz V4.9700 - RFlink USB V48 433.42MHz - Volets Somfy RTS - MySensors USB V2.1.1 - IDE Arduino 1.8.8

cedpic
Messages : 5
Enregistré le : 17 déc. 2018, 22:42
Localisation : 95400

Re: Problème remonte my sensors

Message par cedpic » 18 déc. 2018, 19:21

Bonjour,

Merci pour ton retour, dans le debug ne remonte pas la température, je fais regarde cela ce soir avec le diagramme et aussi en ayant changer mes alimentations.

cedpic
Messages : 5
Enregistré le : 17 déc. 2018, 22:42
Localisation : 95400

Re: Problème remonte my sensors

Message par cedpic » 18 déc. 2018, 23:47

Merci pour le tableaux , j ai pu avancer un peu .
mais reste bloquer j ai l impression que le fils du sensors ne se creaient pas ma sonde est OK teste sur un autre montage mais que le dialogue semble OK dois je cherhcer cote alimententation ou cote condensateur sur l emetteur /recepteur


log Domoticz :
2018-12-18 23:18:46.031 Status: EventSystem: reset all events...
2018-12-18 23:18:46.550 Status: PluginSystem: Started, Python version '3.6.7'.
2018-12-18 23:18:46.678 Status: WebServer(HTTP) started on address: :: with port 8080
2018-12-18 23:18:46.748 Status: WebServer(SSL) started on address: :: with port 443
2018-12-18 23:18:46.749 Status: Proxymanager started.
2018-12-18 23:18:46.749 Status: TCPServer: shared server started...
2018-12-18 23:18:46.749 Status: RxQueue: queue worker started...
2018-12-18 23:18:48.866 MySensors: Gateway Ready...
2018-12-18 23:18:48.917 MySensors: Gateway Version: 2.3.1
2018-12-18 23:18:48.956 MySensors: Gateway Version: 2.3.1
2018-12-18 23:18:48.508 Status: Incoming connection from: 192.168.1.6
2018-12-18 23:18:48.750 Status: MySensors: trying to connect to: 192.168.1.103:5003
2018-12-18 23:18:48.750 Status: EventSystem: reset all events...
2018-12-18 23:18:48.751 Status: EventSystem: reset all device statuses...
2018-12-18 23:18:48.828 Status: MySensors: connected to: 192.168.1.103:5003
2018-12-18 23:18:49.053 Status: PluginSystem: Entering work loop.
2018-12-18 23:18:49.232 Status: Python EventSystem: Initalizing event module.
2018-12-18 23:18:49.232 Status: EventSystem: Started
2018-12-18 23:18:49.232 Status: EventSystem: Queue thread started...
2018-12-18 23:24:06.323 Status: New sensors allowed for 5 minutes...
2018-12-18 23:24:36.419 Status: MySensors: Node: 1, Sketch Name: Temperature Sensor
2018-12-18 23:24:36.483 Status: MySensors: Node: 1, Sketch Version: 1.1


Log Gateway
107 TSF:LRT:OK
123 TSM:INIT
137 TSF:WUR:MS=0
161 TSM:INIT:TSP OK
scandone
state: 0 -> 2 (b0)
state: 2 -> 3 (0)
state: 3 -> 5 (10)
add 0
aid 2
cnt
267 TSM:INIT:GW MODE
290 TSM:READY:ID=0,PAR=0,DIS=0

connected with Domocedpic, channel 1
dhcp client start...
ip:192.168.1.51,mask:255.255.255.0,gw:192.168.1.1
436 MCO:REG:NOT NEEDED
463 TSM:READY:NWD REQ
522 TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
scandone
963 GWT:TIN:CONNECTING...
990 GWT:TIN:IP: 192.168.1.103
1022 MCO:BGN:STP
1040 MCO:BGN:INIT OK,TSP=1
pm open,type:2 0
44554 TSF:MSG:READ,1-1-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
44612 TSF:MSG:BC
44630 TSF:MSG:FPAR REQ,ID=1
44660 TSF:PNG:SEND,TO=0
44685 TSF:CKU:OK
44703 TSF:MSG:GWL OK
45424 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
46612 TSF:MSG:READ,1-1-0,s=255,c=3,t=24,pt=1,l=1,sg=0:1
46671 TSF:MSG:PINGED,ID=1,HP=1
46710 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=OK:1
46783 TSF:MSG:READ,1-1-0,s=255,c=3,t=15,pt=6,l=2,sg=0:0100
46847 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
46922 TSF:MSG:READ,1-1-0,s=255,c=0,t=17,pt=0,l=5,sg=0:2.3.1
46986 TSF:MSG:READ,1-1-0,s=255,c=3,t=6,pt=1,l=1,sg=0:0
48872 TSF:MSG:READ,1-1-0,s=255,c=3,t=11,pt=0,l=18,sg=0:Temperature Sensor
48950 TSF:MSG:READ,1-1-0,s=255,c=3,t=12,pt=0,l=3,sg=0:1.1
49012 TSF:MSG:READ,1-1-0,s=255,c=3,t=26,pt=1,l=1,sg=0:2
49082 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=OK:1

Log Sensor:

16 MCO:BGN:INIT NODE,CP=RNNNA---,REL=255,VER=2.3.1
26 MCO:BGN:BFR
27 TSM:INIT
29 TSF:WUR:MS=0
35 TSM:INIT:TSP OK
37 TSM:INIT:STATID=1
39 TSF:SID:OK,ID=1
40 TSM:FPAR
77 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
912 TSF:MSG:READ,0-0-1,s=255,c=3,t=8,pt=1,l=1,sg=0:0
917 TSF:MSG:FPAR OK,ID=0,D=1
2084 TSM:FPAR:OK
2085 TSM:ID
2086 TSM:ID:OK
2088 TSM:UPL
2100 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=OK:1
2197 TSF:MSG:READ,0-0-1,s=255,c=3,t=25,pt=1,l=1,sg=0:1
2202 TSF:MSG:PONG RECV,HP=1
2204 TSM:UPL:OK
2206 TSM:READY:ID=1,PAR=0,DIS=1
2210 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
2333 TSF:MSG:READ,0-0-1,s=255,c=3,t=15,pt=6,l=2,sg=0:0100
2340 TSF:MSG:SEND,1-1-0-0,s=255,c=0,t=17,pt=0,l=5,sg=0,ft=0,st=OK:2.3.1
2349 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=6,pt=1,l=1,sg=0,ft=0,st=OK:0
4357 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=11,pt=0,l=18,sg=0,ft=0,st=OK:Temperature Sensor
4375 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=12,pt=0,l=3,sg=0,ft=0,st=OK:1.1
4382 MCO:REG:REQ
4385 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=26,pt=1,l=1,sg=0,ft=0,st=OK:2
4566 TSF:MSG:READ,0-0-1,s=255,c=3,t=27,pt=1,l=1,sg=0:1
4571 MCO:PIM:NODE REG=1
4574 MCO:BGN:STP
4575 MCO:BGN:INIT OK,TSP=1
4579 MCO:SLP:MS=94,SMS=0,I1=255,M1=255,I2=255,M2=255
4584 TSF:TDI:TSL
4585 MCO:SLP:WUP=-1
4587 TSF:TRI:TSB
4593 MCO:SLP:MS=30000,SMS=0,I1=255,M1=255,I2=255,M2=255
4598 TSF:TDI:TSL
Modifié en dernier par cedpic le 19 déc. 2018, 00:09, modifié 1 fois.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


domdom
Messages : 62
Enregistré le : 20 mai 2016, 10:48
Localisation : Ille-et-Vilaine

Re: Problème remonte my sensors

Message par domdom » 19 déc. 2018, 00:02

Bonsoir,

Ca m'a l'air de plutôt bien fonctionner au niveau des traces, même si je n'ai jamais expérimenté le nrf24 (je fonctionne avec des rfm69).

Sans trop rentrer dans les détails, un noeud mysensors envoie, au démarrage, son nom et son numéro de version, on voit que la gateway les a bien reçus :
2018-12-18 23:24:36.419 Status: MySensors: Node: 1, Sketch Name: Temperature Sensor
2018-12-18 23:24:36.483 Status: MySensors: Node: 1, Sketch Version: 1.1

Ensuite, le noeud doit déclarer chaque "voie" qui peut être un capteur ou un actionneur. Là, on devrait voir une trace dans les logs de domoticz. MAIS il est possible que ce soit normal, car je crois me souvenir que domoticz n'affiche un log correspondant à ce message que la première fois que le noeud apparaît. Pour s'en assurer, essaie de changer l'ID du noeud dans ton code arduino et regarde les traces.

Après, je crois me souvenir que domoticz gère mal les noeuds tant que ceux-ci n'ont pas remonté une mesure. Il est possible que ton capteur de température fonctionne mal (absence de la résistance de pullup ?) et que du coup, aucune valeur de température ne soit envoyée par le capteur.

Dans un 1er temps, je te suggère de mettre une valeur en dur dans ton code arduino, l'envoyer régulièrement (genre chaque seconde) et voir ce qui se passe dans domoticz. En espérant que ça te décoince.

Bon courage

dom

cedpic
Messages : 5
Enregistré le : 17 déc. 2018, 22:42
Localisation : 95400

Re: Problème remonte my sensors

Message par cedpic » 19 déc. 2018, 01:46

Merci Dom , suite a ton message par soucis de tranquilte j ai changer pour un sketch avec un BP qui ne remontais pas non plus ,suite a cela j ai entree en dur le numero de child et la par miracle cela a presque fonctionner car mon child remontais mais pas mes changements d'etats

J ai donc changer de pin et de numero de child afin d etre a l identique child -> pin et tout est OK que ce soit en bp ou avec sonde de temperature .
Breadbord defaillante .

Apres bizarrement la declaration NODE et Child ne sont pas automatique mais cela ne me derange pas e pas .

Tout est fonctionnel je passe en resolu .

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre