DHT22, pas de données dans ESPeasy

Vos échanges, bricolages, idées et questions concernant l'ESP8266, les NodeMCU,Weemos, et consort
Répondre
thom
Messages : 52
Enregistré le : 29 sept. 2015, 03:12
Localisation : Montréal

DHT22, pas de données dans ESPeasy

Message par thom »

Bonjour,

J'ai un Wemos R1 D2 avec un Adafruit Motorshield v2 qui fait fonctionner un moteur pas à pas Nema 17 et un relais. J'aimerai rajouter une sonde DHT22 ou DHT11, sur cette même carte, J'ai essayé a plusieurs reprises DHT11, DHT22 avec un peu près tous les GPIO disponibles, mais aucune données ne remontent... "NAN"

Tout ça est pour l'automatisation d'un poulailler. Capteur de température pour déclencher la lampe chauffante par le relais et moteur pas à pas pour ouvrir et fermer la porte.
ESP_Easy_mega-20190508_dev_ESP8266_4M.bin
j'ai installé ce binaire sur le Wemos.

Si quelqu'un a une idée...
Capture d’écran, le 2019-05-10 à 14.56.52.png
Capture d’écran, le 2019-05-10 à 14.56.52.png (54.12 Kio) Vu 1225 fois
Raspberry 2B Seafile et NAS
Raspberry 2B MotioneyeOS
Raspberry 3 Domoticz avec Zwave et Mysensors

Jeff
Messages : 772
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: DHT22, pas de données dans ESPeasy

Message par Jeff »

Le Nan est généralement un mauvais branchement.
On peut avoir une photo ou une explication !
As tu mis la résistance de 4.7k entre la DHT et la carte ?
Si tu souhaites communiquer avec Dz, il faut renseigner le idx virtuel de domoticz et cocher la case " send to controller"
Version: 4.9700; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...), Zigbee2MQTT.

thom
Messages : 52
Enregistré le : 29 sept. 2015, 03:12
Localisation : Montréal

Re: DHT22, pas de données dans ESPeasy

Message par thom »

Voici le montage complet, le tout alimenté par du 12V sur le wemos d1 r2.
Le relais fonctionne ainsi que le moteur qui devient chaud. Peut être pas assez d'ampere au niveau de l'alimentation 1A Max.

l'idx est bien renseigné dans domoticz, il affiche 0° et 50% et NAN sur le serveur web espeasy...

J'ai le meme resulat avec alimentation séparé pour Wemos 5v et motorshield 12v

IMG_1962.jpg
IMG_1962.jpg (494.4 Kio) Vu 1215 fois
Raspberry 2B Seafile et NAS
Raspberry 2B MotioneyeOS
Raspberry 3 Domoticz avec Zwave et Mysensors

Jeff
Messages : 772
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: DHT22, pas de données dans ESPeasy

Message par Jeff »

Je ne vois pas ton wemos d1 r2, il doit être sous ton shield motor...pas d'importance.
Il faut du 5v pour une dht, pas du 3v.
Version: 4.9700; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...), Zigbee2MQTT.

fking
Messages : 143
Enregistré le : 03 nov. 2017, 10:19
Localisation : Liverdun (54)
Contact :

Re: DHT22, pas de données dans ESPeasy

Message par fking »

NaN = Not an Number, le capteur ne retourne rien de valable.

Ça arrive avec les DHT. Essaie de débrancher le DHT, mettre le montage sous tension et rebrancher le DHT. Chez moi ça fonctionnait, mais j'ai abandonné les DHT au profit de BME280
Fais le ou ne le fais pas , essayer ne veut rien dire.

thom
Messages : 52
Enregistré le : 29 sept. 2015, 03:12
Localisation : Montréal

Re: DHT22, pas de données dans ESPeasy

Message par thom »

Finalement, j'ai pris 2 D1 pour le montage.

1. DHT et relais pour le contrôle de la lampe chauffante
2. Adafruit motorshield v2 pour le moteur Nema 17 pour l'ouverture de la porte.

Tout fonctionne, par contre je vais devoir implanter un script qui envoi la commande "release" pour pas que le moteur ne chauffe trop...

Autre question en passant: Je devrais etre capable d'alimenter le 2ème D! avec le 1er D1 (sur le adafruit Motorshield)? mais si je connecte "vin et ground" le deuxieme D! n'a pas l'air de bien réagir, le relais se met a clignoter et les données ne remontent pas dans Domoticz...

Voilà il me reste a faire le treuil pour relever la porte et mes poules seront a l'abri des prédateurs et du froid. :D
IMG_1990.jpg
IMG_1990.jpg (428.26 Kio) Vu 1149 fois
Raspberry 2B Seafile et NAS
Raspberry 2B MotioneyeOS
Raspberry 3 Domoticz avec Zwave et Mysensors

Répondre