Problème avec les rules ESPEasy

Vos échanges, bricolages, idées et questions concernant l'ESP8266, les NodeMCU,Weemos, et consort
Répondre
fking
Messages : 137
Enregistré le : 03 nov. 2017, 10:19
Localisation : Liverdun (54)
Contact :

Problème avec les rules ESPEasy

Message par fking » 28 déc. 2019, 14:52

Bonjour,
J'ai un certain nombre de Sonoff Wifi flashés en ESPEasy qui contrôlent le chauffage et éclairage. Je voudrais qu'en cas de coupure secteur, tout soit à OFF, pour des raisons de sécurité.
J'ai créé la rule suivante :

on System#Boot do
gpio,12,0
endon

Elle ne fonctionne pas, quand je coupe le 220 et que je le remets, le Sonoff se met systématiquement à On.

Merci de votre aide.
Fais le ou ne le fais pas , essayer ne veut rien dire.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Keros
Messages : 66
Enregistré le : 23 juil. 2019, 20:57

Re: Problème avec les rules ESPEasy

Message par Keros » 28 déc. 2019, 23:15

Tiens il me semble que mes Sonoff restent à off quand je les branche.

Tu as essayé la config par défaut de l'ESPEasy ?
DomoticZ sur Raspb 3B+ avec : Zigate Wifi (Xiaomi : température & inondation + bouton) & Relayborad GPIO (6 relais) & Téléinfo (Linky par USB) & Notification par SMS (SMS Gateway Ultimate) & RFLink (Relais SF) & Sonoff (ESP Easy)

fking
Messages : 137
Enregistré le : 03 nov. 2017, 10:19
Localisation : Liverdun (54)
Contact :

Re: Problème avec les rules ESPEasy

Message par fking » 31 déc. 2019, 11:00

Oui, ça fait pareil, d'où mon idée de mettre les rules pour forcer l'état bas.
Fais le ou ne le fais pas , essayer ne veut rien dire.

e111111
Messages : 79
Enregistré le : 11 déc. 2018, 19:44

Re: Problème avec les rules ESPEasy

Message par e111111 » 03 janv. 2020, 07:47

Salut,
Peux-tu essayer un autre GPIO ?
L'ESP est assez spécifique sur certaines pins, c'est assez bien documenté sur les sites dédiés, certains GPIO ne peuvent servir à ci ou à ça, ou pas dans certains cas ...

Pour ce qui est du 12, il me semble qu'au boot il passe par un état haut pendant 300 à 500 ms puis repasse à l'état bas.

Si tu ne peux pas changer de GPIO, une petite ruse électronique s'impose pour bypasser ce problème.

Maintenant, je ne sais pas trop comment c'est fichu dans le sonoff, peut-être n'est-il pas possible de changer facilement de GPIO, si c'est celui utilisé d'origine ce comportement est étrange.

As-tu essayé de jouer avec les cases à cocher pull-up ...

ici un exemple de configuration espEasy : https://www.domo-blog.fr/flash-firmware ... e-eedomus/

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


fking
Messages : 137
Enregistré le : 03 nov. 2017, 10:19
Localisation : Liverdun (54)
Contact :

Re: Problème avec les rules ESPEasy

Message par fking » 11 janv. 2020, 17:01

A priori on ne peut pas changer de GPIO, le circuit est fait comme ça d'usine. Il faudrait modifier le PCB.
Je vais regarder la piste de l'état haut au boot.
Fais le ou ne le fais pas , essayer ne veut rien dire.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre