Problème installation MQTT

Ici tout ce qui concerne les interfaces personnalisables pour Domoticz : Custom Pages, Reacticz, Domoboard...

Modérateur : vil1driver

jmv75013
Messages : 117
Enregistré le : 03 janv. 2017, 16:20

Re: Problème installation MQTT

Message par jmv75013 » 14 août 2018, 14:08

Merci rimram31,

Bon j'ai desinstallé mosquitto, puis je l'ai reinstallé ensuivant ce site https://www.instructables.com/id/Instal ... pberry-Pi/ et libwebsocket3 a été installé.

Ensuite j'ai remis la ligne

Code : Tout sélectionner

protocol websockets
dans le fichier "/etc/mosquitto/conf.d/monitor.conf". Mais quand je lance la commande

Code : Tout sélectionner

mosquitto -c /etc/mosquitto/conf.d/monitor.conf -d
, je n'ai plus de message d'erreur mais mosquitto ne se lance pas !!

lorsque je fais la commande

Code : Tout sélectionner

sudo service mosquitto restart
, mosquitto ne se lance pas non plus.
lorsque je fais la commande

Code : Tout sélectionner

mosquitto
, mosquitto démarre mais juste sur le port 1883

Je patauge...
Merci

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


rimram31
Messages : 658
Enregistré le : 04 oct. 2015, 11:22
Localisation : Toulouse

Re: Problème installation MQTT

Message par rimram31 » 14 août 2018, 14:42

Pas glop ... j'avoue que je serais plutot parti sur un rebuild style: https://xperimentia.com/2015/08/20/inst ... ebsockets/ avec mosquitto embarquant (dans le binaire) websocket. Tu es dans quelle version de raspbian ? apparemment de la jessie a la stretch, des choses ont changé sur le support de websocket par mosquitto.

Après attention, tes lancements ne sont pas les memes ... un simple mosquitto soit démarrer sans conf, avec -c c'est le fichier que tu donnes, avec systemctl, ça dépend de ce qui a été entré dans les fichiers systemctl. A terme idéalement, c'est mieux de l'avoir en service système (stop/start et start au boot possible si configuré ...)
Raspberry Pi 2 + carte RF pi "maison" + Domoticz
Sonde Oregon + Aliexpress - Prises Chacon (3500W) - 1wire DS18B20

jmv75013
Messages : 117
Enregistré le : 03 janv. 2017, 16:20

Re: Problème installation MQTT

Message par jmv75013 » 14 août 2018, 15:06

merci pour ton aide, je suis en jessie. Je viens de regarder ton lien et la procédure d'installation est la même que le lien que j'avais trouvé.

jmv75013
Messages : 117
Enregistré le : 03 janv. 2017, 16:20

Re: Problème installation MQTT

Message par jmv75013 » 14 août 2018, 19:15

bon je ne sais pas trop comment j'ai fait, mais cela avance. Donc maintenant Docmoticz se connecte bien a MQTT, si je fais

Code : Tout sélectionner

mosquitto_sub -t 'domoticz/out'
Côté monitor, je vois bien

Code : Tout sélectionner

Connecting to MQTT : Success
et plus les messages d'erreur dont je parlais plus haut.

Mais je ne vois rien d'autre, c'est a dire que je ne vois pas de messages de type

Code : Tout sélectionner

MQTT Message Arrived:

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


jmv75013
Messages : 117
Enregistré le : 03 janv. 2017, 16:20

Re: Problème installation MQTT

Message par jmv75013 » 18 août 2018, 10:45

Bonjour,

Bon malgré toutes mes tentatives, je n'y arrive pas... donc j'abandonne pour l'intant
Merci

Redfirebrooks
Messages : 39
Enregistré le : 23 févr. 2018, 22:02

Re: Problème installation MQTT

Message par Redfirebrooks » 18 juil. 2019, 07:12

Bonjour
je partage un souci similaire, mosquito ne se lance pas au démarrage du RPI.

les log de domoticz

Code : Tout sélectionner

2019-07-18 07:01:28.906 Status: MQTT: Connecting to localhost:1883
2019-07-18 07:01:28.931 Status: MQTT: Connecting to localhost:1883
2019-07-18 07:01:28.907 Error: MQTT: Failed to start, return code: 14 (Check IP/Port)
2019-07-18 07:01:28.933 Error: MQTT: Failed to start, return code: 14 (Check IP/Port)
Le seul moyen pour le faire démarrer est la commande

Code : Tout sélectionner

mosquito -d
sinon

Code : Tout sélectionner

pi@domoticz:~ $ sudo systemctl enable mosquitto.service
mosquitto.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable mosquitto
juste après un reboot on voit bien qu'il se passe quelques chose

Code : Tout sélectionner

pi@domoticz:~ $ journalctl -u mosquitto
-- Logs begin at Thu 2016-11-03 18:16:43 CET, end at Wed 2019-07-17 23:52:15 CEST. --
juil. 17 23:51:33 domoticz systemd[1]: Starting LSB: mosquitto MQTT v3.1 message broker...
juil. 17 23:51:34 domoticz mosquitto[406]: Starting network daemon:: mosquitto.
juil. 17 23:51:34 domoticz systemd[1]: Started LSB: mosquitto MQTT v3.1 message broker.
and
mais

Code : Tout sélectionner

pi@domoticz:~ $ sudo systemctl status mosquitto
● mosquitto.service - LSB: mosquitto MQTT v3.1 message broker
   Loaded: loaded (/etc/init.d/mosquitto; generated; vendor preset: enabled)
   Active: active (exited) since Wed 2019-07-17 23:51:34 CEST; 1min 52s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 406 ExecStart=/etc/init.d/mosquitto start (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/mosquitto.service

juil. 17 23:51:33 domoticz systemd[1]: Starting LSB: mosquitto MQTT v3.1 message broker...
juil. 17 23:51:34 domoticz mosquitto[406]: Starting network daemon:: mosquitto.
juil. 17 23:51:34 domoticz systemd[1]: Started LSB: mosquitto MQTT v3.1 message broker.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre