Perte TRADFRI control outlet

Ici un forum de discussion sur Zigate , sa mise en place , les plugin , l'utilisation avec Domoticz
pipiche
Messages : 1606
Enregistré le : 04 avr. 2018, 16:16
Contact :

Re: Perte TRADFRI control outlet

Message par pipiche »

killtoo a écrit : 22 juin 2020, 17:48 La prise est située a quelle distance de la Zigate ?
- La prise est à environ 15 mètres dont 10 en extérieur. Elle passe par des routeurs j'imagine.
Sur quel canal est ton Wifi 2.4Ghz ?
- Canal 6 (en HT20)
Sur quel canal est la Zigate ?
- Canal 11
A quelle distance la Zigate est-elle de la box Wifi ?
- Moins d'un mètre
A quelle distance la Zigate est-elle du Pc/Serveur/Rpi ?
- Environ 15 mètres
Combien de devices en totale ? Combien de type Router ?
- 48 devices dont 15 routeurs

C'est vraiment un device qui n'a jamais eu de soucis, et là d'un coup les 2 que je possède ont cessé de fonctionner en même temps.
est-ce qu'il t'es possible pour test, de rapprocher une de ces prises de la ZiGate et voir comment cela se comporte ?
48 Devices, ca commence à être chaud d'un point de vue Zigate, car en effet la Zigate est prévue pour
40 devices en direct et 30 en indirect (via router).

killtoo
Messages : 45
Enregistré le : 14 janv. 2019, 16:38

Re: Perte TRADFRI control outlet

Message par killtoo »

Ce matin je me suis rappelé que j'avais encore une autre prise Ikea (donc 3 au total) : même problème alors que celle-ci est située à 1,5 mètre.
Je n'ai rien entrepris dessus (aucune manip sur domoticz).

Sur l'UI du plugin je peux l'allumer et l'éteindre, sur domoticz ça n'interagi pas avec mais il n'y a aucune erreur.
Il y a bien la LED de la zigate qui s'allume à chaque commande envoyée.
C'est comme si le message n'était pas bon : peut-être y a-t-il eu une mise à jour OTA ?

Pas très loin j'ai une prise connectée Xiaomi : aucun problème dessus.

pipiche
Messages : 1606
Enregistré le : 04 avr. 2018, 16:16
Contact :

Re: Perte TRADFRI control outlet

Message par pipiche »

Honnêtement, je ne comprends rien à ton problème. Donc peut-on reprendre et faire les etapes dans l'ordre.
Et ce qui m’intéresse c'est le pilotage depuis Domoticz .

Pour ça j'ai besoin des logs, mais pas l'extrait , il faut savoir ce qu'il se passe avant et après une action coté Domoticz.

Donc
(1) Logs lors de l'appairage
(2) Logs lorsqu'il y a une interaction depuis Domoticz

Idéalement les logs depuis le lancement du plugin ( attacher le fichier dans ce post en le zippant par exemple )
et coté tu dis les manips qui sont faites ( avec le timing pour pouvoir voir ce qu'il y a dans les logs )

PS/ Il y a une option dans le menu Tools->Debug où il faut désactiver 'Use Domoticz Log' .
Dans ce cas tous va être crashé dans un ficher de log dans le repertoire Domoticz-Zigate/Logs
Screenshot 2020-06-23 at 08.40.29.png
Screenshot 2020-06-23 at 08.40.29.png (101.3 Kio) Vu 652 fois

killtoo
Messages : 45
Enregistré le : 14 janv. 2019, 16:38

Re: Perte TRADFRI control outlet

Message par killtoo »

Je vais faire ces manipulations.

En attentant voici un petit résumé simplifié :
- Mes 3 prises Ikea ont cessé de fonctionner avec Domoticz
- Avec l'outil du plugin je pouvais encore les commander
- Sur 2 des 3 prises j'ai fait des manipulations pour les supprimer/appairer : j'ai eu beaucoup d'erreurs et le comportement était aléatoire (là j'ai par exemple une de ces prises qui fonctionne depuis hier)
- Sur la prise où je n'ai fait aucune manipulation (et qui est à 1,5m de la Zigate) je n'ai aucun log d'erreur, elle ne passe même pas en rouge sur Domoticz (le seul moyen de se rendre compte qu'elle ne fonctionne pas est de la voir en vrai)

ricky74
Messages : 68
Enregistré le : 03 sept. 2015, 13:58

Re: Perte TRADFRI control outlet

Message par ricky74 »

Bonjour, j'ai exactement le même problème que toi avec mes prises ikea.
Hier , je me suis apercu que je ne puvais plus les piloter avec Domoticz, alors que tout se passait bien jusque là.

Pour moi, la seule manip que j'ai faite c'est mettre à jour le plugin.

Je suis en stable 4.9.005 et ma zigate est en 031a (a priori, passer en b ne change rien)
Je suis sur la 2020.1 de domoticz (stable)

J'ai fait les mise à jour OTA des prises ce matin, mais cela ne change rien non plus.
J'ai toujours ces messages quand je les pilote depuis domoticz :

2020-09-07 12:58:59.752 Error: (Zigate) APS Failure , Command: 0x0092:On/Off for Prise etage (Prise Etage,33cb,000d6ffffe7cb25f) not correctly transmited. ( d4, NWK - [d4] Unicast frame does not have a route available but it is buffered for automatic resend )

Je n'arrive pas à avoir plus de détail dans les logs...
Du coup, je n'ai plus de répéteurs dans la maison et la qualité de mon maillage est moins bonne...

Pour info, mes prises sont à 2m maxi de la zigate...

Que puis-je faire ?
Merci

Eric

pitchoun
Messages : 12
Enregistré le : 22 mars 2019, 12:15

Re: Perte TRADFRI control outlet

Message par pitchoun »

ricky74 a écrit : 07 sept. 2020, 13:21 Bonjour, j'ai exactement le même problème que toi avec mes prises ikea.
Hier , je me suis apercu que je ne puvais plus les piloter avec Domoticz, alors que tout se passait bien jusque là.

Pour moi, la seule manip que j'ai faite c'est mettre à jour le plugin.

Je suis en stable 4.9.005 et ma zigate est en 031a (a priori, passer en b ne change rien)
Je suis sur la 2020.1 de domoticz (stable)

J'ai fait les mise à jour OTA des prises ce matin, mais cela ne change rien non plus.
J'ai toujours ces messages quand je les pilote depuis domoticz :

2020-09-07 12:58:59.752 Error: (Zigate) APS Failure , Command: 0x0092:On/Off for Prise etage (Prise Etage,33cb,000d6ffffe7cb25f) not correctly transmited. ( d4, NWK - [d4] Unicast frame does not have a route available but it is buffered for automatic resend )

Je n'arrive pas à avoir plus de détail dans les logs...
Du coup, je n'ai plus de répéteurs dans la maison et la qualité de mon maillage est moins bonne...

Pour info, mes prises sont à 2m maxi de la zigate...

Que puis-je faire ?
Merci

Eric
As-tu essayé de re-appairer cette prise "Prise etage" ? car du message d'erreur on peut considérer qu'elle ne fait plus partie du réseau.
- ZIgate USB-TTL
- Xiaomi Sensors et Switch
- Ikea Tradfri Bulb
- Hue Motion Sensor et Remote
- Aqara Bulb

ricky74
Messages : 68
Enregistré le : 03 sept. 2015, 13:58

Re: Perte TRADFRI control outlet

Message par ricky74 »

Oui, ce matin, j'ai tenté un re-appairage et voilà le message que j'ai eu :

2020-09-07 06:34:49.772 Status: (Zigate) Accepting new Hardware: On
2020-09-07 06:35:34.515 Status: (Zigate) Device Announcement: Prise garage(7b7c, 000d6ffffe2c3830) Join Flag: 0x99 - Unknown value received. RSSI: 0 ChangeShortID: False

Répondre