[Béta]Plugin Zigate USB + Wifi

Ici un forum de discussion sur Zigate , sa mise en place , les plugin , l'utilisation avec Domoticz
domo!
Messages : 21
Enregistré le : 12 mars 2017, 19:02

Re: [Béta]Plugin Zigate USB + Wifi

Message par domo! »

Re-bonjour
Petite question également sur le détecteur de fumée Xiaomi/HoneyWell.
Est-ce possible de commander sa sonnerie (ON et OFF) depuis Domoticz, afin de s'en servir comme d'une sirène d'alarme ?
Merci

SpaWnOL
Messages : 24
Enregistré le : 05 févr. 2018, 15:53

Re: [Béta]Plugin Zigate USB + Wifi

Message par SpaWnOL »

Tojours mon probleme identique avec mon switch Xiaomi.. il est détecté sous Domoticz mais je n'arrive à faire fonctionner que le 1 click. Aucune réaction sur 2 clicks / 3 clicks / 4 clicks...

Pas d'erreur dans les logs de Domoticz.. qu'aurais je fait de mal ?

jk77
Messages : 2
Enregistré le : 05 févr. 2018, 16:57

Re: [Béta]Plugin Zigate USB + Wifi

Message par jk77 »

SpaWnOL a écrit :Tojours mon probleme identique avec mon switch Xiaomi.. il est détecté sous Domoticz mais je n'arrive à faire fonctionner que le 1 click. Aucune réaction sur 2 clicks / 3 clicks / 4 clicks...

Pas d'erreur dans les logs de Domoticz.. qu'aurais je fait de mal ?
La solution ici, merci à rollyfx !

https://github.com/sasu-drooz/Domoticz-Zigate/issues/65

Quant à la doc, elle est dispo ici :
http://zigate.fr/xiaomi-bouton-switch-cluster/

... effectivement, l'attribute ID est different entre un simple clic et un multi clics

SpaWnOL
Messages : 24
Enregistré le : 05 févr. 2018, 15:53

Re: [Béta]Plugin Zigate USB + Wifi

Message par SpaWnOL »

jk77 a écrit :
SpaWnOL a écrit :Tojours mon probleme identique avec mon switch Xiaomi.. il est détecté sous Domoticz mais je n'arrive à faire fonctionner que le 1 click. Aucune réaction sur 2 clicks / 3 clicks / 4 clicks...

Pas d'erreur dans les logs de Domoticz.. qu'aurais je fait de mal ?
La solution ici, merci à rollyfx !

https://github.com/sasu-drooz/Domoticz-Zigate/issues/65

Quant à la doc, elle est dispo ici :
http://zigate.fr/xiaomi-bouton-switch-cluster/

... effectivement, l'attribute ID est different entre un simple clic et un multi clics
Super, je viens de faire la modif et ca fonctionne enfin....... merci pour ta réponse !

seb19
Messages : 3
Enregistré le : 27 nov. 2017, 18:05

Re: [Béta]Plugin Zigate USB + Wifi

Message par seb19 »

SpaWnOL a écrit :
jk77 a écrit :
SpaWnOL a écrit :Tojours mon probleme identique avec mon switch Xiaomi.. il est détecté sous Domoticz mais je n'arrive à faire fonctionner que le 1 click. Aucune réaction sur 2 clicks / 3 clicks / 4 clicks...

Pas d'erreur dans les logs de Domoticz.. qu'aurais je fait de mal ?
La solution ici, merci à rollyfx !

https://github.com/sasu-drooz/Domoticz-Zigate/issues/65

Quant à la doc, elle est dispo ici :
http://zigate.fr/xiaomi-bouton-switch-cluster/

... effectivement, l'attribute ID est different entre un simple clic et un multi clics
Super, je viens de faire la modif et ca fonctionne enfin....... merci pour ta réponse !
Bonjour à tous,

Alors oui cela fonctionne mais voici ce que j'ai remarqué :

https://github.com/sasu-drooz/Domoticz-Zigate/issues/71 :

Je débute avec ma Zigate. Je n'arrive pas à faire fonctionner en même temps un capteur ouverture/fermeture et un bouton aqara. Dans le fichier plugin.py si ligne 11OO est égal à : if MsgAttrID=="0000": alors le capteur fonctionne mais le bouton reste toujours à 1 click et si la ligne 1100 est égal à : if MsgAttrID=="8000": alors le bouton fonctionne mais pas le capteur.


Autre chose je suis aussi tombé sur le même problème que SpaWnOL :

2018-03-18 20:54:02.494 Error: (ZIGATE) 'onStart' failed 'KeyError'.
2018-03-18 20:54:02.494 Error: (ZIGATE) ----> Line 278 in /home/pi/domoticz/plugins/Domoticz-Zigate-2.2.3/plugin.py, function onStart
2018-03-18 20:54:02.494 Error: (ZIGATE) ----> Line 68 in /home/pi/domoticz/plugins/Domoticz-Zigate-2.2.3/plugin.py, function onStart

et mon DeviceList :

dad9 : {'Battery': 104, 'Model': 'lumi.sensor_switch.aq2', 'Ep': {'01': {'0006': {}, '0000': {}}}, 'IEEE': '00158d0002134d06', 'ProfileID': {}, 'Status': 'inDB', 'ZDeviceID': {}, 'Heartbeat': '402', 'MacCapa': '80', 'Type': 'MSwitch', 'RIA': '3'}
6e5f : {'Battery': 102, 'Model': 'lumi.sensor_magnet.aq2', 'Ep': {'01': {'0006': '00', '0000': {}}}, 'IEEE': '00158d0001b7bd9d', 'ProfileID': {}, 'Status': 'inDB', 'ZDeviceID': {}, 'Heartbeat': '402', 'MacCapa': '80', 'Type': 'Door', 'RIA': '8'}
e5dd : {'Battery': 99, 'Model': 'lumi.weather', 'Ep': {'01': {'0403': 982.2, '0402': 9.7, '0405': 75.4, '0000': {}}}, 'IEEE': '00158d0001b92251', 'ProfileID': {}, 'Status': 'inDB', 'ZDeviceID': {}, 'Heartbeat': '402', 'MacCapa': '80', 'Type': 'Temp/Humi/Baro', 'RIA': '24'}
ad9b : {'Battery': 102, 'Model': 'lumi.sensor_magnet.aq2', 'Ep': {'01': {'0006': '00', '0000': {}}}, 'IEEE': '00158d0001b7bc49', 'ProfileID': {}, 'Status': 'inDB', 'ZDeviceID': {}, 'Heartbeat': '402', 'MacCapa': '80', 'Type': 'Door', 'RIA': '10'}
bb36 : {'Battery': 102, 'Model': 'lumi.sensor_magnet.aq2', 'Ep': {'01': {'0006': '01', '0000': {}}}, 'IEEE': '00158d0001e48a2f', 'ProfileID': {}, 'Status': 'inDB', 'ZDeviceID': {}, 'Heartbeat': '402', 'MacCapa': '80', 'Type': 'Door', 'RIA': '7'}
ce0b : {'Battery': 102, 'Model': 'lumi.sensor_motion.aq2', 'Ep': {'01': {'0400': 10, '0000': {}, '0406': '01'}}, 'IEEE': '00158d000225495e', 'ProfileID': {}, 'Status': 'inDB', 'ZDeviceID': {}, 'Heartbeat': '402', 'MacCapa': '80', 'Type': 'Motion/Lux', 'RIA': '75'}

Pour moi aussi ce souci est arrivé sans raison particulière. La première fois j'ai tous réinitialisé mais j'aimerai bien comprendre ce qu'il se passe.

Voila, merci pour votre aide

SpaWnOL
Messages : 24
Enregistré le : 05 févr. 2018, 15:53

Re: [Béta]Plugin Zigate USB + Wifi

Message par SpaWnOL »

Alors, j'ai toujours des petits soucis par contre, je retrouve ca dans mes logs Domoticz
Je viens de me rendre compe que mon fichier DeviceList est vide....

2018-03-18 23:36:37.354 (Zigate) ZigateDecode - decodind data : 018102120210021ef1b5816c021102100216021002100210100210021102113303
2018-03-18 23:36:37.355 (Zigate) ZigateRead - decoded data : 018102000ef1b5816c010006000000100001013303
2018-03-18 23:36:37.355 (Zigate) ZigateRead - Message Type : 8102, Data : b5816c01000600000010000101, RSSI : 33, Length : 000e, Checksum : f1
2018-03-18 23:36:37.355 (Zigate) ZigateRead - MsgType 8102 - Report Individual Attribute response : 018102000ef1b5816c010006000000100001013303
2018-03-18 23:36:37.355 (Zigate) Decode8102 - reception data : 01 ClusterID : 0006 Attribut ID : 0000 Src Addr : 816c Scr Ep: 01
2018-03-18 23:36:37.355 (Zigate) MajDomoDevice - Device ID : 816c - Device EP : 01 - Type : 0006 - Value : 01
2018-03-18 23:36:37.355 (Zigate) onMessage - effacement de la trame suite a une erreur de decodage : 018102120210021ef1b5816c021102100216021002100210100210021102113303

SpaWnOL
Messages : 24
Enregistré le : 05 févr. 2018, 15:53

Re: [Béta]Plugin Zigate USB + Wifi

Message par SpaWnOL »

SpaWnOL a écrit :Alors, j'ai toujours des petits soucis par contre, je retrouve ca dans mes logs Domoticz
Je viens de me rendre compe que mon fichier DeviceList est vide....

2018-03-18 23:36:37.354 (Zigate) ZigateDecode - decodind data : 018102120210021ef1b5816c021102100216021002100210100210021102113303
2018-03-18 23:36:37.355 (Zigate) ZigateRead - decoded data : 018102000ef1b5816c010006000000100001013303
2018-03-18 23:36:37.355 (Zigate) ZigateRead - Message Type : 8102, Data : b5816c01000600000010000101, RSSI : 33, Length : 000e, Checksum : f1
2018-03-18 23:36:37.355 (Zigate) ZigateRead - MsgType 8102 - Report Individual Attribute response : 018102000ef1b5816c010006000000100001013303
2018-03-18 23:36:37.355 (Zigate) Decode8102 - reception data : 01 ClusterID : 0006 Attribut ID : 0000 Src Addr : 816c Scr Ep: 01
2018-03-18 23:36:37.355 (Zigate) MajDomoDevice - Device ID : 816c - Device EP : 01 - Type : 0006 - Value : 01
2018-03-18 23:36:37.355 (Zigate) onMessage - effacement de la trame suite a une erreur de decodage : 018102120210021ef1b5816c021102100216021002100210100210021102113303
Alors j'ai tout reinitialisé et pour le moment ca marche.. a suivre :)

zaraki673
Messages : 229
Enregistré le : 07 oct. 2016, 04:29

Re: [Béta]Plugin Zigate USB + Wifi

Message par zaraki673 »

Bonjour,

Plugin mis à jour avec le fix de rollyfx et un correctif pour la creation de nouveau device si un device a ete supprimé précédement (erreur Device creation failed, Hardware/Unit combination ...)

v2.2.5 ;)

pour l'erreur onstart, je regarde mais je vois pas trop pourquoi vous avez encore cette erreur :(

seb19
Messages : 3
Enregistré le : 27 nov. 2017, 18:05

Re: [Béta]Plugin Zigate USB + Wifi

Message par seb19 »

zaraki673 a écrit :Bonjour,

Plugin mis à jour avec le fix de rollyfx et un correctif pour la creation de nouveau device si un device a ete supprimé précédement (erreur Device creation failed, Hardware/Unit combination ...)

v2.2.5 ;)

pour l'erreur onstart, je regarde mais je vois pas trop pourquoi vous avez encore cette erreur :(
Alors pour l'erreur onstart, je voulais supprimer un par un les différents devices et j'ai commencé par supprimer le bouton aqara, puis j'ai relancé domoticz.sh et là miracle plus d'erreurs. Je n'ai pas trop d'explication mais cela fonctionne.

Merci

SpaWnOL
Messages : 24
Enregistré le : 05 févr. 2018, 15:53

Re: [Béta]Plugin Zigate USB + Wifi

Message par SpaWnOL »

Bon bah c'était trop beau pour que cela dure...

Hier soir tout fonctionne
Ce matin le switch ne veut plus rien savoir

Plus de reaction sous Domoticz...
et quand je clique sur Domoticz sur l'un des 4 boutons, j'ai ce message d'erreur dans les logs

2018-03-23 08:49:18.993 Error: (Zigate) 'onCommand' failed 'UnboundLocalError':'local variable 'ClusterSearch' referenced before assignment'.
2018-03-23 08:49:18.993 Error: (Zigate) ----> Line 294 in /home/pi/domoticz/plugins/Domoticz-Zigate/plugin.py, function onCommand
2018-03-23 08:49:18.993 Error: (Zigate) ----> Line 154 in /home/pi/domoticz/plugins/Domoticz-Zigate/plugin.py, function onCommand

:roll: :roll: :roll: :roll:

Répondre