Volet roulant Profalux

Ici un forum de discussion sur Zigate , sa mise en place , les plugin , l'utilisation avec Domoticz
k20human
Messages : 18
Enregistré le : 22 juil. 2017, 17:37

Volet roulant Profalux

Message par k20human » 10 août 2019, 01:15

Bonjour à tous,

J'ai depuis peu fait installé un volet roulant Profalux radio Zigbee. J'ai voulu l'intégrer à mon Domoticz via une Zigate branchée sur un Raspberry Pi 3.

Au niveau de la configuration je suis sous Python 3.7 et j'utilise la branche beta du plugin. J'avais une erreur sur la branche stable.

J'ai voulu intégrer le volet à la Zigate mais je crois avoir mal réalisé une étape ...
Lors de l'intégration du volet j'ai 4 switchs qui se sont créés mais aucun d'eux ne commande vraiment le volet. Il ne fait qu'un léger va et vient ...
Sélection_281.png
Sélection_281.png (49.41 Kio) Vu 362 fois
Pire encore, il m'est maintenant impossible d'utiliser la télécommande ... J'ai beau appuyer 5 sur le bouton reset ou essayé de l'intégrer au réseau elle ne veut rien savoir ...

Est-ce que vous avez une solution pour déjà faire un sorte que la télécommande fonctionne et que je puisse repartir de 0 ?
Je peux fournir différents logs si nécessaire.

Merci d'avance

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


pipiche
Messages : 795
Enregistré le : 04 avr. 2018, 16:16

Re: Volet roulant Profalux

Message par pipiche » 10 août 2019, 09:09

Quelles est la procédure que tu as suivi pour l'appairage ? Il faut faire attente a ne pas faire le Reset de la télécommande alors que la Zigate est en mode appairage.
Le fait que tu es eu 4 Switch est surprenant, car ils sont dupliqués.

1_ Pour remettre ta télécommande opérationnelle, je pense qu'il faut que tu reset ton installation. Voir avec ton installateur, ou sur le site de profalux .

IL faut voir la date de fabrication ( car il y a des moteur avant et après 2016 )

http://www.profalux-pro.com/documentati ... %20Zigbee/

Suivant ta situation, il y a peut-être une manip électrique à effectuer

2_ Pour refaire l'appairage

Il faudra que tu supprimes les switch créés dans Domoticz
Suivre la doc https://zigate.fr/2018/02/03/associatio ... la-zigate/
Et bien faire attention que à l'étape 1 et à l'etape 2, la Zigate ne soit pas en mode appairage

k20human
Messages : 18
Enregistré le : 22 juil. 2017, 17:37

Re: Volet roulant Profalux

Message par k20human » 10 août 2019, 13:03

Bonjour,

Merci pour la réponse. En effet je pense que ma Zigate était en permit join depuis le début ...
J'ai réinitialiser le volet et la télécommande comme indiquée dans la doc Profalux, mon volet a été installé récemment donc après 2016. J'ai ensuite pu récupérer l'usage de ma télécommande, merci.

J'ai ensuite suivi le tuto que tu m'as indiqué, c'était celui-ci que j'avais utilisé hier, après avoir réinit la Zigate et supprimé les devices dans Domoticz. Mais malheureusement rebolote, j'ai encore 4 devices qui se sont créés, que des switchs et ma télécommande ne refonctionne plus :'(

J'ai zappé quelque chose ? Voici les logs : https://drive.google.com/file/d/1AdRayR ... sp=sharing. Pour le moment je laisse comme ça, il faudra que je refasse la manip pour remettre la télécommande.

pipiche
Messages : 795
Enregistré le : 04 avr. 2018, 16:16

Re: Volet roulant Profalux

Message par pipiche » 10 août 2019, 14:26

Je regarde les logs ce soir, mais essaye sur la branche stable. En effet la bêta est en plein chamboulement.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


k20human
Messages : 18
Enregistré le : 22 juil. 2017, 17:37

Re: Volet roulant Profalux

Message par k20human » 10 août 2019, 17:26

Avec la branche stable j'ai l'erreur suivante au lancement du plugin (je l'avais hier aussi, c'est pour ça que j'ai voulu tester la branche béta)

Code : Tout sélectionner

019-08-10 17:25:07.593 Error: (Zigate) 'onStart' failed 'AttributeError':''NoneType' object has no attribute 'pluginConf''.
2019-08-10 17:25:07.593 Error: (Zigate) ----> Line 786 in '/home/k20/domoticz/plugins/Domoticz-Zigate/plugin.py'
2019-08-10 17:25:07.593 Error: (Zigate) ----> Line 200 in '/home/k20/domoticz/plugins/Domoticz-Zigate/plugin.py'
2019-08-10 17:25:07.593 Error: (Zigate) ----> Line 524 in '/home/k20/domoticz/plugins/Domoticz-Zigate/Modules/tools.py'
J'ai supprimé le dossier __pycahce__, vérifier les dépendances mais sans succès :(

pipiche
Messages : 795
Enregistré le : 04 avr. 2018, 16:16

Re: Volet roulant Profalux

Message par pipiche » 10 août 2019, 18:06

Il doit y avoir une erreur en amont


Envoyé de mon iPhone en utilisant Tapatalk
Je maintiens le plugin Zigate sur mon temps libre .
Si vous appréciez ce que je fais, vous pouvez contribuer par un don Paypal , ce qui me permettra notamment l'achat d’équipements et de les tester/valider pour le plugin.

pipiche
Messages : 795
Enregistré le : 04 avr. 2018, 16:16

Re: Volet roulant Profalux

Message par pipiche » 10 août 2019, 20:40

bonsoir,

je viens de regarder les logs, et je te confirme que à 12h44 c'est bien la Télécommande qui s'appaire.
Donc je te suggère d'essayer la manip suivante.

(1) Dans Domoticz, tu supprimes les Widgets qui ont été créées.
(2) Tu arretes Domoticz
(3) Tu debranches la Zigate

(4) Tu fais le Reset de ta telecomande ce qui devrait refaire fonctionner ton volet ( etape 1 à 2 )

(5) Tu rebranches la Zigate
(6) Tu relances Domotciz
(7) Tu mets la Zigate en mode appairage ( celle-ci doit clignoter Bleu)

(8) Tu passes aux etapes 3 et 4

Ps/ j'ai aussi galéré sur les appairages .. J'ai 7 volets


Pour le Problème avec la version stable. Si tu peux partager le log entier, il doit y avoir un truc qui se passe mal au lancement.
Je maintiens le plugin Zigate sur mon temps libre .
Si vous appréciez ce que je fais, vous pouvez contribuer par un don Paypal , ce qui me permettra notamment l'achat d’équipements et de les tester/valider pour le plugin.

k20human
Messages : 18
Enregistré le : 22 juil. 2017, 17:37

Re: Volet roulant Profalux

Message par k20human » 12 août 2019, 08:24

Je viens de relancer Domoticz, rien de plus dans les logs concernant la version stable :( j'ai activé tous les logs du plugin.

Code : Tout sélectionner

2019-08-12 08:20:31.021 Status: (Zigate) Started.
2019-08-12 08:20:32.215 (Zigate) Debug: 30
2019-08-12 08:20:32.203 Status: (Zigate) Entering work loop.
2019-08-12 08:20:32.204 Status: (Zigate) Initialized version 4.5, author 'zaraki673 pipiche38'
2019-08-12 08:20:32.215 Status: (Zigate) Zigate plugin stable-4.5.2 started
2019-08-12 08:20:32.215 Error: (Zigate) 'onStart' failed 'AttributeError':''NoneType' object has no attribute 'pluginConf''.
2019-08-12 08:20:32.215 Error: (Zigate) ----> Line 786 in '/home/k20/domoticz/plugins/Domoticz-Zigate/plugin.py'
2019-08-12 08:20:32.215 Error: (Zigate) ----> Line 200 in '/home/k20/domoticz/plugins/Domoticz-Zigate/plugin.py'
2019-08-12 08:20:32.215 Error: (Zigate) ----> Line 524 in '/home/k20/domoticz/plugins/Domoticz-Zigate/Modules/tools.py'
Pour la manip je la ferai quand la version stable sur mon Rasp sera fonctionnel, j'aimerai éviter de devoir remanipuler la prise sur laquelle est branchée le volet encore une fois :)

pipiche
Messages : 795
Enregistré le : 04 avr. 2018, 16:16

Re: Volet roulant Profalux

Message par pipiche » 12 août 2019, 08:36

k20human a écrit :
12 août 2019, 08:24
Je viens de relancer Domoticz, rien de plus dans les logs concernant la version stable :( j'ai activé tous les logs du plugin.

Code : Tout sélectionner

2019-08-12 08:20:31.021 Status: (Zigate) Started.
2019-08-12 08:20:32.215 (Zigate) Debug: 30
2019-08-12 08:20:32.203 Status: (Zigate) Entering work loop.
2019-08-12 08:20:32.204 Status: (Zigate) Initialized version 4.5, author 'zaraki673 pipiche38'
2019-08-12 08:20:32.215 Status: (Zigate) Zigate plugin stable-4.5.2 started
2019-08-12 08:20:32.215 Error: (Zigate) 'onStart' failed 'AttributeError':''NoneType' object has no attribute 'pluginConf''.
2019-08-12 08:20:32.215 Error: (Zigate) ----> Line 786 in '/home/k20/domoticz/plugins/Domoticz-Zigate/plugin.py'
2019-08-12 08:20:32.215 Error: (Zigate) ----> Line 200 in '/home/k20/domoticz/plugins/Domoticz-Zigate/plugin.py'
2019-08-12 08:20:32.215 Error: (Zigate) ----> Line 524 in '/home/k20/domoticz/plugins/Domoticz-Zigate/Modules/tools.py'
Pour la manip je la ferai quand la version stable sur mon Rasp sera fonctionnel, j'aimerai éviter de devoir remanipuler la prise sur laquelle est branchée le volet encore une fois :)
Comme mentionné plus haut, mets le Debug à None et ca fonctionne !
IL est inutile de mettre du debug, car ca pollue plus les logs qu'autre chose.

pipiche
Messages : 795
Enregistré le : 04 avr. 2018, 16:16

Re: Volet roulant Profalux

Message par pipiche » 12 août 2019, 12:06

pipiche a écrit :
12 août 2019, 08:36
k20human a écrit :
12 août 2019, 08:24
Je viens de relancer Domoticz, rien de plus dans les logs concernant la version stable :( j'ai activé tous les logs du plugin.

Code : Tout sélectionner

2019-08-12 08:20:31.021 Status: (Zigate) Started.
2019-08-12 08:20:32.215 (Zigate) Debug: 30
2019-08-12 08:20:32.203 Status: (Zigate) Entering work loop.
2019-08-12 08:20:32.204 Status: (Zigate) Initialized version 4.5, author 'zaraki673 pipiche38'
2019-08-12 08:20:32.215 Status: (Zigate) Zigate plugin stable-4.5.2 started
2019-08-12 08:20:32.215 Error: (Zigate) 'onStart' failed 'AttributeError':''NoneType' object has no attribute 'pluginConf''.
2019-08-12 08:20:32.215 Error: (Zigate) ----> Line 786 in '/home/k20/domoticz/plugins/Domoticz-Zigate/plugin.py'
2019-08-12 08:20:32.215 Error: (Zigate) ----> Line 200 in '/home/k20/domoticz/plugins/Domoticz-Zigate/plugin.py'
2019-08-12 08:20:32.215 Error: (Zigate) ----> Line 524 in '/home/k20/domoticz/plugins/Domoticz-Zigate/Modules/tools.py'
Pour la manip je la ferai quand la version stable sur mon Rasp sera fonctionnel, j'aimerai éviter de devoir remanipuler la prise sur laquelle est branchée le volet encore une fois :)
Comme mentionné plus haut, mets le Debug à None et ca fonctionne !
IL est inutile de mettre du debug, car ca pollue plus les logs qu'autre chose.
@k20human désolé j'ai mixé avec un autre post.
Donc si tu mets Debug=None , tu ne devrais pas avoir d'erreur au lancement du plugin

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre