Mise en route Zigate -- Erreur du plugin ...

Ici un forum de discussion sur Zigate , sa mise en place , les plugin , l'utilisation avec Domoticz
loops
Messages : 296
Enregistré le : 13 nov. 2014, 18:14

Mise en route Zigate -- Erreur du plugin ...

Message par loops » 18 oct. 2019, 23:53

Salut à tous,
J'ai acheté mon module Zigate au tout début de l'aventure. Je n'ai jamais pris le temps de le mettre en route jusqu’à aujourd'hui :/

J'ai commencé par mettre à jour la Zigate (3.1.a) elle même avec JennicModuleProgrammer et le FTDI acheté aussi avec la Zigate. Ça s'est apparemment bien passé.
J'ai mis à jour le module Wifi (ZiGate-WiFi v2.00 with esp-link v3.2.50-gfe4f565-dirty). Tout s'est bien passé et j'ai bien la nouvelle interface si je me connecte à l'ip de ma Zigate.

J'ai mis à jour le plugin Domoticz que j'avais installé il y a quelques mois avec un git pull depuis le dossier du plugin. Tout s'est apparemment bien passé mais quand je démarre le plugin j'ai ces messages :

2019-10-18 23:41:42.086 Status: (Zigate) Started.
2019-10-18 23:41:42.216 Status: (Zigate) Entering work loop.
2019-10-18 23:41:42.216 Status: (Zigate) Initialized version 4.5, author 'zaraki673 pipiche38'
2019-10-18 23:41:42.217 Status: (Zigate) Zigate plugin stable-4.5.4 started
2019-10-18 23:41:42.217 Error: (Zigate) 'onStart' failed 'ValueError':'invalid literal for int() with base 10: 'null''.
2019-10-18 23:41:42.217 Error: (Zigate) ----> Line 781 in '/home/loops/domoticz/plugins/Zigate/plugin.py', function onStart
2019-10-18 23:41:42.217 Error: (Zigate) ----> Line 198 in '/home/loops/domoticz/plugins/Zigate/plugin.py', function onStart

Savez vous ce que je peux faire pour corriger ?

En vous remerciant !

JC

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


pipiche
Messages : 955
Enregistré le : 04 avr. 2018, 16:16

Re: Mise en route Zigate -- Erreur du plugin ...

Message par pipiche » 19 oct. 2019, 09:01

loops a écrit :
18 oct. 2019, 23:53
Salut à tous,
J'ai acheté mon module Zigate au tout début de l'aventure. Je n'ai jamais pris le temps de le mettre en route jusqu’à aujourd'hui :/

J'ai commencé par mettre à jour la Zigate (3.1.a) elle même avec JennicModuleProgrammer et le FTDI acheté aussi avec la Zigate. Ça s'est apparemment bien passé.
J'ai mis à jour le module Wifi (ZiGate-WiFi v2.00 with esp-link v3.2.50-gfe4f565-dirty). Tout s'est bien passé et j'ai bien la nouvelle interface si je me connecte à l'ip de ma Zigate.

J'ai mis à jour le plugin Domoticz que j'avais installé il y a quelques mois avec un git pull depuis le dossier du plugin. Tout s'est apparemment bien passé mais quand je démarre le plugin j'ai ces messages :

2019-10-18 23:41:42.086 Status: (Zigate) Started.
2019-10-18 23:41:42.216 Status: (Zigate) Entering work loop.
2019-10-18 23:41:42.216 Status: (Zigate) Initialized version 4.5, author 'zaraki673 pipiche38'
2019-10-18 23:41:42.217 Status: (Zigate) Zigate plugin stable-4.5.4 started
2019-10-18 23:41:42.217 Error: (Zigate) 'onStart' failed 'ValueError':'invalid literal for int() with base 10: 'null''.
2019-10-18 23:41:42.217 Error: (Zigate) ----> Line 781 in '/home/loops/domoticz/plugins/Zigate/plugin.py', function onStart
2019-10-18 23:41:42.217 Error: (Zigate) ----> Line 198 in '/home/loops/domoticz/plugins/Zigate/plugin.py', function onStart

Savez vous ce que je peux faire pour corriger ?

En vous remerciant !

JC

Ton problème semble etre lié sur un des paramètres de lancement du plugin.
Dans le menu Hardware de DOmoticz, qu'as tu mis pour Verbors and Debuging. Laisses bien les paramètres par default None ou Aucun

loops
Messages : 296
Enregistré le : 13 nov. 2014, 18:14

Re: Mise en route Zigate -- Erreur du plugin ...

Message par loops » 19 oct. 2019, 12:22

Merci, c’était bien ca ! Ou presque. Le champ "Verbors and debugging" était vide. J'ai mis aucun et ça a l'air mieux mais j'ai quand même encore des erreurs au démarrage ... :(

2019-10-19 12:16:14.165 Status: (Zigate) ZigateConf setting Channel(s) to: 0
2019-10-19 12:16:14.165 Status: (Zigate) setChannel - Channel set to : 00000000
2019-10-19 12:16:14.165 Status: (Zigate) Set Zigate as a Coordinator
2019-10-19 12:16:14.165 Status: (Zigate) Start network
2019-10-19 12:16:19.132 (Zigate) No Firmware Version received from Zigate
2019-10-19 12:16:24.149 (Zigate) No Firmware Version received from Zigate
2019-10-19 12:16:29.166 (Zigate) No Firmware Version received from Zigate
2019-10-19 12:16:29.166 (Zigate) Try to get Firmware version once more HB:8
2019-10-19 12:16:34.133 (Zigate) No Firmware Version received from Zigate
2019-10-19 12:16:39.150 (Zigate) No Firmware Version received from Zigate
2019-10-19 12:16:44.171 (Zigate) No Firmware Version received from Zigate
2019-10-19 12:16:44.171 Error: (Zigate) Plugin is not started ...
2019-10-19 12:16:44.171 Error: (Zigate) - Communication issue with the Zigate
2019-10-19 12:16:44.171 Error: (Zigate) - restart once the plugin, and if this remain the same
2019-10-19 12:16:44.171 Error: (Zigate) - unplug/plug the zigate
2019-10-19 12:16:49.137 (Zigate) No Firmware Version received from Zigate
2019-10-19 12:16:49.138 Error: (Zigate) Plugin is not started ...
2019-10-19 12:16:49.138 Error: (Zigate) - Communication issue with the Zigate
2019-10-19 12:16:49.138 Error: (Zigate) - restart once the plugin, and if this remain the same

Le module Wifi est bien connecté, j'ai accès à son interface web sur l'ip qui se trouve dans la conf du plugin. Ce que je comprend de ces messages c'est que la zigate répond pas. J'ai peut être merdé sur la mise à jour de son FW ???
Sélection_130.png
Sélection_130.png (85.79 Kio) Vu 509 fois

pipiche
Messages : 955
Enregistré le : 04 avr. 2018, 16:16

Re: Mise en route Zigate -- Erreur du plugin ...

Message par pipiche » 19 oct. 2019, 17:52

Essayes de commencer en mode USB . Pour. Our si ça fonctionne


Envoyé de mon iPhone en utilisant Tapatalk
Je maintiens le plugin Zigate sur mon temps libre .
Si vous appréciez ce que je fais, vous pouvez contribuer par un don Paypal , ce qui me permettra notamment l'achat d’équipements et de les tester/valider pour le plugin.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


loops
Messages : 296
Enregistré le : 13 nov. 2014, 18:14

Re: Mise en route Zigate -- Erreur du plugin ...

Message par loops » 21 oct. 2019, 17:06

Salut !

C'est chose faite mais même problème. Je vais essayer de reflasher la Zigate ...

Code : Tout sélectionner

2019-10-21 17:03:50.796 Status: (Zigate) Started.
2019-10-21 17:03:50.900 Status: (Zigate) Entering work loop.
2019-10-21 17:03:50.900 Status: (Zigate) Initialized version 4.5, author 'zaraki673 pipiche38'
2019-10-21 17:03:50.901 Status: (Zigate) Zigate plugin stable-4.5.4 started
2019-10-21 17:03:50.902 Status: (Zigate) Python Version - 3.6.8 (default, Oct 7 2019, 12:59:55)
2019-10-21 17:03:50.902 Status: (Zigate) Switching Heartbeat to 5 s interval
2019-10-21 17:03:50.902 Status: (Zigate) DomoticzVersion: 4.10717
2019-10-21 17:03:50.902 Status: (Zigate) DomoticzHash: b38b49e5
2019-10-21 17:03:50.902 Status: (Zigate) DomoticzBuildTime: 2019-05-09 13:04:08
2019-10-21 17:03:50.902 Status: (Zigate) load PluginConf
2019-10-21 17:03:50.903 Status: (Zigate) filename set to /home/loops/domoticz/plugins/Zigate/Conf/PluginConf-05.json
2019-10-21 17:03:50.903 Status: (Zigate) pluginHome set to /home/loops/domoticz/plugins/Zigate/
2019-10-21 17:03:50.903 Status: (Zigate) homedirectory set to /home/loops/domoticz/plugins/Zigate/
2019-10-21 17:03:50.903 Status: (Zigate) pluginData set to /home/loops/domoticz/plugins/Zigate/Data/
2019-10-21 17:03:50.903 Status: (Zigate) pluginConfig set to /home/loops/domoticz/plugins/Zigate/Conf/
2019-10-21 17:03:50.903 Status: (Zigate) pluginOTAFirmware set to /home/loops/domoticz/plugins/Zigate/OTAFirmware/
2019-10-21 17:03:50.903 Status: (Zigate) pluginReports set to /home/loops/domoticz/plugins/Zigate/Reports/
2019-10-21 17:03:50.903 Status: (Zigate) pluginWWW set to /home/loops/domoticz/plugins/Zigate/www/
2019-10-21 17:03:50.903 Status: (Zigate) Opening DomoticzDB in raw
2019-10-21 17:03:50.904 Status: (Zigate) Plugin Database: DeviceList-5.txt
2019-10-21 17:03:50.910 Status: (Zigate) DeviceConf loaded
2019-10-21 17:03:50.911 Status: (Zigate) load ListOfDevice
2019-10-21 17:03:50.912 Status: (Zigate) Entries loaded from /home/loops/domoticz/plugins/Zigate/Data/DeviceList-5.txt : 0
2019-10-21 17:03:50.912 Status: (Zigate) Transport mode: USB
2019-10-21 17:03:50.912 Status: (Zigate) Connection Name: Zigate, Transport: Serial, Address: /dev/ttyUSB1
2019-10-21 17:03:50.937 Status: (Zigate) Zigate set Time Server
2019-10-21 17:03:50.937 Status: (Zigate) Configure Permit To Join
2019-10-21 17:03:50.937 Status: (Zigate) Request Accepting new Hardware for ever
2019-10-21 17:03:50.937 Status: (Zigate) Trigger a Topology Scan
2019-10-21 17:03:50.937 Status: (Zigate) Trigger a Energy Level Scan
2019-10-21 17:03:50.937 Status: (Zigate) Network Energy Level Report: 0000
2019-10-21 17:03:50.937 Status: (Zigate) -----------------------------------------------
2019-10-21 17:03:50.937 Status: (Zigate) router <- nwkid Tx Failure 11 15 19 20 25 26
2019-10-21 17:04:00.925 (Zigate) No Firmware Version received from Zigate
2019-10-21 17:04:05.954 (Zigate) No Firmware Version received from Zigate
2019-10-21 17:04:10.953 (Zigate) No Firmware Version received from Zigate
2019-10-21 17:04:15.926 (Zigate) No Firmware Version received from Zigate
2019-10-21 17:04:15.926 (Zigate) Try to get Firmware version once more HB:4
2019-10-21 17:04:15.910 Status: (Zigate) Stop directive received.
2019-10-21 17:04:15.910 Status: (Zigate) Exiting work loop.
2019-10-21 17:04:15.938 Status: (Zigate) onStop called
2019-10-21 17:04:15.966 Error: (Zigate) Callback event 'onMessageCallback' (Python call 'onMessage') discarded.

pipiche
Messages : 955
Enregistré le : 04 avr. 2018, 16:16

Re: Mise en route Zigate -- Erreur du plugin ...

Message par pipiche » 21 oct. 2019, 18:18

Oui, je pense que un reflash peut le faire ... Sinon essaye avec l'outil ZGUI si tu es sur PC sous windows

loops
Messages : 296
Enregistré le : 13 nov. 2014, 18:14

Re: Mise en route Zigate -- Erreur du plugin ...

Message par loops » 21 oct. 2019, 18:40

Non je suis sous Linux ... Si ca marche pas, je le ferai au boulot avec ZGUI ...

loops
Messages : 296
Enregistré le : 13 nov. 2014, 18:14

Re: Mise en route Zigate -- Erreur du plugin ...

Message par loops » 21 oct. 2019, 19:49

Bon, flash du module effectué sous Linux ... le problème est encore présent ...
Sélection_132.png
Sélection_132.png (89.89 Kio) Vu 430 fois
Sélection_131.png
Sélection_131.png (114.41 Kio) Vu 430 fois

loops
Messages : 296
Enregistré le : 13 nov. 2014, 18:14

Re: Mise en route Zigate -- Erreur du plugin ...

Message par loops » 21 oct. 2019, 20:37

Re !
Bon en fait ça marche !!! Je me suis rendu compte que mon Dongle USB Téléinfo EDF ne marchait plus depuis que j'ai monté sous Proxmox le /dev/ttyUSB1 de la Zigate. J'ai éteint la Vm Domoticz et redémarré (ce que j'avais pourtant fait après la configuration du port série dans le fichier de conf de la VM) et tout s'est mis à fonctionner !!!

Merci pour le coup de main ... Je continuerai surement à ajouter à ce post pour configurer mes device Xiaomi si je suis en galère.

Merci encore !

pipiche
Messages : 955
Enregistré le : 04 avr. 2018, 16:16

Re: Mise en route Zigate -- Erreur du plugin ...

Message par pipiche » 21 oct. 2019, 21:09

loops a écrit :
21 oct. 2019, 20:37
Re !
Bon en fait ça marche !!! Je me suis rendu compte que mon Dongle USB Téléinfo EDF ne marchait plus depuis que j'ai monté sous Proxmox le /dev/ttyUSB1 de la Zigate. J'ai éteint la Vm Domoticz et redémarré (ce que j'avais pourtant fait après la configuration du port série dans le fichier de conf de la VM) et tout s'est mis à fonctionner !!!

Merci pour le coup de main ... Je continuerai surement à ajouter à ce post pour configurer mes device Xiaomi si je suis en galère.

Merci encore !
Super. Regardes coté udev pour configuré les ports de façon static
https://www.domoticz.com/wiki/Linux#Set ... _udev_rule

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre