Sonde temperture zwave

Tout ce que vous avez toujours voulu savoir sur le Z-Wave, protocole, equipements, interface,s ...
Répondre
Olivier_1968
Messages : 28
Enregistré le : 30 sept. 2018, 18:34

Sonde temperture zwave

Message par Olivier_1968 » 29 déc. 2019, 14:50

Bonjour à tous,

Depuis que j'utilise Domoticz sur ma Raspberry j'ai régulièrement des pertes de connexions avec mes sondes de température.
La première sonde est intégrée à mon détecteur d'inondation , à chaque changement de piles les données de température ne sont plus recues par domoticz.
Ma deuxieme sonde est une onewire connectée à un module FIBARO System FGBS001 Universal Binary Sensor, sans raisons apparentes la sonde a cessé de transmettre des données, c'est déjà arrivé a plusieurs reprise à chaque fois c'est le bazar il faut que je retire le FGBS du réseau Zwave, que je supprime l'appareil de domoticz et je recommence l'inscription. Du coup je perd tout l'historique.
Quelqu'un aurait-il une solutions pour fiabiliser ces sondes ? y a-t-il une solutions pour les "récupérer" sans tout réinitialiser ?

Merci d'avance

Olivier

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


balajol
Messages : 683
Enregistré le : 13 nov. 2015, 18:54
Localisation : 62

Re: Sonde temperture zwave

Message par balajol » 29 déc. 2019, 18:26

Bonsoir,
Pour la sonde reliée à un FGBS001, Vérifie qu'une nouvelle sonde ne se soit pas créé.
J'en ai sur plusieurs modules qui changent de modèle de façon aléatoire , en passant bien souvent de sonde T° seule à T° et H° .
Pour les repérer tu vas sur la liste des dispositifs et tu mets dans le pavé "recherche" le Numéro de Nœud du FGBS..
Ne supprime pas le dispositif de la sonde d' origine, parfois tout revient à la Normale de façon inopinée..
Je soupçonne que le phénomène se produit au redémarrage de Domoticz.

Pour les sondes les plus fiables, les sondes Orégon en 433 sont parfois Muettes, j'utilise un script qui vérifie qu'elle émettent régulièrement.

http://easydomoticz.com/forum/viewtopic ... e&start=10

Je teste actuellement une sonde sur un sonoff en WIFI, le signal semble être stable dans le temps.
Cdt
Bertrand
v4.9700 sur PC Windows10 (Elite book); DANFOSS LC13, Topp; Senseurs univ FIBARO FGBS001, Flood Sensor, ZMNHBD1 Flush 2 Relays ; FIBARO FGS222-FGS212;RFXCOM-RFXtrx433 USB 433.92MHz , Prises Phénix, Prises et Eclairage DI-O, SOMFY RTS,Sonoff etc..

Chrominator
Messages : 446
Enregistré le : 19 déc. 2015, 07:29

Re: Sonde temperture zwave

Message par Chrominator » 30 déc. 2019, 13:04

On peut ne pas perdre l'historique quand on remplace un capteur de température ;
Pour cela, après un changement de piles par exemple, DZ attribue un nouvel ID à ce capteur pourtant déjà existant.
Na pas oublier d'autoriser les nouveaux devices à cette occasion, et de donner un nom dont on aura besoin plus bas....

A ce stade, pour conserver l'historique, il convient de cliquer sur la roue dentée de l'ancien capteur
Screenshot_2019-12-30 Domoticz.png
Screenshot_2019-12-30 Domoticz.png (8.98 Kio) Vu 295 fois
puis de cliquer sur Remplacer et de sélectionner le nouveau capteur dans la liste qui s'affiche par le nom qu'on lui a donné.
Screenshot_2019-12-30 Domoticz(1).png
Screenshot_2019-12-30 Domoticz(1).png (9.05 Kio) Vu 295 fois
L'ancien capteur disparait, le nouveau le remplace et reprend l'historique.

Ensuite, si des scripts faisaient référence à ce capteur par son index, il va falloir les revoir un par un ou envisager sérieusement de les modifier pour n'utiliser que le nom du capteur. :D

Olivier_1968
Messages : 28
Enregistré le : 30 sept. 2018, 18:34

Re: Sonde temperture zwave

Message par Olivier_1968 » 30 déc. 2019, 13:20

Bonjour,

Merci à tous les deux pour vos conseils.
Je vais les suivre et voir ce que cela va donner.

Olivier

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Olivier_1968
Messages : 28
Enregistré le : 30 sept. 2018, 18:34

Re: Sonde temperture zwave

Message par Olivier_1968 » 30 déc. 2019, 13:44

Je reviens sur la réponse de Bertrand,

Il est arrivé exactement ce que décrit Bertrand, ma sonde de température qui avait un sous type : LaCrosse TX3 a été recrée avec un sous type : WTGR800 et indique maintenant la température mais aussi l'humidité et le point de rosée, c'est très fort !!!
Comment est-ce que je peux revenir à un sous type normal 'LaCrosse TX3' ?
Comme le sous type est différent je ne peux pas utiliser la fonction "remplacer" comme suggéré dans la réponse ci dessus.

Merci d'avance

Olivier

balajol
Messages : 683
Enregistré le : 13 nov. 2015, 18:54
Localisation : 62

Re: Sonde temperture zwave

Message par balajol » 31 déc. 2019, 12:46

Bonjour,
Personnellement je créé une sonde virtuelle Température qui est mise à jour par un script.
Il suffit de modifier le script pour changer de sonde physique. De cette façon c est l 'historique de la virtuelle qui continu de être mis à jour.
Cdt
Bertrand
v4.9700 sur PC Windows10 (Elite book); DANFOSS LC13, Topp; Senseurs univ FIBARO FGBS001, Flood Sensor, ZMNHBD1 Flush 2 Relays ; FIBARO FGS222-FGS212;RFXCOM-RFXtrx433 USB 433.92MHz , Prises Phénix, Prises et Eclairage DI-O, SOMFY RTS,Sonoff etc..

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre