[Résolu] Problème 1-wire sur Raspberry

Le bus 1-Wire, connectique, et intégration dans Domoticz
Répondre
jmv75013
Messages : 117
Enregistré le : 03 janv. 2017, 16:20

[Résolu] Problème 1-wire sur Raspberry

Message par jmv75013 » 13 janv. 2018, 18:28

Bonjour,

J'ai sur mon raspberry PI2 deux sondes DS18B20 qui fonctionnaient. J'ai un problème avec mon disque dur (le PI boote sur un disque dur ) que j'ai réparé après réinstallation je n'ai plus de 1-wire, les sondes ne sont pas mises à jour dans domoticz

Je n'ai plus de répertoire w1 dans /sys/bus

J'ai essayé la commande :

Code : Tout sélectionner

sudo modprobe w1-gpio
et j'obtiens l'erreur suivante :

Code : Tout sélectionner

modprobe: ERROR: ../libkmod/libkmod.c:557 kmod_search_moddep() could not open moddep file '/lib/modules/4.1.19+/modules.dep.bin'
Il n'y a pas de répertoire 4.1.19+ dans /lib/modules

Je sais que ce n'est pas un problème lié à domoticz, mais quelqu'un peut-il m'aider?

Merci

J-Marc
Modifié en dernier par jmv75013 le 15 janv. 2018, 10:57, modifié 1 fois.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


PeM
Messages : 61
Enregistré le : 24 nov. 2016, 14:32

Re: Problème 1-wire sur Raspberry

Message par PeM » 13 janv. 2018, 21:14

et si tu fais un

Code : Tout sélectionner

sudo modprobe w1-therm
parceque pour moi le gpio c'est pour la gestion du gpio si tu veux utiliser des ds 18B20 c'est therm qu'il faut utiliser

jmv75013
Messages : 117
Enregistré le : 03 janv. 2017, 16:20

Re: Problème 1-wire sur Raspberry

Message par jmv75013 » 13 janv. 2018, 22:28

Bonsoir
Tu as raison, mais j'ai la même erreur
Merci

jmv75013
Messages : 117
Enregistré le : 03 janv. 2017, 16:20

Re: Problème 1-wire sur Raspberry

Message par jmv75013 » 15 janv. 2018, 10:57

Bonjour,

J'ai trouvé la solution à mon problème.
un rpi-update a remis les choses en ordre.

Merci

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


PeM
Messages : 61
Enregistré le : 24 nov. 2016, 14:32

Re: [Résolu] Problème 1-wire sur Raspberry

Message par PeM » 15 janv. 2018, 19:00

Ah ben t'as du bol! moi sur les vieilles distrib un rpi-update ca fait que je suis obligé de sortir ma sauvegarde...

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre