Port GPIO

Le bus 1-Wire, connectique, et intégration dans Domoticz
Répondre
meche_3_1
Messages : 1
Enregistré le : 29 mars 2020, 14:10

Port GPIO

Message par meche_3_1 »

Bonjour à tous .

J'etait sous une version plus ancienne de plus de 3 ans . Et en ce temps de confinement j'ai téléchargé un nouvelle OS pour le RaspBerry et Installer Domoticz 2020.1

Pourquoi ne pas faire les mises a jour , car il me manquait une librairie et donc domoticz ne voulais plus démarrer.


J'ai donc un module Zwave , sa de ce coté la tout fonctionne, ainsi que le module RFXCOM

Voilà je pilote plusieurs chose par le port GPIO .
Ou j'ai du inverser les relais dans le domoticz.sh
Par la commande
sudo sh -c "echo '1' >> /sys/class/gpio/gpio21/active_low" de ce coté la pas de soucis
Quand je dis ON sur Domoticz le relais colle bien .

Le soucis est lorsque le raspi redemarre ou alors que je redemarre le service domoticz , les relais reste collé alors que dans domoticz il sont sur OFF . Je dois dans l'interface appuyer sur ON et ensuite sur OFF pour reprendre un état normal .
Et pareil si j'arrete le service domoticz , la tous les relais colle et si je redemerre je reste dans le même etat .

Le soucis c'est que je pilote une pompe de relevage cumulus ect... et je peux pas me permettre d'avoir un etat hasardeux.

Je penserais a une ligne de commande sous domoticz.sh pour piloter l"état des relais au redémarrage.

Merci pour vos suggestions ;)

Neutrino
Messages : 1526
Enregistré le : 10 juil. 2015, 15:42
Localisation : Challans (85)
Contact :

Re: Port GPIO

Message par Neutrino »

J'utilise ça : https://easydomoticz.com/forum/viewtopic.php?f=17&t=456
J'ai simplement ajouté le lancement du script dans domoticz.sh à la fin du do_start().
ça date un peu, il y a d'autres solutions sans doute plus simple.

Il faudrait peut-être chercher aussi pourquoi un reboot colle les relais.
Le passage en active low ne change pas l'état normalement.
Ma maison à plein d'IP ! :mrgreen:
SAV Bonjour. Vous avez vidé le cache ?

sphinxou
Messages : 177
Enregistré le : 03 déc. 2016, 13:37

Re: Port GPIO

Message par sphinxou »

bonjour
j'avais le même problème que toi rajoute
usr/bin/gpio export 17 high
Domoticz 4.9700/ rfxcom /sonde diy/raspberry pi3+HDD/cirusms/contact de porte diy

samourai47
Messages : 118
Enregistré le : 04 déc. 2018, 19:44

Re: Port GPIO

Message par samourai47 »

hello
Va voir icihttps://easydomoticz.com/forum/viewtopic.php?f=9&t=2633
Ca a marche pour moi j'avais le meme soucis sur une carte relai commandant la pompe de filtration de pisicne

Répondre