Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

les autres capteurs : Sondes Météo, switches
mulot35
Messages : 200
Enregistré le : 20 déc. 2014, 00:27

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par mulot35 »

Pour ma part:
-Sans la valeur PAPP maintenant ca "marche" c'est a dire que le module téléinfo apparait on a les HC-HP toutefois on a pas l'instantané d'affiché.
C'est resté coincé http://www.domoticz.com/forum/viewtopic.php?f=6&t=6389.
Raspi B+ avec Domoticz ,6 Chacon 2300W , 6 Sondes Oregon, 1 Sonde DIY Oregon ds18b20, Téléinfo sur photovoltaique, script backup ftp & anti offline.

Domotifan
Messages : 49
Enregistré le : 29 sept. 2015, 08:47

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par Domotifan »

Salut Mulot35 ! Bah, c'est bien tout ça, mais le teleinfo.h et le teleinfo.cpp je les met où ?
J'ai cherché dans les divers rép. de Domoticz, mais je ne vois pas ces 2 fichiers...
A rajouter peut-être ? mais où ? :roll:

mulot35
Messages : 200
Enregistré le : 20 déc. 2014, 00:27

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par mulot35 »

Normalement si ton domoticz est a jour du doit avoir ton téléinfo avec ou sans Papp.
Pour la mise en place d'un nouveau .h et .cpp il faut recompiler domoticz (je ne l'ai jamais fait).
Raspi B+ avec Domoticz ,6 Chacon 2300W , 6 Sondes Oregon, 1 Sonde DIY Oregon ds18b20, Téléinfo sur photovoltaique, script backup ftp & anti offline.

Domotifan
Messages : 49
Enregistré le : 29 sept. 2015, 08:47

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par Domotifan »

Oui, j'ai bien TELEINFO USB qui apparait, mais comme je disais, je n'ai rien d'autre que l'index compteur qui apparait et rien d'autre.
La recompil, compilqué tout ça, et puis pas logique non ? :roll:
Je suis tout de même surpris que le tarif TEMPO intéresse si peu de monde. :?

thor4785
Messages : 5
Enregistré le : 18 juin 2015, 11:44

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par thor4785 »

Bonjour,

J'ai un soucis similaire au votre.

A la première installation du dispositif je n'ai aucun soucis je vois bien la consommation instantané et aucn soucis dans domoticz

Les choses se compliquent après un reboot, mon domoticz n'a plus aucune valeur.

J'ai utilisé ce topic là pour faire ma téléinfo.

http://easydomoticz.com/raspberry-et-teleinfo/

lorsque je reboot et que je fais un sudo cat /dev/ttyAMA0 je n'ai plus les infos du compteur je suis obligé de refaire à chaque fois la commande suivante = sudo stty -F /dev/ttyAMA0 1200 sane evenp parenb cs7 -crtscts ( du coup j'ai remis cette ligne dans le inittab )

là du coup lorsque je refais un sudo cat /dev/ttyAMA0 je reçois bien les trames du compteur mais ça ne remonte pas dans le domoticz je suis obligé d'enlever le matériel et le remettre et là ça repart.

merci de votre aide

deennoo
Messages : 4023
Enregistré le : 25 janv. 2015, 02:00

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par deennoo »

Moi aussi j'ai fait des tests, pleins pour la teleinfo en direct sur le PI, par arduino, par radio (avec le scripts de snips),et dernièrement pour un module Teleinfo par Wifi (qui est encore en développement mais qui marche le mieux de tous)

Sur un compteur SAGEM et le Linky.

Sans trop l'étendre allez lire le site de Charles, qui c'est spécialisé dans la télé information et qui donne énormément d'info :
http://hallard.me
De quoi se faire Plaisir et essayer d'aider...
http://www.domo-attitude.fr

rodomo
Messages : 7
Enregistré le : 06 déc. 2015, 18:37

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par rodomo »

Bonjour à tous,

Je me permets de répondre à cette discution après avoir lu la réponse de Jose du début de l'année.
Jose a écrit : Une trame classique est formée de la sorte:

ADCO 0XXXXXX62309 D
OPTARIF HC.. <
ISOUSC 45 ?
HCHC 078323153 &
HCHP 087963311 9
PTEC HC.. S
IINST 023 \
IMAX 036 H
HHPHC C .

Effectivement, je n'ai pas MOTDETAT ni même de puissance instantanée. Mon script python fonctionne en repérant le champ ADCO.
Je serai très heureux que l'on arrive ensemble a faire bouger les choses,
En effet, j'ai aujourd'hui le même souci.

Voici mon histoire ;-) :
J'ai réalisé avec une plaque à essais sans soudure un module téléinfo, qui ressemble à celui du tuto
http://easydomoticz.com/raspberry-et-teleinfo/
hormis la résistance à 4.7K au lieu de 47K. J'ai déjà fait tourner ce montage pendant 2 ans ailleurs.

Code : Tout sélectionner

ADCO XXXXXXXXXXX>
OPTARIF HC.. <
ISOUSC 30 9
HCHC 042116615  
HCHP 034246387 8
PTEC HP..  
IINST 001 X
IMAX 009 H
HHPHC C .
MOTDETAT 000000 B
Il y a peu de temps, j'ai refait le montage sur une plaque, avec soudures cette fois pour "solidifier" le tout.
Depuis lors, ça fonctionne comme avant, mais je ne reçois plus la ligne MOTDETAT...

Code : Tout sélectionner

ADCO XXXXXXXX>
OPTARIF HC.. <
ISOUSC 30 9
HCHC 042119702
HCHP 034248882 :
PTEC HP..
IINST 001 X
IMAX 009 H
HHPHC C .
[ici on a quand même un CR-LF en plus qui devrait se trouver à la fin de a ligne MOTDETAT]
ADCO XXXXXXX>
Si un composant serait défectueux ou que le montage serait mauvais, je pense que je n'aurais pas toutes les autres lignes, sans erreur ?
Si c'est le compteur qui ne m'envoie plus MOTDETAT, pourquoi maintenant (téléinfo activée depuis une semaine) ?

Qu'en pensez-vous ?

patrice
Messages : 1667
Enregistré le : 22 sept. 2014, 21:51

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par patrice »

Bonjour
Aucun lien avec un composant quelconque, tu n'a pas changé d'abonnement ? , tu n'a pas un compteur Linksys depuis la semaine dernière ,
Maison en construction : en attente d'un nouveau terrain de jeu.

rodomo
Messages : 7
Enregistré le : 06 déc. 2015, 18:37

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par rodomo »

Merci pour ta réponse.

Je me connecte en ssh au raspberry qui reçoit les infos directement.
Je n'ai pas changé d'abonnement, ni de compteur.

Sauf erreur, j'avais encore MOTDETAT avant de démonter mes branchements et de ressouder le tout.

Je ne m'y connais pas assez sur les composants éléctroniques, mais si un des composants est endommagé, je ne vois pas le rapport avec MOTDETAT.
Toutes les autres données défilent sans erreur :?: .

berty
Messages : 9
Enregistré le : 02 juin 2015, 11:17

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par berty »

Bonsoir,

Je suppose que tu fais un 'cat /dev/ttyAMA0'?

Ce n'est pas parce que tu ne vois pas MOTDETAT que tu ne l'as pas, il y a des caractères non imprimables dans la sortie des trames téléinfo, notamment le STX (Start of frame) 0x02 et ETX (End of frame) 0x03.
Ce sont ces caractères non imprimables qui peuvent perturber l'affiche correcte des trames et "cacher" le MOTDETAT par exemple.

Le mieux est d'afficher en mode hexa: 'hexdump -C /dev/ttyAMA0'

Répondre