Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

les autres capteurs : Sondes Météo, switches
Répondre
thor4785
Messages : 5
Enregistré le : 18 juin 2015, 11:44

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par thor4785 » 10 mai 2016, 16:42

Bonjour,

J'ai le même problème que vous .. la trame s'affiche avec des caractères en plus.
Moi c'est suite à la mise de mon domoticz ( raspberry ) en version 3.48.34 avant avec l'ancienne version je n'avais aucun soucis.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


adv
Messages : 229
Enregistré le : 02 févr. 2016, 13:54
Contact :

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par adv » 19 juil. 2016, 15:15

Salut à tous, ce sujet m'a interpellé car j'ai moi même eu des symptômes bizarre avec mon télé-info connecté sur le ttyAMA0 (broche 10 du pi) - lien symbolique USB20 -> ttyAMA0.

J'avais suivi ce guide: http://easydomoticz.com/raspberry-et-teleinfo/

Mais après un reboot j'étais obligé de débrancher un des fils du report du compteur et le rebrancher pour que Domoticz "raccroche".
Avec l'option "Délais d'attente des données" activé à une minute sur le /dev/ttyUSB20 pas de mieux...

J'ai donc modifié la partie hardware... l'optocoupleur est donc maintenant relié au RX d'un convertisseur USB -> série TTL à base de PL2303HX (alim de l'opto en 3,3 volts).
Je n'ai passé aucune commande particulière pour la config... un cat /dev/ttyUSB1 affiche les trames (et j'ai pu le re-verifier avec une fresh install !)

J'ai quand même positionné le "Délais d'attente des données" à 1 minute, juste au cas où...

J'ai rebooté pas mal de fois pour tester: plus de bug je suis ravi et ça m'a pas couté cher !

Module trouvable partout sur ebay par exemple: USB UART Arduino TTL RS232 - PL2303HX - Convertisseur Adaptateur 5V 3,3V Module

A+
Fichiers joints
téléinfoUSB.png
téléinfoUSB.png (555.68 Kio) Vu 7096 fois
téléinfoDomoticz.png
téléinfoDomoticz.png (50.33 Kio) Vu 7096 fois
Raspberry pi 3 - Domoticz beta | Piface v.2 + Téléinfo + RFXtrx433E + Aeon Z-Wave+GEN5
sondes Oregon | motorisations Somfy Yslo Flex 2 RTS | prises chacon | Fibaro FGD-212, FGSD002, FGFS101 | Sonoff easyESP, Tasmota, Espurna | Sherlock S2 | ParadoxMG5050

dimitry
Messages : 16
Enregistré le : 02 août 2015, 11:10

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par dimitry » 23 août 2016, 08:50

Salut,
J'ai acheté le module dont tu parles et installé comme tu l'as décrit. Par contre ça ne marche pas alors que sur la pin 10, ça roulait. Tu n'as vraiment rien installé niveau soft ?
raspberry B+
domoticz V4.10841

ludo37
Messages : 8
Enregistré le : 10 sept. 2016, 16:21

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par ludo37 » 10 sept. 2016, 16:24

mis en place et fonctionnel, en toute simplicité comme décrit par adv.
adv a écrit :Salut à tous, ce sujet m'a interpellé car j'ai moi même eu des symptômes bizarre avec mon télé-info connecté sur le ttyAMA0 (broche 10 du pi) - lien symbolique USB20 -> ttyAMA0.

J'avais suivi ce guide: http://easydomoticz.com/raspberry-et-teleinfo/

Mais après un reboot j'étais obligé de débrancher un des fils du report du compteur et le rebrancher pour que Domoticz "raccroche".
Avec l'option "Délais d'attente des données" activé à une minute sur le /dev/ttyUSB20 pas de mieux...

J'ai donc modifié la partie hardware... l'optocoupleur est donc maintenant relié au RX d'un convertisseur USB -> série TTL à base de PL2303HX (alim de l'opto en 3,3 volts).
Je n'ai passé aucune commande particulière pour la config... un cat /dev/ttyUSB1 affiche les trames (et j'ai pu le re-verifier avec une fresh install !)

J'ai quand même positionné le "Délais d'attente des données" à 1 minute, juste au cas où...

J'ai rebooté pas mal de fois pour tester: plus de bug je suis ravi et ça m'a pas couté cher !

Module trouvable partout sur ebay par exemple: USB UART Arduino TTL RS232 - PL2303HX - Convertisseur Adaptateur 5V 3,3V Module

A+

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Alex
Messages : 3
Enregistré le : 19 janv. 2015, 23:42

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par Alex » 12 juil. 2017, 20:28

Bonjour,

Je réveille ce vieux sujet car je suis dans la même situation que les derniers qui ont posté, je suis sur un RPI2 avec la dernière version stable (3.5877).
J'avais le compteur branché par le montage que l'on trouve un peu partout, directement sur le RX du GPIO, tout marchait nickel depuis décembre 2014.
Et d'un coup la semaine dernière plus de mesures de conso.
Je fais un cat sur le tty et je vois qu'il n'y a plus de retour à la ligne, pour chaque groupe de données un ne vois au final qu'un ligne:

Code : Tout sélectionner

5OPTARIF HC.. <2334 ;
5OPTARIF HC.. <2334 ;
5OPTARIF HC.. <2334 ;
5OPTARIF HC.. <2334 ;
En réinitialisant le tty, l'affichage semble normal, mis à part qu'un caractère parasite en début de ligne:

Code : Tout sélectionner

ISOUSC 30 9
OHCHC 021159489 -
PHCHP 023018408 -
7PTEC HP..
;IINST1 002 J
.IINST2 009 R
 IINST3 002 L
9IMAX1 024 6
0IMAX2 027 :
PIMAX3 019 <
IPMAX 08340 5
IPAPP 02860 1
IHHPHC A ,
LMOTDETAT 000000 B
XPPOT 00 #
AXADCO 701209412334 ;
5OPTARIF HC.. <
Dès que je relance le matériel téléinfo sous domoticz, c'est reparti, plus de retour chariot.
En lisant ce post, je me dis que je vais essayer le convertisseur USB vers TTL UART a base de PL2303HX, je l'achète, installation rapide, pas de souci, /dev/ttyUSB0 dispo et actif.... mais.... toujours exactement le même problème!

Donc je voulais voir si après 1 an d'inactivité sur ce topic quelqu'un avait compris le souci!
Mon compteur est une gyr+landis tri-phasé.

Merci à ceux qui ont des infos pour moi!
RPi 2 avec Domoticz / RFXTRX433 / Synology DS414
5 Sondes DS18B20 / 1 Sonde Oregon / 2 Sondes Alecto Chinoises / 2 Contacteurs filaires / 1 Relais sur Télécommande Nice / TéléInfo EDF
2 Cameras IP

dimitry
Messages : 16
Enregistré le : 02 août 2015, 11:10

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par dimitry » 19 juil. 2017, 21:12

Salut Alex,
Pour info, j’ai toujours le même problème que toi. Depuis 1 mois la connexion teleinfo se remet à bugger.
Je pense que j'ai le même compteur que toi...
raspberry B+
domoticz V4.10841

js-martin
Messages : 469
Enregistré le : 22 mars 2015, 22:08
Contact :

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par js-martin » 04 déc. 2017, 16:02

J'ai eu moi aussi un bug... que j'ai résolu 8-)

Tout d'abord, en bricolant, je me suis retrouvé avec beaucoup d'erreurs dans mes logs Domoticz:

Code : Tout sélectionner

2017-12-04 12:53:34.133 Error: (Teleinfo1 - consommation) CRC check failed on Teleinfo line 'P0 MOTDEA 000BADCO 0122149' using both modes 1 and 2. Line skipped.
2017-12-04 12:53:34.191 Error: (Teleinfo2 - production) CRC check failed on Teleinfo line 'ADC 0318701627' using both modes 1 and 2. Line skipped.
2017-12-04 12:53:34.284 Error: (Teleinfo1 - consommation) CRC check failed on Teleinfo line '308706 OPTARFBE0' using both modes 1 and 2. Line skipped.
2017-12-04 12:53:34.340 Error: (Teleinfo2 - production) CRC check failed on Teleinfo line 'DTAT0 O022 OARI BAS' using both modes 1 and 2. Line skipped.
2017-12-04 12:53:34.403 Error: (Teleinfo1 - consommation) CRC check failed on Teleinfo line 'I AS ISOS 0 ' using both modes 1 and 2. Line skipped.
2017-12-04 12:53:34.461 Error: (Teleinfo2 - production) CRC check failed on Teleinfo line 'PTFE 0ISUSC15' using both modes 1 and 2. Line skipped.
2017-12-04 12:53:34.563 Error: (Teleinfo1 - consommation) CRC check failed on Teleinfo line ' 1274 ' using both modes 1 and 2. Line skipped.
2017-12-04 12:53:34.620 Error: (Teleinfo2 - production) CRC check failed on Teleinfo line 'BE0135' using both modes 1 and 2. Line skipped.
Pourtant, en faisant un CAT sur mon device, cela semblait correct :

Code : Tout sélectionner

$ cat ttyUSB1

PAPP 00180 *
MOTDETAT 000000 B
ADCO 031028270164 9
OPTARIF BASE 0
ISOUSC 30 9
BASE 019207552 *
PTEC TH.. $
IINST 001 X
IMAX 039 K
... mais ce n’était pas bon...

il faut en effet un retour à la ligne en plus.

un coup de :

Code : Tout sélectionner

sudo stty -F /dev/ttyUSB1 1200 sane evenp parenb cs7 -crtscts
dans : sudo nano /etc/rc.local et c'est mieux :

Code : Tout sélectionner

$ cat ttyUSB1

PAPP 00180 *

MOTDETAT 000000 B

ADCO 031028270169 9

OPTARIF BASE 0
(il y a les retours à la ligne)

Ensuite, j'avais mis des noms explicite dans mes "persistants USB" :

ttyUSB1 => ttyUSB-consommation

et cela me faisait bugger Domoticz !!

un simple changement de nom en

ttyUSB1 => ttyUSBC

et c'est reparti sans erreur.

Si cela peut aider quelqu'un...
Domotisation de : mes compteurs EDF, solaire, eau / mon alarme / ma Chaudière Viessamnn / mon congel / ma sonnette. Matériels : Pi2 - RFXTrx433e - Zwave+ Aeotec, ampoules Hue - Détecteur et prises Fibaro - Capteurs Oregon - présentation installation => lien

Ykoto07
Messages : 1
Enregistré le : 11 déc. 2017, 21:30

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par Ykoto07 » 11 déc. 2017, 21:37

patrice a écrit :Bonjour

Je vous fait par ici de la fin d'une discussion dans les commentaires du blog concernant la non détection du module teleinfo par Domoticz.
Salut,
Suite de mes péripéties surement Rachat prêt un probleme sur mon compteur EDF.
Je m’explique:
-Distrib toute neuve / meme montage / 4heures de desespoir
-Décision de remballer
-et pis si allez j’essaye sur le photovoltaique et bim le p1 smart meter apparait alors que le matériel est désactivé.
-j’active et la bim la production en instantané
-je rebranche sur le compteur edf et la rien…

Donc affaire bizarre je recois la trame sous putty mais domoticz n’en veux pas et pour le photovoltaique je recois la trame sous putty et domoticz le prend.

Compteur edf : Sagem S10C1
Compteur photovoltaique : Sagem S10C4

trame edf non fonctionnelle:
MOTDETAT 000000 B
ADCO 029701401358 ?
OPTARIF HC.. <
ISOUSC 30 9
HCHC 057450434 &
HCHP 056376988 G
PTEC HP..
IINST 002 Y
IMAX 031 C
HHPHC D /
MOTDETAT 000000 B
ADCO 029701401358 ?
OPTARIF HC.. <


Voila peut etre un defaut de reconnaissance ???
Il semble donc qu'il y ait des trames différentes suivants les types de compteurs car sur le mien qui fonctionne correctement (S10C4) je n'ai pas le terme MODETAT d'envoyé

Et vous qui avez rencontré des soucis d'intégration (Jihem,José) quel modèle avez vous ?
Je ne comprend pas??

ChrisS
Messages : 16
Enregistré le : 21 févr. 2017, 13:17

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par ChrisS » 20 mars 2018, 08:52

Bonjour j'ai le même problème d'un jour à l'autre ma conso EDF n'apparaît plus, j'ai fais vos manipulations et j'ai effectivement exactement le même problème avec un Landis Gyr Triphasé.
Pourriez vous me donner les lignes de commande pour changer le nom de mon port USB ?
Merci
Conf Domoticz:
RFXcom, Téléinfo, Netatmo, Milight...

manuloup
Messages : 480
Enregistré le : 18 févr. 2015, 13:05

Re: Teleinfo : un début d'explication à la non reconnaisance par Domoticz ?

Message par manuloup » 28 mai 2018, 19:13

Bonjour,

Je fais remonter ce fil car il m'arrive un problème un peu similaire. Je précise que cette même configuration (domoticz, rpi2 avec Raspbian, Teleinfo USB..) fonctionnait parfaitement dans mon ancien logement. Ce n'est plus le cas dans ma nouvelle maison, qui est équipé d'un Linky.

J'en viens à penser qu'il y a un souci avec la lecture de mes trames par Teleinfo.cpp . La valeur PAPP est ignoré, la valeur de conso instantanée est calculée en se basant sur la valeur IINST, bien moins précise.

Voici un exemple de trame :
root@raspberrypi2:/home/pi# cat /dev/ttyUSB0
05 \
IMAX 060 E
PAPP 01060 (
HHPHC A ,
MOTDETAT 000000 B
ADCO 031764199281 J
OPTARIF HC.. <
ISOUSC 60 <
HCHC 000261043 V
HCHP 000378949 ;
PTEC HP..
IINST 005 \
IMAX 060 E
PAPP 01060 (
HHPHC A ,
MOTDETAT 000000 B
ADCO 031764199281 J
OPTARIF HC.. <
ISOUSC 60 <
HCHC 000261043 V
HCHP 000378950 3
PTEC HP..
IINST 005 \
IMAX 060 E
PAPP 01060 (
Voilà, si vous avez des pistes, je suis preneur.

Manu
Rapberry PI 2 (RaspBian), RFplayer, Aeon Labs Z-Stick Gen5, Everspring ST814 Temperature Sensor, Everspring SF812 Smoke Detector, 4x Fibaro Wallplug, Aeon Zwave Miniremote , Teleinfo USB

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre