[Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

les autres capteurs : Sondes Météo, switches
Madcat
Messages : 14
Enregistré le : 13 oct. 2017, 20:41

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par Madcat »

Bonjour à tous,
Il semblerait qu'à la suite d'une mise à jour de l'une des bibliothèques, le sketch ne fonctionne plus... J'ai ce message d'erreur:
/Users/Moi/Documents/Arduino/ATtiny85_DHT11_433MHz/ATtiny85_DHT11_433MHz.ino: In function 'void setup()':
/Users/Moi/Documents/Arduino/ATtiny85_DHT11_433MHz/ATtiny85_DHT11_433MHz.ino:517:37: warning: large integer implicitly truncated to unsigned type [-Woverflow]
setId(OregonMessageBuffer, NODE_ID);
^
Puis les erreurs s'enchainent, puis tout se termine par :
avrdude: Device signature = 0x000000
avrdude: Yikes! Invalid device signature.

Pour info, j'ai programmé une dizaine d'attiny sans problème jusqu'à maintenant... La seule chose ayant changé a été une mise à jour des bibliothèques, mais cela me dépasse...
Si quelqu'un peut me confirmer si le tutoriel fonctionne toujours ou si c'est moi qui ait un souci...
Cordialement,

herve56
Messages : 13
Enregistré le : 11 janv. 2019, 11:42

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par herve56 »

Bonjour,
J'ai une question concernant la consomation...
j'utilise ce script seulement avec un red (detecteur de porte et pas de sonde); la consommation au repos est de 4,77mA et lors d'une emission de signal, 14mA.
Je pensais qu'au repos, la conso est de quelque micro Amp, mais pas de quelque milliamps..
Quelqu'un peut-il m'expliquer ou ai-je mal compris..?
Merci

vil1driver
Messages : 5502
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par vil1driver »

Tout se joue sur les résistances du montage, qu'as tu mis ? Tu as suivi le plan ?
Car cela devrait être beaucoup moins assurément
MAJ = VIDER LE CACHE(<-Clicable)
/!\Les mises à jour de Domoticz sont souvent sources de difficultés, ne sautez pas dessus
modules.lua

Un ex domoticzien

herve56
Messages : 13
Enregistré le : 11 janv. 2019, 11:42

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par herve56 »

J'ai suivi les valeurs des resistance de la page 1 a savoir un R de 1M
Donc :
+ de la Batt => Red => Resistance 1M => - de la Batt
=> Resistance 1M => input Attiny

Donc en fait, ma conso au repose et de :
Tension piles (environ 3V : Resistance) + la conso de l'emmetteur433

PS: ma source est 2 piles AA

vil1driver
Messages : 5502
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par vil1driver »

C'est étrange, perso je re contrôlerais la valeur des résistances..
Sinon c'est reed et non red que tu veux dire ?
MAJ = VIDER LE CACHE(<-Clicable)
/!\Les mises à jour de Domoticz sont souvent sources de difficultés, ne sautez pas dessus
modules.lua

Un ex domoticzien

herve56
Messages : 13
Enregistré le : 11 janv. 2019, 11:42

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par herve56 »

Effectivement Red (reed c'est d'autre projet) en fait un detecteur magnetique d'ouverture de porte tout bete.
Je vais reverifier mes valeur de Resistance.

herve56
Messages : 13
Enregistré le : 11 janv. 2019, 11:42

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par herve56 »

mais du coup, en pratique qu'elle valeur de conso mini devrais-je pouvoir attendre ?
et je n'ai pas de condo car je ne vois pas l'interet pour un contact sec...ai-je correct?
Merci encore

vil1driver
Messages : 5502
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par vil1driver »

Le condo, non pas vraiment d'intérêt, si tout va bien..

Pour la conso, j'avoue n'avoir fait de mesures qu'avec une ds18b20..

Mais bon u=r.i
Donc 3/1000000, on est loin des 4mA en principe..
MAJ = VIDER LE CACHE(<-Clicable)
/!\Les mises à jour de Domoticz sont souvent sources de difficultés, ne sautez pas dessus
modules.lua

Un ex domoticzien

herve56
Messages : 13
Enregistré le : 11 janv. 2019, 11:42

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par herve56 »

bon, j'avance sur les mesures...
J'ai refais le montage sur une breadboard sans le module 433 et la au repos, 0mA (mon multimetre n'est pas assez precis pour mesurer les micro..) et lorsque j'active le contact, le conso est d'environ 4mA pour une fraction de secondes.

J'ai branché mon module 433 direct sur le 3V sans rien d autre, et la, 18mA en continue.

j'ai tout rebranché attiny + module 433 et la, 8mA pendant 1-2 sec (phase de boot je presume) et ensuite au repos, toujours 4mA et 13 en Transmission...

Bon apres il faut que je remette dans l'electro car module 433 seul consomme 13mA et avec le Red et Attiny, 4mA...

herve56
Messages : 13
Enregistré le : 11 janv. 2019, 11:42

Re: [Tuto diy] Fabriquer sonde radio Oregon a 5€ pour les nuls V2

Message par herve56 »

peut etre cela vient du module 433. j'ai essayé avec un autre module similaire qu'il me reste et meme mesures

https://www.aliexpress.com/item/3273733 ... 4c4dvMt4Ii

Répondre