Teleinfo WIFI

les autres capteurs : Sondes Météo, switches
le belge
Messages : 346
Enregistré le : 12 déc. 2016, 19:02

Re: Teleinfo WIFI

Message par le belge » 02 déc. 2017, 18:14

stephdes a écrit :Je vais passer une 2° couche de peinture sur mon plafond et je te détaille ça ! ;)

A toute
y a pas le feu , va pas mettre de la peinture sur le clavier quand même :lol: :lol: :lol:

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


stephdes
Messages : 263
Enregistré le : 06 oct. 2016, 20:50

Re: Teleinfo WIFI

Message par stephdes » 02 déc. 2017, 20:09

Après avoir passé x heures sur ce p*** de plafond que l'ancien proprio a dévalisé, il est fini et... Je ne suis pas satisfait du résultat. (maniaquerie sort de ce corps...)

Bref, revenons à nos wemos. Pour commencer j'ai pris ma fidèle Wemos de test.

1°/ Une bonne remise à zéro : https://easydomoticz.com/forum/viewtopi ... =24&t=5366

2°/ j'ai télécharger : le LibTeleinfo-static depuis le github de Doume et le ESP8266FS-0.2.0.zip

3° / j'ai placé le fichier esp8266fs.jar dans le dossier C:\Program Files (x86)\Arduino\tools\ESP8266FS\tool

4° / j'ai lancé mon Arduino IDE (1.6.5) avec la version 2.3.0 de la carte esp82266 (board manager)
(attention, je précise que mon installation d'Arduino IDE est propre càd pas de librairie dans les fichiers temporaires ni ailleurs...)

5°/ je suis allé dans Croquis / include library puis add .zip library et j'ai ajouté la librairie LibTeleinfo-static.zip

6° / Il me manquait la librairie NeoPixelBus je suis donc allé dans Croquis / include library puis manage libraries puis j'ai recherché et installé NeoPixelBus by Makuna.

7 °/ J'ai fermé l'Arduino IDE et je l'ai relancé

8°/ j'ai fait fichier / Exemples / LibTeleinfo / Wifinfo : là, une nouvelle fenêtre avec le sketch (et ses dépendances : plusieurs onglets) s'ouvre.

J'ai enregistré le sketch dans un dossier que j'ai appelé Wifinfo.

Dans ce dossier, j'ai créé un autre dossier "data" et j'ai collé le fichier Wifinfo.spiffs.bin précédemment donné par Doume

9°/ je suis allé dans Outils puis j'ai réglé :

- Type de carte : Wemos D1 R2 & mini
- CPU Frequency : 160 Mhz (attention, bien mettre 160Mhz...)
- Flash size : 4M (1M SPIFFS)
- Upload speed : 115200
- PORT : COM4 (mais ça c'est selon ton port)

10° / Croquis / Téléverser

11° / Une fois le téléversement terminé : j'ai fait Outils / ESP8266 Sketch Data Upload : le flash du SPIFFS a démarré.

12° / Une fois terminé j'ai débranché et rebranché la wemos et je me suis connecté au wifi diffusé par la wemos pour faire les réglages

C'est stable depuis que je l'ai mis en marche !
MiniPC W10 + RFXCom 433e Ext1013 + RFLINK R45; 1 temp Bresser + 4 Banggood, lumières+volets+prises:Blyss
Autre modules volets chinois - RM Mini3 + RM PRO 2
Conso élec : OWL 180+ -- 2 Wattmètres OTIO
Imperihome+Sarah+MDAH+Domoticz (merci easydomoticz !)

le belge
Messages : 346
Enregistré le : 12 déc. 2016, 19:02

Re: Teleinfo WIFI

Message par le belge » 02 déc. 2017, 20:41

allez je me lance !!!

j'arrive pour te faire un compte-rendu ! ;)

edit : je pense que j'ai un souci avec ma wemos ... je n'arrive même plus à la remettre à zéro ....

demain je test avec un autre câble ou je remets espeasy pour tester la wemos avec une sonde de T°

fait chi€r !!!!

:oops: :oops: :oops:

dokho
Messages : 495
Enregistré le : 28 déc. 2014, 19:32

Re: Teleinfo WIFI

Message par dokho » 03 déc. 2017, 11:31

Il y a bien longtemps que j'aurais commandé un autre wemos pour vérifier... :)

Envoyé de mon SM-N9005 en utilisant Tapatalk

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


le belge
Messages : 346
Enregistré le : 12 déc. 2016, 19:02

Re: Teleinfo WIFI

Message par le belge » 03 déc. 2017, 12:18

je suis d'accord avec toi , mais dans ce cas pourquoi la wemos fonctionne avec espeasy ....

c'est à devenir fou !

le belge
Messages : 346
Enregistré le : 12 déc. 2016, 19:02

Re: Teleinfo WIFI

Message par le belge » 03 déc. 2017, 16:26

je viens de refaire un test...
est-ce que la led sur la wemos clignote toutes les secondes sur la votre ???

stephdes
Messages : 263
Enregistré le : 06 oct. 2016, 20:50

Re: Teleinfo WIFI

Message par stephdes » 04 déc. 2017, 17:05

le belge a écrit :je viens de refaire un test...
est-ce que la led sur la wemos clignote toutes les secondes sur la votre ???
Non en ce qui me concerne, toutes les 15s. Sans doute car j'ai réglé l'envoi d'info à Domoticz toutes les 15s...
MiniPC W10 + RFXCom 433e Ext1013 + RFLINK R45; 1 temp Bresser + 4 Banggood, lumières+volets+prises:Blyss
Autre modules volets chinois - RM Mini3 + RM PRO 2
Conso élec : OWL 180+ -- 2 Wattmètres OTIO
Imperihome+Sarah+MDAH+Domoticz (merci easydomoticz !)

le belge
Messages : 346
Enregistré le : 12 déc. 2016, 19:02

Re: Teleinfo WIFI

Message par le belge » 04 déc. 2017, 21:03

@stephdes :

je reprends tout une dernière fois ...

j'ai supprimé tout ce qui concerne Arduino IDE suivi d'une installation complète

tout va bien jusqu'au 8°

ensuite ça bloque ...j'ai déjà un dossier "data" dans le dossier ! donc je colle le fichier wifinfo.spiffs.bin dedans

9 ok
10 ok
11 Nok .....

Code : Tout sélectionner

Exception in thread "AWT-EventQueue-0" java.lang.NoSuchMethodError: processing.app.Sketch.getBuildPath()Ljava/io/File;
	at com.esp8266.mkspiffs.ESP8266FS.getBuildFolderPath(ESP8266FS.java:117)
	at com.esp8266.mkspiffs.ESP8266FS.createAndUpload(ESP8266FS.java:263)
	at com.esp8266.mkspiffs.ESP8266FS.run(ESP8266FS.java:322)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

stephdes
Messages : 263
Enregistré le : 06 oct. 2016, 20:50

Re: Teleinfo WIFI

Message par stephdes » 05 déc. 2017, 18:41

le belge a écrit :@stephdes :

je reprends tout une dernière fois ...

j'ai supprimé tout ce qui concerne Arduino IDE suivi d'une installation complète

tout va bien jusqu'au 8°

ensuite ça bloque ...j'ai déjà un dossier "data" dans le dossier ! donc je colle le fichier wifinfo.spiffs.bin dedans

9 ok
10 ok
11 Nok .....

Code : Tout sélectionner

Exception in thread "AWT-EventQueue-0" java.lang.NoSuchMethodError: processing.app.Sketch.getBuildPath()Ljava/io/File;
	at com.esp8266.mkspiffs.ESP8266FS.getBuildFolderPath(ESP8266FS.java:117)
	at com.esp8266.mkspiffs.ESP8266FS.createAndUpload(ESP8266FS.java:263)
	at com.esp8266.mkspiffs.ESP8266FS.run(ESP8266FS.java:322)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Ce coup-ci c'est ma faute... Je t'ai enduit dans l'erreur ;) Je pense que le Wifinfo.spiffs.bin n'est pas au bon endroit

En fait j'ai ceci comme hiérarchie :

\Mes docs\Arduino\Wifinfo : dans ce dossier, j'ai 2 dossiers :

- 1 "Wifinfo" avec à l'intérieur le fichier ino + les fichiers cpp etc... (donc \Mes docs\Arduino\Wifinfo\Wifinfo)

- 1 dossier "data" avec le fichier Wifinfo.spiffs.bin soit : \Mes docs\Arduino\Wifinfo\data\Wifinfo.spiffs.bin

J'ai mis 2 fois le même nom de dossier c'est ce qui a créé mon erreur d'explication
MiniPC W10 + RFXCom 433e Ext1013 + RFLINK R45; 1 temp Bresser + 4 Banggood, lumières+volets+prises:Blyss
Autre modules volets chinois - RM Mini3 + RM PRO 2
Conso élec : OWL 180+ -- 2 Wattmètres OTIO
Imperihome+Sarah+MDAH+Domoticz (merci easydomoticz !)

le belge
Messages : 346
Enregistré le : 12 déc. 2016, 19:02

Re: Teleinfo WIFI

Message par le belge » 05 déc. 2017, 23:36

bonsoir ,

pas de souci , je viens de refaire des tests et c'est toujours pareil .... dès que je clique sur Téleinformation , l'uptime repart à zéro ...

pour écarter le fonctionnement de la wemos , j'ai remis le sketch de Charles et pour l'instant la wemos tourne depuis plus de 3 heures sans reboot ...

je ne comprends pas ...

je dois merder quelquepart mais je ne vois pas où !!!

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre