Domoticz + hue + interrupteur en WIFI = lenteur?

Posez ici vos questions d'utilisation, de configuration de Domoticz, de bugs, de conseils sur le logiciel lui même dans son utilisation et son paramètrage Concernant le Raspberry ou les scripts de toute nature des forums spécifiques sont ouverts
Répondre
Nomoticz
Messages : 4
Enregistré le : 17 sept. 2020, 09:27

Domoticz + hue + interrupteur en WIFI = lenteur?

Message par Nomoticz »

Bonjour à tous,

Je débute complètement dans ce bel univers de la domotique.

J'ai depuis quelques temps déjà un système basé sur Hue (le pont + divers interrupteurs et luminaires). Cela marche très bien, mais je souhaite m'éviter l'achat de multiples boxes propriétaires lorsque mes volets roulants vont arriver par exemple :) Je me suis donc dit qu'il était temps de réaliser ma box domotique pour centraliser tout mon système.

Après m'être un peu renseigné, j'ai jeté mon dévolu sur un Raspberry Pi 3B+ sur lequel j'ai installé la solution Domoticz. Et me voilà donc ici :)

Ma question est aujourd'hui la suivante : j'ai apairé mon pont Hue sans problème, et tous les éléments de mon système sont reconnus.

J'ai voulu commencer par un test simple pour me faire la main : j'ai activé dans Domoticz un Smart Bouton Hue et un lightstrip Hue. Avec un script tout simple Lua, je demande à ce que le lightstrip s'allume lorsque j'appuie sur le Smart Bouton. Cela fonctionne... au bout de 4 à 5 secondes! C'est trèèèèèès long. Le script ne semble pas être en cause, c'est plutôt le temps que met Domoticz à recevoir l'information comme quoi j'ai appuyé sur le Smart Button. D'ailleurs, si je lance l'action directement depuis Domoticz, le lightstrip s'allume instantanément.

Est-ce normal ce délai? Je sais que je suis en WIFI, et que donc Domoticz, dans ce cas, ne discute pas en direct avec le bouton, mais passe par le pont. Cela fait donc, si je ne dis pas de bêtise : SmartBouton ==> Pont Hue ==> Domoticz ==> Pont Hue ==> Lightstrip. Mais 4 à 5s, tout de même, c'est une éternité non? Une idée?

Merci d'avoir pris le temps de me lire, le message est un peu long :)

Keros
Messages : 712
Enregistré le : 23 juil. 2019, 20:57

Re: Domoticz + hue + interrupteur en WIFI = lenteur?

Message par Keros »

Bonjour Nomoticz et bienvenu sur le forum ;)

1 à 2 secondes me semble correct mais 4 à 5 secondes me semble long...

Quelles sont les portées de tes différents équipements ? Est-ce que cela change quelque chose si tu te rapproche du récepteur avec ton SmartBouton ?

Nomoticz
Messages : 4
Enregistré le : 17 sept. 2020, 09:27

Re: Domoticz + hue + interrupteur en WIFI = lenteur?

Message par Nomoticz »

Hello Keros, merci pour ta réponse. Cela ne change rien. J’ai même mesuré précisément, et c’est plutôt 7-8s! :shock:

Quand j’active le script via le switch représentant le bouton dans Domotics, c’est vraiment instantanée. Le délai semble donc vraiment lié au temps que met Domoticz à recevoir l’information (provenant du pont Hue j’imagine?) comme quoi le bouton a été activé.

Edit : je me rends compte que je n'ai pas répondu à la question :) Les éléments sont tous dans la même pièce, à 4 ou 5 mètres de distance environ.

Keros
Messages : 712
Enregistré le : 23 juil. 2019, 20:57

Re: Domoticz + hue + interrupteur en WIFI = lenteur?

Message par Keros »

C'est plutôt long en effet ...

Je n'ai pas ce matériel , je ne peux pas t'en dire plus malheureusement.

Une petite chose peut-être : cale toi sur l'heure de DomoticZ (elle est généralement en haut et à droite), et lance une commande depuis ton bouton. Tu devrais voir dans les log du device le moment où il a reçu l'info (on ne cherche pas les demi-secondes dans ton cas).

Nomoticz
Messages : 4
Enregistré le : 17 sept. 2020, 09:27

Re: Domoticz + hue + interrupteur en WIFI = lenteur?

Message par Nomoticz »

Encore merci Keros. Effectivement, il y a 7s environ entre le moment où j'appuie sur l'interrupteur Hue, et le moment où il est reçu sur le switch dans Domoticz. C'est dingue cette histoire!

Je pense que le problème se situe au niveau du pont Hue, c'est lui qui met du temps à transmettre l'info à Domoticz j'ai l'impression. Car j'ai fait un autre test : il y aussi environ 7s entre le moment ou j'allume le lightstrip Hue avec un autre interrupteur Hue qui n'est pas dans Domoticz, donc sans passer par Domoticz, et le moment où le statut du lightstrip dans Domoticz passe en "On". C'est donc bien le temps de transmission de l'info par le pont Hue vers Domoticz qui est long. Je ne sais pas comment je peux réduire ce temps.

Alors, vous me direz, le mieux est de passer par un module Zigbee à connecter sur le Raspberry, j'ai bon ? :)

Mais c'est quand même bizarre cette histoire de délai en WIFI entre le pont Hue et Domoticz.

Nomoticz
Messages : 4
Enregistré le : 17 sept. 2020, 09:27

Re: Domoticz + hue + interrupteur en WIFI = lenteur?

Message par Nomoticz »

Bonjour à la communauté,

Personne d'autre n'a cette configuration, Hue + Domoticz en WIIFI ?

Répondre