Mise à jour de 3.8153 nouvelle version erreur

Posez ici vos questions d'utilisation, de configuration de Domoticz, de bugs, de conseils sur le logiciel lui même dans son utilisation et son paramètrage Concernant le Raspberry ou les scripts de toute nature des forums spécifiques sont ouverts
Répondre
jeleve
Messages : 4
Enregistré le : 02 juil. 2018, 14:05

Mise à jour de 3.8153 nouvelle version erreur

Message par jeleve »

Bonjour,
J'utilise la version domoticz 3.8153 sur raspberry pi raspian qui marchait parfaitement jusqu'a hier.
Avant de partir en vacances j'ai eu la mauvaise idée hier de lancer la mise à jour avec la nouvelle version proposée par l'application.
Le serveur s'est arrêté.
Depuis j'ai le message d'erreur suivant lorsque j'essaie de faire un restart:
"error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory"
Je ne sais pas quoi faire, quelqu'un peut-il m'aider ?

Neutrino
Messages : 1673
Enregistré le : 10 juil. 2015, 15:42
Localisation : Les Herbiers(85)
Contact :

Re: Mise à jour de 3.8153 nouvelle version erreur

Message par Neutrino »

Bonjour,
Essaye la fonction recherche du forum et tu trouveras ton bonheur : search.php?keywords=libudev&terms=all&a ... Rechercher
Ma maison à plein d'IP ! :mrgreen:
SAV Bonjour. Vous avez vidé le cache ?

jeleve
Messages : 4
Enregistré le : 02 juil. 2018, 14:05

Re: Mise à jour de 3.8153 nouvelle version erreur

Message par jeleve »

Merci beaucoup.
J'ai finalement résolu le problème en créant un link libudev.so.1 sur le fichier libudev.so.0.13.0 dans /lib/arm-linux-gnueabihf/
J'ai pu ainsi démarrer domoticz.
Merci encore.

oula85
Messages : 161
Enregistré le : 29 avr. 2015, 18:09
Localisation : Challans

Re: Mise à jour de 3.8153 nouvelle version erreur

Message par oula85 »

jeleve a écrit :Merci beaucoup.
J'ai finalement résolu le problème en créant un link libudev.so.1 sur le fichier libudev.so.0.13.0 dans /lib/arm-linux-gnueabihf/
J'ai pu ainsi démarrer domoticz.
Merci encore.

Pourrais tu décrire la démarche plus précisément pour le néophyte que je suis, je suis également bloqué après mise à jour...

oula85
Messages : 161
Enregistré le : 29 avr. 2015, 18:09
Localisation : Challans

Re: Mise à jour de 3.8153 nouvelle version erreur

Message par oula85 »

oula85 a écrit :
jeleve a écrit :Merci beaucoup.
J'ai finalement résolu le problème en créant un link libudev.so.1 sur le fichier libudev.so.0.13.0 dans /lib/arm-linux-gnueabihf/
J'ai pu ainsi démarrer domoticz.
Merci encore.

Pourrais tu décrire la démarche plus précisément pour le néophyte que je suis, je suis également bloqué après mise à jour...

Manip:
cd /usr/lib
sudo ln -s libudev.so libudev.so.1



Merci Vil1driver encore une fois tu m'a sauvé !!!

vil1driver
Messages : 5661
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: Mise à jour de 3.8153 nouvelle version erreur

Message par vil1driver »

Merci mais je ne suis pas à l'origine de cette astuce et je dirais même que je la désapprouve.
Mieux vaut mettre son système à jour
MAJ = VIDER LE CACHE(<-Clicable)
/!\Les mises à jour de Domoticz sont souvent sources de difficultés, ne sautez pas dessus
modules.lua

Un ex domoticzien

oula85
Messages : 161
Enregistré le : 29 avr. 2015, 18:09
Localisation : Challans

Re: Mise à jour de 3.8153 nouvelle version erreur

Message par oula85 »

vil1driver a écrit :Merci mais je ne suis pas à l'origine de cette astuce et je dirais même que je la désapprouve.
Mieux vaut mettre son système à jour
sauf que j'ai crashé le système justement en faisant cette mise à jour... 2 mises à jour que je fais et 2 fois que je suis emmerdé !!!

Répondre