Bug affichage logs interrupteurs

Posez ici vos questions d'utilisation, de configuration de Domoticz, de bugs, de conseils sur le logiciel lui même dans son utilisation et son paramètrage Concernant le Raspberry ou les scripts de toute nature des forums spécifiques sont ouverts
Répondre
abonillo82
Messages : 21
Enregistré le : 14 mars 2019, 11:24
Localisation : tarn et garonne

Bug affichage logs interrupteurs

Message par abonillo82 » 08 mai 2019, 12:26

Bonjour à tous,
j'ai un bug d'affichage des logs en mode graphique je géré les detecteurs de mon alarme (radars et detecteurs ouverture)
tout fonctionnai bin jusqu'a la semaine derniere mais depuis quelques jours je vois les logs textes mais pas en mode graphique.
pour les autres paramétres temùpérature et consommatioin lectrique tout va bien.
Quelqu un aurait il une idee du probleme?
je mets une copie d'ecran
Merci à vous
log.jpg
log.jpg (78.37 Kio) Vu 852 fois

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


vil1driver
Messages : 5189
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: Bug affichage logs interrupteurs

Message par vil1driver » 08 mai 2019, 13:33


abonillo82
Messages : 21
Enregistré le : 14 mars 2019, 11:24
Localisation : tarn et garonne

Re: Bug affichage logs interrupteurs

Message par abonillo82 » 08 mai 2019, 18:14

Bonjour Vil1driver,
merci de ta réponse mais j'avais déjà tenté de vider le cache sans succès j'ai essayé une connexion a partir d'un autre ordinateur idem.
comme j'effectue une sauvegarde tous les jours à minuit 15 de tout le répertoire domoticz avec script cron sur un disque dur USB au cas ou la carte SD serait HS, j'ai restauré le répertoire de plusieurs jours avant.
Même problème au premier test, donc je restaure la base de données par l'intermédiaire du panneau paramètres de Domoticz et la tout est ok donc j'ai résolu le problème mais sans savoir d'ou cela venait. :?
Sûrement un bug dans la structure de la base de données ???
Voila en tout cas la sauvegarde m'a bien servi je suis content de l'avoir mis en place.

Merci à tous.

sperate
Messages : 12
Enregistré le : 19 sept. 2019, 18:03

Re: Bug affichage logs interrupteurs

Message par sperate » 04 nov. 2019, 13:52

Bonjour,

J'avais le même problème depuis la mise à jour à la dernière release stable : 4.10717 2019-05-09.
J'avais bien les données dans la table mais pas les graphes. Enfin si, j'avais quelques traits disparates au niveau des graphes et seulement lorsque l'inter était actif ou allumé qui plus est.

Ne voulant pas passer à la version beta pour tenter de résoudre le problème, j'ai juste téléchargé l'archive de celle-ci sur le site web de Domoticz (pour ARM en ce qui me concerne car ça tourne sur une Raspberry chez moi) et pris le fichier qui nous intéresse ici : DeviceOnOffChat.js du 29/08/2019 (donc modifié depuis la dernière stable) pour le remplacer à cet endroit :

Code : Tout sélectionner

/home/pi/domoticz/www/app/components/DeviceOnOffChart.js
Depuis tout est nickel, cf capture d'écran ci-dessous :

commande chauffage.PNG
commande chauffage.PNG (50.96 Kio) Vu 526 fois

Pour ceux que ça interesse de triturer ces fichiers il est possible d'envisager d'autres plages d'affichage des logs de température. Je n'aimais pas trop l'autozoom et j'en ai fait deux différentes pour l'instant :
* 14° à 28° pour l'intérieur
* -20° à 40° pour l'extérieur

moyenne maison.PNG
moyenne maison.PNG (39.33 Kio) Vu 526 fois
exterieur.PNG
exterieur.PNG (45.04 Kio) Vu 526 fois

Revenez vers moi si vous voulez le code. D'ailleurs il faudrait peut-être creer un nouveau sujet pour cela ..

sperate

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


adv
Messages : 313
Enregistré le : 02 févr. 2016, 13:54
Contact :

Re: Bug affichage logs interrupteurs

Message par adv » 06 nov. 2019, 09:53

EXCELLENT ! :o

Merci pour le partage, une toute petite correction, le fichier se trouve dans /home/pi/domoticz/www/app/log/components/DeviceOnOffChart.js

Et en effet cela refonctionne "comme avant" !

A+
Raspberry pi 3 - Domoticz beta | Piface v.2 + Téléinfo + RFXtrx433E + ZME_UZB1 USB Stick
sondes Oregon | motorisations Somfy Yslo Flex 2 RTS | prises chacon | Fibaro FGD-212, FGSD002, FGFS101 | Sonoff easyESP, Tasmota, Espurna | Sherlock S2 | ParadoxMG5050

boum
Messages : 46
Enregistré le : 18 janv. 2019, 11:34
Localisation : France

Re: Bug affichage logs interrupteurs

Message par boum » 06 nov. 2019, 11:23

Yep, un grand merci ! Je regarde rarement les logs des interrupteurs donc je n'avais pas cherché plus loin.
Et pour les ceusses encore plus flemmards que moi, pour télécharger la bonne version du fichier, c'est là :
https://raw.githubusercontent.com/domot ... ffChart.js
Domoticz v4.10717 sur Pi³ / Z-Wave / RFXCom

gibus17
Messages : 19
Enregistré le : 08 nov. 2019, 17:44

Re: Bug affichage logs interrupteurs

Message par gibus17 » 26 nov. 2019, 09:08

bonjour,
Bien que mon soucis soit un peu différent (vous avez les graphiques mais sans les courbes. Pour moi les logs sont présents mais les graphiques sont totalement absents,)j'ai mis en oeuvre la solution proposée sans résultat.
merci de bien vouloir m'aider

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre