Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Posez ici vos questions d'utilisation, de configuration de Domoticz, de bugs, de conseils sur le logiciel lui même dans son utilisation et son paramètrage Concernant le Raspberry ou les scripts de toute nature des forums spécifiques sont ouverts
bruce
Messages : 18
Enregistré le : 08 juil. 2019, 14:29

Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par bruce » 11 juil. 2019, 10:12

Bonjour a tous

Je poste ici un problème que j'ai depuis l'inclusion d'un second module zwave
Peut être un problème de conf rasbpian ou autre

viewtopic.php?f=4&t=8687

Si vous avez des idées….
raspberry pi 3+
raspbian buster
domoticz 4.10717
everspring usb z-wave+
rfxcom xl

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


bruce
Messages : 18
Enregistré le : 08 juil. 2019, 14:29

Re: Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par bruce » 13 juil. 2019, 19:08

bonjour

j'ai tout réinstallé
de plus une nouvelle version de raspbian buster est sortie le 10 juillet, maintenant domoticz s'install nikel

ceci dit, après install et config je n'ai toujours pas les fibaro dans la liste des dispositifs, du moins avec leur noms que je leur ai donné... du coup en cliquant sur l'ampoule j'ai le message
Erreur d'envoi de la commande à l’interrupteur, vérifiez le dispositif/matériel !
pourtant les modules et domoticz communiquent bien puisque j'ai pu configurer les modules

à noté que j'ai ajouter au fichier existant /etc/udev/rules.d/99-com.rules les lignes suivantes en début
SUBSYSTEM=="tty", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6015", ATTRS{serial}=="DO3MKRZC", SYMLINK+="ttyUSB-RFX433"
SUBSYSTEM=="tty", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", SYMLINK+="ttyUSB-ZStick-5G"

une petite serait pas de trop....
merci

bien à vous
raspberry pi 3+
raspbian buster
domoticz 4.10717
everspring usb z-wave+
rfxcom xl

bruce
Messages : 18
Enregistré le : 08 juil. 2019, 14:29

Re: Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par bruce » 14 juil. 2019, 02:00

Peut être que malgré les exclusions et inclusion les modules fibaro au niveau domoticz sont correctement géré
Mais peut être pas au niveau de la clé everspring meme
Alors je vais tenter un soft reset et un hard reset de la clé depuis le menu domoticz
Il y a peut être des modules fantômes non visible dans domoticz mais présent dans la clé
raspberry pi 3+
raspbian buster
domoticz 4.10717
everspring usb z-wave+
rfxcom xl

tunam
Messages : 7
Enregistré le : 14 juin 2015, 04:15

Re: Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par tunam » 14 juil. 2019, 20:12

salut

impossible pour moi de connecter ma clé usb z-wave gen5 pour l'instant , pas reconnu par le pi4

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


bruce
Messages : 18
Enregistré le : 08 juil. 2019, 14:29

Re: Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par bruce » 14 juil. 2019, 20:56

Que renvoie la commande lsusb avec buster sous pi4?
raspberry pi 3+
raspbian buster
domoticz 4.10717
everspring usb z-wave+
rfxcom xl

tunam
Messages : 7
Enregistré le : 14 juin 2015, 04:15

Re: Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par tunam » 14 juil. 2019, 21:05

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

rien du tout

bruce
Messages : 18
Enregistré le : 08 juil. 2019, 14:29

Re: Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par bruce » 15 juil. 2019, 01:03

effectivement, on devrait avoir une ligne de ce type
Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
raspberry pi 3+
raspbian buster
domoticz 4.10717
everspring usb z-wave+
rfxcom xl

tunam
Messages : 7
Enregistré le : 14 juin 2015, 04:15

Re: Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par tunam » 15 juil. 2019, 19:41

je viens de changer de prise usb et la miracle ( pourtant je l'avais deja fait pas mal de fois )

root@raspberrypi:/home/pi# lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub



et bien reconnu dans Domoticz aussi :D

par contre c'est aléatoire il ne le reconnaît pas tous le temps ..



je continu les testes sur le pi4 :)

alttrash
Messages : 2
Enregistré le : 19 juil. 2019, 15:49

Re: Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par alttrash » 19 juil. 2019, 15:53

tunam a écrit :
15 juil. 2019, 19:41
je viens de changer de prise usb et la miracle ( pourtant je l'avais deja fait pas mal de fois )

root@raspberrypi:/home/pi# lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

et bien reconnu dans Domoticz aussi :D

par contre c'est aléatoire il ne le reconnaît pas tous le temps ..

je continu les testes sur le pi4 :)

Je suis sur le pi4 aussi, et donc sous Buster. Comme toi lsusb ne m'affiche JAMAIS la clé Aeotec.... j'ai fait 50 fois le test, rebooté, changé le port. Rien, nada, pourtant elle est bien vue sur mon Mac.

J'ai perdu une après midi complète à penser qu'il fallait que je renvoie la clé à mon vendeur (je l'ai depuis 15j et deballée hier seulement!) mais ton post me conforte... c'est un bug Pi4 ou Buster....
Tu as pu progresser sur cette detection ?

Merci

alttrash
Messages : 2
Enregistré le : 19 juil. 2019, 15:49

Re: Raspbian buster zwave fibaro cle usb everspring: Pb de commande de module

Message par alttrash » 19 juil. 2019, 16:36

Bon ben après avoir vu ton post... en creusant sur le net, j ai trouvé :

https://github.com/raspberrypi/linux/issues/3027

C'est possiblement un problème concernant cette clé, mais que tous les OS semblent corriger "naturellement"... sauf Buster :?

Heureusement y'a une solution, je confirme qu'elle fonctionne : il faut mettre un hub USB 2 entre le Pi 4 et la clé Aeotec. A priori c'est important d'avoir un hub USB 2, pas 3... et je ne l'alimente pas...

Ca y'est je vois desormais la clé avec lsusb. Woohoo, mon Pi 4 est devenu un usine a gaz avec le hub USB qui est plus gros que lui !

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre