gpio change au reboot

Posez ici vos questions d'utilisation, de configuration de Domoticz, de bugs, de conseils sur le logiciel lui même dans son utilisation et son paramètrage Concernant le Raspberry ou les scripts de toute nature des forums spécifiques sont ouverts
Répondre
micky1183
Messages : 1
Enregistré le : 08 juin 2019, 13:21

gpio change au reboot

Message par micky1183 » 21 août 2019, 23:51

Bonjour,

Cela fait plus d'une semaine que je m'arrache les cheveux tous les soirs avec ces entrées et sorties GPIO qui reviennent en IN à chaque reboot de mon raspberry.
Si quelqu'un pouvait éventuellement m'aider pour débloquer ma situation ca serait super!!!
J'ai bien installer wiring PI, lorsque je fais un gpio readall, j'ai bien tous mes ports gpio. J'arrive à changer leurs états IN ou OUT...ca fonctionne également dans domoticz mais des que je reboot le pi3b+, les gpio repasse en in.
J'ai placer les exports dans init.d/domoticz.sh au tout début comme ceci

#! /bin/sh
### BEGIN INIT INFO
# Provides: domoticz
# Required-Start: $network $remote_fs $syslog
# Required-Stop: $network $remote_fs $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Home Automation System
# Description: This daemon will start the Domoticz Home Automation System
### END INIT INFO

# Do NOT "set -e"
/usr/local/bin/gpio export 22 out
/usr/local/bin/gpio export 3 out
/usr/local/bin/gpio exports
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin
DESC="Domoticz Home Automation System"

et ensuite dans rc.local à la fin comme ceci

printf "My IP address is %s\n" "$_IP"
fi
/usr/local/bin/gpio export 3 out
/usr/local/bin/gpio export 22 out
/home/pi/domoticz/domoticz.sh
exit 0

J'ai du oublier quelque chose? une idée?
Merci d'avance

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre