Disque de 4To sur Raspberry pi 4

Posez vos questions concernant le Raspberry (conseil avant achat, choix de connectique, demandes de câblages...) un espace spécifiques pour les questions relatives aux scripts shell,bask,block etc ... est ouvert dans un autre forum.
Répondre
Kachan_fr
Messages : 25
Enregistré le : 17 janv. 2019, 08:15

Disque de 4To sur Raspberry pi 4

Message par Kachan_fr » 13 févr. 2020, 16:08

Bonjour,

Depuis des années j'ai une batterie de 4 disques externes USB (Western Digital MyBook), 2 de 1 To et 2 de 500 Go. Ils sont alimentés de manière autonome, connectés à un hub USB, qui était lui-même connecté à un serveur Windows. Cela me servait pour mes sauvegardes. Le serveur me posant de plus en plus de problèmes, j'ai décidé de le remplacer par un NAS sur Raspberry.

J'ai donc installé Raspbian Buster Lite et OpenMediaVault sur un Raspberry pi 4. J'ai connecté les disques sur le Raspberry, et ça fonctionne.

Disposant d'un disque interne 3,5" de 2 To, j'ai remplacé l'un des 500 Go par celui-ci et ça fonctionne.

Le loi de Murphy étant ce qu'elle est, le second 500 Go en a profité pour rendre l'âme. J'ai donc acheté un autre disque dur pour le remplacer, un 4 To tant qu'à faire. J'ai remplacé le 500 Go dans le boitier, et je l'ai connecté à l'ensemble, voici ce que j'obtiens :

Image

J'ai d'abord pensé que le disque avait un problème. Je l'ai démonté et connecté à l'aide d'un dock sur mon PC et il est bien vu en tant que 4 To.

J'ai pensé que ça venait du boitier SATA-USB. Je l'ai remonté dedans et connecté en USB au PC. RAS.

Je l'ai reconnecté à OpenMediaVault, il ne voit toujours que 1,64 To. J'ai mis une carte SD avec Raspbian Buster complet (interface graphique) sur le Raspberry, et là il ne le voit même pas. Il voir bien les autres si je les connecte, mais pas le 4 To.

Comprends pas :cry:

Si quelqu'un connait une astuce. Merci d'avance.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


domcars0
Messages : 217
Enregistré le : 18 févr. 2017, 20:23

Re: Disque de 4To sur Raspberry pi 4

Message par domcars0 » 13 févr. 2020, 16:36

Salut ,
Ton disque de 4Go est partitionné en GPT ou en MBR ? Si il est en MBR c'est normal le partitionnement MBR est limité à 2To...Il faut le repartitionner en GPT. AH non excuses.Tu dis que sur ton PC les 4To sont bien vus, c'est donc plutôt le "OpenMediaVault" (je sais pas ce que c'est) qui ne connaitrait pas le GPT (Plus dinfos : https://linoxide.com/storage/mbr-vs-gpt ... titioning/)
Ton PI ne le "voit" pas (enfin il le voit je pense.. branche ton disque dur de 4To puis, tape dans un terminal la commande 'dmesg', débranche le et retape la commande 'dmesg'. Il y a fort à parier que le noyau "voit" ce disque) ... probablement parce qu'il est formaté en NTFS. D'origine un Pi ne connait pas ce format je crois (voir https://pimylifeup.com/raspberry-pi-ntfs/) .
La liberté a un prix... celui de l'effort.

Kachan_fr
Messages : 25
Enregistré le : 17 janv. 2019, 08:15

Re: Disque de 4To sur Raspberry pi 4

Message par Kachan_fr » 13 févr. 2020, 17:36

Bonsoir, merci pour ta réponse.

Ce soir je n'ai plus trop le temps, et les 4 disques sont connectés au hub et branchés au RPI. mais j'ai balancé quand même un dmesg pour voir, et effectivement, il voit un HDD de 1,8 To au lieu de 4 :

Code : Tout sélectionner

[  484.170194] usb-storage 1-1.1.3:1.0: USB Mass Storage device detected
[  484.170930] scsi host2: usb-storage 1-1.1.3:1.0
[  484.266747] usb 1-1.1.4: new high-speed USB device number 15 using xhci_hcd
[  484.399931] usb 1-1.1.4: New USB device found, idVendor=050d, idProduct=706a, bcdDevice=77.64
[  484.399939] usb 1-1.1.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[  484.401530] hub 1-1.1.4:1.0: USB hub found
[  484.402805] hub 1-1.1.4:1.0: 4 ports detected
[  484.716812] usb 1-1.1.4.4: new high-speed USB device number 16 using xhci_hcd
[  484.717982] scsi 0:0:0:0: Direct-Access     WD       40EZRZ External  1.65 PQ: 0 ANSI: 0
[  484.718997] sd 0:0:0:0: Attached scsi generic sg0 type 0
[  484.719753] sd 0:0:0:0: [sda] 3519069872 512-byte logical blocks: (1.80 TB/1.64 TiB)
[  484.720854] sd 0:0:0:0: [sda] Write Protect is off
[  484.720871] sd 0:0:0:0: [sda] Mode Sense: 00 00 00 00
[  484.721855] sd 0:0:0:0: [sda] Asking for cache data failed
[  484.721870] sd 0:0:0:0: [sda] Assuming drive cache: write through
[  484.847968] usb 1-1.1.4.4: New USB device found, idVendor=1058, idProduct=1100, bcdDevice= 1.65
[  484.847979] usb 1-1.1.4.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  484.847987] usb 1-1.1.4.4: Product: My Book
[  484.847994] usb 1-1.1.4.4: Manufacturer: Western Digital
[  484.848002] usb 1-1.1.4.4: SerialNumber: 57442D574341565933343138303032
[  484.849917] usb-storage 1-1.1.4.4:1.0: USB Mass Storage device detected
[  484.850212] scsi host3: usb-storage 1-1.1.4.4:1.0
[  484.960500] scsi 1:0:0:0: Direct-Access     WD       10EAVS External  1.65 PQ: 0 ANSI: 4
[  484.960922] sd 1:0:0:0: Attached scsi generic sg1 type 0
[  484.961365] sd 1:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[  484.962068] sd 1:0:0:0: [sdb] Write Protect is off
[  484.962074] sd 1:0:0:0: [sdb] Mode Sense: 21 00 00 00
[  484.962748] sd 1:0:0:0: [sdb] No Caching mode page found
[  484.962754] sd 1:0:0:0: [sdb] Assuming drive cache: write through
[  485.197305] scsi 2:0:0:0: Direct-Access     WD       10EAVS External  1.75 PQ: 0 ANSI: 4
[  485.197687] sd 2:0:0:0: Attached scsi generic sg2 type 0
[  485.197950] sd 2:0:0:0: [sdc] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[  485.198199] sd 2:0:0:0: [sdc] Write Protect is off
[  485.198208] sd 2:0:0:0: [sdc] Mode Sense: 23 00 00 00
[  485.198459] sd 2:0:0:0: [sdc] No Caching mode page found
[  485.198466] sd 2:0:0:0: [sdc] Assuming drive cache: write through
[  485.587958]  sdb: sdb1
[  485.590258] sd 1:0:0:0: [sdb] Attached SCSI disk
[  485.697597]  sdc: sdc1
[  485.700277] sd 2:0:0:0: [sdc] Attached SCSI disk
[  485.961300] scsi 3:0:0:0: Direct-Access     WD       20EADS External  1.65 PQ: 0 ANSI: 4
[  485.961749] sd 3:0:0:0: Attached scsi generic sg3 type 0
[  485.966036] sd 3:0:0:0: [sdd] 3907027055 512-byte logical blocks: (2.00 TB/1.82 TiB)
[  485.966973] sd 3:0:0:0: [sdd] Write Protect is off
[  485.966982] sd 3:0:0:0: [sdd] Mode Sense: 21 00 00 00
[  485.967774] sd 3:0:0:0: [sdd] No Caching mode page found
[  485.967781] sd 3:0:0:0: [sdd] Assuming drive cache: write through
[  485.977916]  sdd: sdd1
[  485.980441] sd 3:0:0:0: [sdd] Attached SCSI disk
[  486.522830] EXT4-fs (sdb1): recovery complete
[  486.523251] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[  486.775678] EXT4-fs (sdc1): recovery complete
[  486.776163] EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: (null)
[  486.931007] EXT4-fs (sdd1): recovery complete
[  486.931410] EXT4-fs (sdd1): mounted filesystem with ordered data mode. Opts: (null)
[  491.491041] sd 0:0:0:0: [sda] Attached SCSI disk
Pas encore pu tout analyser :oops:

Kachan_fr
Messages : 25
Enregistré le : 17 janv. 2019, 08:15

Re: Disque de 4To sur Raspberry pi 4

Message par Kachan_fr » 14 févr. 2020, 16:21

Bonjour,

Bon, en fait je suis persuadé que c’est l’interface USB du boitier MyBook qui pose problème. En effet :

(Je rappelle que je l’avais formaté en NTFS à l’aide de mon dock SATA.)

J’ai reconnecté le disque en USB sur le PC, il apparait bien en 4 To.
J’ai détruit la partition.
J’ai repartitionné sans formater, et il apparait en 1,7 To.
J’ai redétruit la partition et repartionné en formatant en NTFS, toujours 1,7 To.
J’ai démonté le disque du boitier et je l’ai connecté au dock SATA.
Il apparait en 4 To, idem en le partionnant, idem en le formatant.

Comme mon disque interne de données principal est un 2 To, je vais le remplacer par le 4 To et mettre le 2 To dans le boitier, pour l’autre ça a bien fonctionné. Et 6 To pour le NAS, ça suffira.

Merci. @+

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre