problème montage etc/fstab

Posez vos questions concernant le Raspberry (conseil avant achat, choix de connectique, demandes de câblages...) un espace spécifiques pour les questions relatives aux scripts shell,bask,block etc ... est ouvert dans un autre forum.
vr6man
Messages : 457
Enregistré le : 18 juil. 2017, 12:15

problème montage etc/fstab

Message par vr6man »

Bonjour,

Je souhaite reporter des fichiers contenu dans un répertoire du RPI vers un dossier de mon Synology

J'utilise la commande moving suivante :

mount -t nfs 192.168.0.250:/volume1/surveillance /mnt/surveillance

la commande est bien montée comme je le vois en lançant la commande Mount (en bas) :

Code : Tout sélectionner

pi@rasp_motion:~ $ mount
/dev/mmcblk0p2 on / type ext4 (rw,noatime,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=495480k,nr_inodes=123870,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=27,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
tmpfs on /var/tmp type tmpfs (rw,nosuid,noatime,size=10240k)
tmpfs on /var/log type tmpfs (rw,nosuid,noatime,size=10240k,mode=755)
tmpfs on /tmp type tmpfs (rw,nosuid,noatime,size=10240k)
/dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=100016k,mode=700,uid=1000,gid=1000)
192.168.0.250:/volume1/surveillance on /mnt/surveillance type nfs4 (rw,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=192.168.0.242,local_lock=none,addr=192.168.0.250)
pi@rasp_motion:~ $ 
J'en déduis que le montage est bien effectué et je vérifie sur le NAS et des fichiers sont bien déposé sur celui ci

du coup je souhaite que ce montage soit fait automatiquement au redémarrage du RpI

dans mon fichier etc/fstab je met la ligne suivante :

Code : Tout sélectionner

192.168.0.250:/volume1/surveillance /mnt/surveillance nfs4 rw,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=192.168.0.242,local_lock=n$
ou alors cette ligne

Code : Tout sélectionner

192.168.0.250:/volume1/surveillance   /mnt/surveillance    nfs4  defaults   0       0
Ni l'une de ces lignes ne permet le montage lors du redémarrage du rpi

Merci de votre aide

Keros
Messages : 1213
Enregistré le : 23 juil. 2019, 20:57

Re: problème montage etc/fstab

Message par Keros »

Tu ne serais pas en train d'essayer d'exécuter une ligne de retour d'info ?

La commande devrait être mount -t nfs 192.168.0.250:/volume1/surveillance /mnt/surveillance

vr6man
Messages : 457
Enregistré le : 18 juil. 2017, 12:15

Re: problème montage etc/fstab

Message par vr6man »

je viens de tester en mettant dans le Fstab:

Code : Tout sélectionner

mount -t nfs 192.168.0.250:/volume1/surveillance /mnt/surveillance
ca ne change rien le montage ne se fait pas

Jeff
Messages : 793
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: problème montage etc/fstab

Message par Jeff »

Me concernant j'utilise ceci et ca fonctionne très bien
http://doc.ubuntu-fr.org/tutoriel/acced ... plications
Version: 4.9700; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...), Zigbee2MQTT.

vil1driver
Messages : 5665
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: problème montage etc/fstab

Message par vil1driver »

Salut,

Et en ajoutant l'option ?

_netdev qui va attendre que le réseau soit effectif avant d’essayer de monter le disque

Code : Tout sélectionner

192.168.0.250:/volume1/surveillance /mnt/surveillance    nfs    defaults,_netdev,rw    0    0
MAJ = VIDER LE CACHE(<-Clicable)
/!\Les mises à jour de Domoticz sont souvent sources de difficultés, ne sautez pas dessus
modules.lua

Un ex domoticzien

vr6man
Messages : 457
Enregistré le : 18 juil. 2017, 12:15

Re: problème montage etc/fstab

Message par vr6man »

pareil ca ne monte toujours pas

Jeff
Messages : 793
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: problème montage etc/fstab

Message par Jeff »

vr6man a écrit : 02 oct. 2020, 22:00 pareil ca ne monte toujours pas
Tu as regardé le tuto ?
Version: 4.9700; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...), Zigbee2MQTT.

vr6man
Messages : 457
Enregistré le : 18 juil. 2017, 12:15

Re: problème montage etc/fstab

Message par vr6man »

Jeff a écrit : 02 oct. 2020, 23:23
vr6man a écrit : 02 oct. 2020, 22:00 pareil ca ne monte toujours pas
Tu as regardé le tuto ?
oui j'ai suivi la partie 4.2

et j'ai le message d'erreur suivant :

Code : Tout sélectionner

pi@rasp_motion:~ $ sudo mount -a
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
voici ma ligne dans le fstab

Code : Tout sélectionner

//192.168.0.250/volume1/surveillance    /mnt/surveillance       cifs    credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,_netdev      0       0
ce qui est bizarre c'est que lorsque que je fais un montage à la main via

Code : Tout sélectionner

sudo mount    -t    nfs    192.168.0.250:/volume1/surveillance    /mnt/surveillance
pas de soucis ca fonctionne et pas via le fstab

Jeff
Messages : 793
Enregistré le : 17 nov. 2016, 20:54
Localisation : Rennes (35)

Re: problème montage etc/fstab

Message par Jeff »

Tu n'as donc pas tenu compte de cette remarque ?
Depuis La version 18.04 d'Ubuntu, il faut ajouter l'option vers=1.0 dans les options pour que ça fonctionne. Par exemple après _netdev

Code : Tout sélectionner

gid=1000,uid=1000,vers=1.0,_netdev 0
Sans cela je n'y arrivais pas de mon coté

Il faut aussi installer "cifs-utils"
Version: 4.9700; RFXCOM Rfxtrx433e ext/1007 ; Zwave (Z-stick GEN5, Fibaro...), Zigbee2MQTT.

vr6man
Messages : 457
Enregistré le : 18 juil. 2017, 12:15

Re: problème montage etc/fstab

Message par vr6man »

ok donc le problème viendrait de l'installation impossible de cifs utils

j'ai l'erreur suivante quand je fais :

Code : Tout sélectionner

sudo apt install cifs-utils

Code : Tout sélectionner

pi@rasp_motion:~ $ sudo apt install cifs-utils
Lecture des listes de paquets... Erreur !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_main_binary-armhf_Packages
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.
a votre avis

Répondre