[pour info] domoticz et raspbian buster

Posez ici vos questions d'utilisation, de configuration de Domoticz, de bugs, de conseils sur le logiciel lui même dans son utilisation et son paramètrage Concernant le Raspberry ou les scripts de toute nature des forums spécifiques sont ouverts
Répondre
adv
Messages : 229
Enregistré le : 02 févr. 2016, 13:54
Contact :

[pour info] domoticz et raspbian buster

Message par adv » 26 juin 2019, 15:05

Salut à tous,

je suis en train de me monter un domoticz parallèle au miens pour repartir sur une base saine et à jour du système raspbian.

A l'heure où je vous parle il existe 3 problèmes majeurs qui empêchent l'install avec raspbian buster.

1/ Script d'installation ne fonctionne pas, parce qu'il vérifie la présence de libcurl3 hors c'est libcurl4 qui est installé sur buster.

Au lieu de lancer "sudo curl -L install.domoticz.com | sudo bash" pour lancer l'installation, faites:

Code : Tout sélectionner

sudo curl -sSL install.domoticz.com > install.sh
sudo sed -i 's/curl3/curl4/g' install.sh
sudo chmod 755 install.sh
sudo ./install.sh
et ça roule ! Je pense que ça sera corrigé bientôt !


2/ Librairie libusb0.1 pas installée:

Code : Tout sélectionner

sudo apt-get install libusb-0.1
(peut être qu'ils contrôleront sa présence à l'avenir au moment de l'install ?)


3/ Toujours le problème avec la libssl (empêche l'affichage de la page web) mais la plupart des blogs qui en parlent ont un lien qui n'est plus à jour:

Code : Tout sélectionner

wget http://ftp.nl.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u8_armhf.deb
sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u8_armhf.deb

Code : Tout sélectionner

sudo service domoticz.sh restart
Après ça roule !

Bonne install et attention aux coups de soleil !

EDIT: ah, problème avec libpython, je suis en train de regarder ce qui cloche...
dans mes logs: Status: EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available for your platform.
hors j'ai bien la 3.7... (ça matche avec ma version de python)

Ah trouvé dans le wiki:

Code : Tout sélectionner

sudo apt-get install python3-dev
Et ça roule sur 4 roues maintenant :D
Raspberry pi 3 - Domoticz beta | Piface v.2 + Téléinfo + RFXtrx433E + Aeon Z-Wave+GEN5
sondes Oregon | motorisations Somfy Yslo Flex 2 RTS | prises chacon | Fibaro FGD-212, FGSD002, FGFS101 | Sonoff easyESP, Tasmota, Espurna | Sherlock S2 | ParadoxMG5050

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Tonio16
Messages : 331
Enregistré le : 13 oct. 2017, 17:00

Re: [pour info] domoticz et raspbian buster

Message par Tonio16 » 27 juin 2019, 07:09

Merci pour ce retour, je me posais justement la question !

Antoine
Domoticz V4.9700 sous raspbian-Stretch
Raspberry Pi B+ avec Clé Z-Wave Plus Z-Stick GEN5 - Aeon Labs
Raspberry Pi 3B+ avec RFLink

DavidFromRouen
Messages : 103
Enregistré le : 26 févr. 2016, 23:40

Re: [pour info] domoticz et raspbian buster

Message par DavidFromRouen » 27 juin 2019, 17:18

Merci ! JUSTEMENT, j'ai entrepris aujourd'hui de faire pareil et j'avais le même soucis. THANKS !

alomamabobo
Messages : 7
Enregistré le : 10 août 2015, 09:41
Localisation : Occitanie

Re: [pour info] domoticz et raspbian buster

Message par alomamabobo » 11 juil. 2019, 13:43

Merci pour ce retour :)
Raspbian & Domoticz v4.10717 sur Raspberry Pi 3,
AeonStick, RFXcom, Enocean, Xiaomi Mijia.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


bruce
Messages : 18
Enregistré le : 08 juil. 2019, 14:29

Re: [pour info] domoticz et raspbian buster

Message par bruce » 14 juil. 2019, 11:06

Une version buster en date du 10 juillet est sortie

L'install classique fonctionne de nouveau
raspberry pi 3+
raspbian buster
domoticz 4.10717
everspring usb z-wave+
rfxcom xl

Thorgal
Messages : 114
Enregistré le : 16 août 2018, 20:02
Contact :

Re: [pour info] domoticz et raspbian buster

Message par Thorgal » 03 août 2019, 11:16

Y aurait quelqu'un sous buster qui pourrais faire un test rapide ?
Je cherche a voir si il y a un probleme de compatibilité avec la lib python requests. Il suffit juste d'avoir buster (et avoir garde python 3.7), et de rajouter dans un plugin python au hazard (qui est utilisé) en debut de fichier.

Code : Tout sélectionner

import requests
En etant sur que le lib est deja presente (pip3 install requests).

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre