Pluviomètre TFA problème de configuation ?

forum dédié au Rfxcom et à ses périphériques. Merci de ne pas poster de questions ici concernant les RFLINK, utilisez le forum spécifique pour cela
samick
Messages : 8
Enregistré le : 30 juin 2020, 18:21

Pluviomètre TFA problème de configuation ?

Message par samick »

Bonjour,

Je viens d'acheter le nouveau pluviomètre TFA 30.3233.01 et les comptages ne se font pas :(
L'appareil est listé sur le RFXCOM depuis janvier 2020
Avez-vous réussi à le paramétrer parce que là je peine ?

Il est bien reconnu sous Domotics :
Capture RAIN-4.JPG
Capture RAIN-4.JPG (38.67 Kio) Vu 683 fois
Avec RFXmngr il m'indique n'importe quoi :
------------------------------------------------
30/06/2020 05:12:36:032= FC7F00000000D3030F02AF030800CD020B00D4021401C0011E01C1011401CB011801C6011501CB011A00D1020B01C8011E00CD020C01C8011601C9011601CA011800D0021201C4011A00CF021101C2011800D3020C00D2021300CD021100CE020F00D0020D01C7011801C7011D00CE020C00D4020C00D3020E00D1020C01C8011800D0021301C4011C00CC021101C3011B01C4011D01C3011A01C5011B00D0020D01C7011701C8011A01C6011801C7011700D1020D01C7011B00CE021201C3011700D3020A01CA011700D4021001C4011C01C3011B01C5011C01C0011B01C7011801C8011501CA011501C8011A01C5011601CA011601C9011701C80114
Packettype = RAW Packet
Packet Length = 252
subtype = RAW packet
Sequence nbr = 0
Repeat = 0
Nbr of pulses = 62
211 783 687 776 205 523 212 532 448 286 449 276 459 280 454 277 459 282 209 523 456 286 205 524 456 278 457 278 458 280 208 530 452 282 207 529 450 280 211 524 210 531 205 529 206 527 208 525 455 280 455 285 206 524 212 524 211 526 209 524 456 280 208 531 452 284 204 529 451 283 452 285 451 282 453 283 208 525 455 279 456 282 454 280 455 279 209 525 455 283 206 530 451 279 211 522 458 279 212 528 452 284 451 283 453 284 448 283 455 280 456 277 458 277 456 282 453 278 458 278 457 279 456 276
------------------------------------------------

Une seule fois il m'a indiqué une bonne valeur :

------------------------------------------------
30/06/2020 12:18:36:586= 0B5509013E51000000000289
Packettype = RAIN
subtype = RAIN9 - TFA 30.3233.01
Sequence nbr = 1
ID = 3E51 decimal:15953
Flip count = 2
Total rain = 0,51 mm
Signal level = 8 -56dBm
Battery = OK

voici ma configuration :

0/06/2020 05:12:34:715= 1401001106532BFFDFFF0303011C107C4658434F4D
Packettype = Interface Message
subtype = Interface Response
Sequence nbr = 17
response on cmnd = Save Settings
Transceiver type = 433.92MHz
Firmware version = 1043
Firmware Type = ProXL1
Noise level = 124
Transmit power = 10dBm
Hardware version = 3.1 RFXtrx433XL
Undec on
Imagintronix enabled
Byron SX enabled
RSL enabled
Lighting4 enabled
FineOffset enabled
Rubicson enabled
AE Blyss enabled
BlindsTx enabled
BlindsT0 enabled
Legrand enabled
La Crosse enabled
Hideki enabled
AD LightwaveRF enabled
Mertik enabled
Visonic enabled
ATI,Cartelectroni enabled
Oregon Scientific enabled
Meiantech enabled
HomeEasy EU enabled
AC enabled
ARC enabled
X10 enabled
HomeConfort,Fan enabled
KeeLoq enabled
------------------------------------------------

merci pour votre aide

Chrominator
Messages : 524
Enregistré le : 19 déc. 2015, 07:29

Re: Pluviomètre TFA problème de configuation ?

Message par Chrominator »

samick a écrit :
30 juin 2020, 20:08
Bonjour,

Je viens d'acheter le nouveau pluviomètre TFA 30.3233.01 et les comptages ne se font pas :(
Image
On dirait que si ; d'après les données que tu montres, il n'a pas plu depuis 1h et auparavant il a plu 25.2 mm (depuis l'installation ?).

samick
Messages : 8
Enregistré le : 30 juin 2020, 18:21

Re: Pluviomètre TFA problème de configuation ?

Message par samick »

Merci de m’aider,
C’est normal j’habite en Bretagne ! non blague à part c’est moi qui l’active à la main en basculant le levier. La valeur ne change plus. Autant sur domoticz que sur le manager.
Merci

samick
Messages : 8
Enregistré le : 30 juin 2020, 18:21

Re: Pluviomètre TFA problème de configuation ?

Message par samick »

La valeur reste fichée à 0 sur Domoticz:
Capture RAIN-5.JPG
Capture RAIN-5.JPG (20.03 Kio) Vu 667 fois
Et sur RFX Manager le pluviomètre n'a pas l'air d'être reconnu :

------------------------------------------------
30/06/2020 10:08:39:017= FC7F00000000DA031102AC031600BE021700C8021701BD011F01C1011B01C5011D00CB021800C8021B00C3021A01BA011A00D2021700C9021201C1012001BD012200C8021500CB021900C7021500CB021301C1012201BD012101BC012001C0011D01C1012300C8021400CC021600CA021500C8021E00C2021500C9021400CC021C01B8011E01C2012000C8021901BB012501BB012001C0012001BF011E01C2011B00CE021601BE011C01C2011E01C2011500D6020F01C5011800D1021201C2012100C9020E01C6012100CB021301C0011D01C3011901C4012101BF011B01C3011F01C1011D01C2011D01C3011A01C6011D01C0011D01C2011C00CE0213
Packettype = RAW Packet
Packet Length = 252
subtype = RAW packet
Sequence nbr = 0
Repeat = 0
Nbr of pulses = 62
218 785 684 790 190 535 200 535 445 287 449 283 453 285 203 536 200 539 195 538 442 282 210 535 201 530 449 288 445 290 200 533 203 537 199 533 203 531 449 290 445 289 444 288 448 285 449 291 200 532 204 534 202 533 200 542 194 533 201 532 204 540 440 286 450 288 200 537 443 293 443 288 448 288 447 286 450 283 206 534 446 284 450 286 450 277 214 527 453 280 209 530 450 289 201 526 454 289 203 531 448 285 451 281 452 289 447 283 451 287 449 285 450 285 451 282 454 285 448 285 450 284 206 531
------------------------------------------------

Comme si le protocole n'était pas reconnu...

Chrominator
Messages : 524
Enregistré le : 19 déc. 2015, 07:29

Re: Pluviomètre TFA problème de configuation ?

Message par Chrominator »

La valeur à 0 c'est qu'il n' a pas plu au cours de la journée, et la barre rouge c'est parce que la sonde n'a pas envoyé d'update depuis longtemps (voir paramètres/autres).

Pour comparaison, les données du device que j'ai (ce n'est pas exactement ton pluviomètre) sont comparables,
Screenshot_2020-07-01 Domoticz(1).png
Screenshot_2020-07-01 Domoticz(1).png (1.36 Kio) Vu 629 fois
mais chez moi DZ a bien enregistré les précipitations heure par heure.
Screenshot_2020-07-01 Domoticz.png
Screenshot_2020-07-01 Domoticz.png (28.48 Kio) Vu 629 fois
Est-ce que tu pourrais nous montrer l'historique de ton capteur pour voir si quand tu l'actives à la main DZ enregistre bien l'évènement ?

Je soupçonne que ce soit l'absence de transmission vers DZ à intervalles réguliers qui te porte à croire qu'il ne fonctionne pas.
Après tout, pourquoi transmettre des informations lorsqu'il n'y a pas de nouvelles précipitations ?
Ça utilise de l'énergie pour rien.

Pour info, mon widget ce soir aligné avec les images écran précédentes, on y voit le cumul des précipitations de la journée.
Screenshot_2020-07-01 Domoticz(2).png
Screenshot_2020-07-01 Domoticz(2).png (13.58 Kio) Vu 623 fois
NB : Mon pluviomètre est aussi doté d'une sonde de température, ce n'est pas le cas du tiens ?

samick
Messages : 8
Enregistré le : 30 juin 2020, 18:21

Re: Pluviomètre TFA problème de configuation ?

Message par samick »

Bonjour,

Ton pluviomètre fonctionne bien en effet ,j'espère arriver au même résultat.

Quand je bascule à la main le capteur rien ne se passe et pas d'historique :(

Sur ce modèle pas de capteur de T°C ext.

Par contre il est bien reconnu par Domoticz mais rien dans le les graphiques d'historique. Quand je le réinitialise en enlevant les piles il apparait dans la section Dispositif, il change bien de N° ID et c'est là qu'il affiche une précipitation ensuite plus rien :
Capture RAIN-6.JPG
Capture RAIN-6.JPG (37.17 Kio) Vu 600 fois
Sur l'écran fourni avec l'appareil les précipitations s'affiche sans problème et dans l'historique aussi.

J'ai vu sur la notice de chez RFXcom qu'il fallait mettre le minimum de protocole. Je suis donc passé en mode défaut avec le Hideki bien "Activé" mais toujours rien...

Un idée ?

samick
Messages : 8
Enregistré le : 30 juin 2020, 18:21

Re: Pluviomètre TFA problème de configuation ?

Message par samick »

à l'installation :
Capture RAIN-14.JPG
Capture RAIN-14.JPG (16.92 Kio) Vu 599 fois
Capture RAIN-13.JPG
Capture RAIN-13.JPG (43.01 Kio) Vu 599 fois
J'active à la main :
Capture RAIN-15.JPG
Capture RAIN-15.JPG (138.56 Kio) Vu 599 fois
Et je continue :
Capture RAIN-16.JPG
Capture RAIN-16.JPG (270.34 Kio) Vu 599 fois

samick
Messages : 8
Enregistré le : 30 juin 2020, 18:21

Re: Pluviomètre TFA problème de configuation ?

Message par samick »

Des averses cet après-midi et là tout semble s'enregistrer dans Domotics :
Capture RAIN-18.JPG
Capture RAIN-18.JPG (31.43 Kio) Vu 588 fois
Il reste des erreurs :
Capture RAIN-17.JPG
Capture RAIN-17.JPG (92.08 Kio) Vu 588 fois
Étrange ce pluviomètre... j'ai éloigné le pluviomètre, il est à 6 mètres du RFXcom avant j'étais à 2 mètres
J'attends un peu pour valider. Je vous tiens au courant.

Chrominator
Messages : 524
Enregistré le : 19 déc. 2015, 07:29

Re: Pluviomètre TFA problème de configuation ?

Message par Chrominator »

Toutes ces textes qui s'affichent en rouge sont des erreurs, dont la conclusion est que la base est verrouillée.
En tout cas on voit nettement que DZ ne parvient pas à mettre à jour ta base concernant le device n¨67, mais aussi plusieurs autres.

Une base peut être verrouillée lorsqu'un processus réclame un accès exclusif.
Est-ce que par hasard tu n'aurais pas un autre processus (soit un autre DZ, soit un éditeur de base sqlite qui serait resté sur la base, ....) ?
Reste-t-il de la place sur le système de fichier où est la base ?

samick
Messages : 8
Enregistré le : 30 juin 2020, 18:21

Re: Pluviomètre TFA problème de configuation ?

Message par samick »

Pour l'installation, je suis sur Raspberry avec dernière installation stable mai 2020. Les logiciels installés : VNC viewer et Domoticz. Il reste plusieurs Go de libre sur la carte mémoire.

Plus de défaut la base doit se vider :
Capture RAIN-19.JPG
Capture RAIN-19.JPG (133.79 Kio) Vu 572 fois
L'historique fonctionne, on y croit :
Capture RAIN-20.JPG
Capture RAIN-20.JPG (32.29 Kio) Vu 572 fois

Répondre