Pas de communication Zwave après Mise à jour > v4.x

Tout ce que vous avez toujours voulu savoir sur le Z-Wave, protocole, equipements, interface,s ...
burno
Messages : 10
Enregistré le : 21 nov. 2016, 20:51

Pas de communication Zwave après Mise à jour > v4.x

Message par burno » 06 déc. 2018, 12:37

Bonjour à vous,

ça fait un bout de temps que ma config fonctionne, mais j'ai un problème assez embêtant aujourd'hui je ne peux faire aucune mise à jour logiciel de domoticz sans que mes périphériques Z-wave ne reçoivent plus mes ordres.

ce que j'ai fait jusqu'à présent :
- snapshot puis update vers stable -> pas de communication
- snapshot puis update vers beta -> pas de communication
- revert snapshot -> tout fonctionne

- nouvelle installation sur une machine neuve (LXC) vers stable, import DB, import des répertoires "Config" et "Scripts" -> pas de communication
- nouvelle installation sur une machine neuve (LXC) vers beta, import DB, import des répertoires "Config" et "Scripts"> pas de communication

Jusque là rien de bien fou, toutes mes machines voient les noeuds Z-wave et domoticz log bien l'envoi
des commandes, mais rien coté périphériques.
c'est étonnant car si j'éteins mes machines de test et relance la machine de prod tout communique bien ...

Qu'es ce que je peux faire pour affiner le diagnostique ? Y a-t-il des fichiers à modifier pour pouvoir effectuer des mises à jours ?

Ma config actuelle :
- ZStick-5G Oui OpenZWave USB Version: 1.4-2998-g5bdd857f-dirty /dev/ttyUSB-ZStick-5G (Controller - Aeotec ZW090 Z-Stick Gen5 EU)
- 6x Qubino ZMNHJD1 Flush Dimmer Pilot Wire+
- Domoticz Version: 3.9139 - Compile Date: 2018-03-31 08:19:09
- Debian 9 - LXC - Proxmod v5.3-1 (debian 9)

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Flo
Messages : 45
Enregistré le : 25 janv. 2018, 21:21

Re: Pas de communication Zwave après Mise à jour > v4.x

Message par Flo » 06 janv. 2019, 18:24

Salut,
en principe rien à faire avant upgrade.
Je dirais que c’est probablement openzwave qui deconne. Faut voir les logs d’openzwave.
Et openzwave control panel dit quoi ?
(https://192.168.1.xxx/ozwcp/cp.html)
Domoticz sur Raspberry. Rfxcom. Zwave. Xiaomi Gateway. Yeelight. Homebridge.

titis14
Messages : 120
Enregistré le : 22 juin 2018, 14:09

Re: Pas de communication Zwave après Mise à jour > v4.x

Message par titis14 » 09 janv. 2019, 15:15

Moi j'ai le même problème après un reboot. J'ai Domoticz sur un Débian 8 que je viens de faire avec une alarme (Sirène + capteur de porte) pendant 3 jours test de l'alarme OK et là j'ai rebooté KO plus rien ne communique avec Zwave. Mes ports USB sont fixé donc pas de problème de changement de port.
J'ai restauré la BD j'ai réussi à faire repartir tout. Je penser que cela venait du fait de rebooter le pc par le menu graphique de débian et non par l'interface de Domoticz. J'ai donc fait un teste en faisant un reboot mais KO plus rien ne communique de nouveau, tout mes modules sont bien dans matériel, sur le panneau de la clé ils sont tous présent mais plus rien de réagis.
Une restauration de BD KO, une guérison du Noeud KO il me mets même un capteur en erreur et en état ouvert alors qu'il est fermé et n'a pas bougé depuis un moment.
Franchement ça fait un mois que je galère avec domoticz et y a toujours un problème avec les modules Z wave, des fois j'ai plus les noms, des fois ça communique plus. Mon installation n'est pas encore en prod donc je n'imagine pas une fois en place je ne serais pas rassuré.

Des pistes ? Merci

titis14
Messages : 120
Enregistré le : 22 juin 2018, 14:09

Re: Pas de communication Zwave après Mise à jour > v4.x

Message par titis14 » 09 janv. 2019, 20:49

J'ai trouvé comment avoir de nouveau la communication, quand je reboot le PC, Domoticz se relance tout seul mais rien ne fonctionne.
Il faut arrêter le service et le relancer et là tout fonctionne.

J'ai tenté d'arrêter le service puis de rebooter mais KO, je me demande si domoticz ne se lance pas trop vite et du coup ne détecter pas forcément la clé au démarrage.
A voir si il serait possible de retarder le service au démarrage.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Flo
Messages : 45
Enregistré le : 25 janv. 2018, 21:21

Re: Pas de communication Zwave après Mise à jour > v4.x

Message par Flo » 09 janv. 2019, 20:52

Salut,
cela doit être un problème d’installation des composants soft. Ou des accès concurrents.
Un restart du service domoticz (sans reboot) ça donne quoi ?
OpenZwave control panel dit quoi ?
Domoticz sur Raspberry. Rfxcom. Zwave. Xiaomi Gateway. Yeelight. Homebridge.

Flo
Messages : 45
Enregistré le : 25 janv. 2018, 21:21

Re: Pas de communication Zwave après Mise à jour > v4.x

Message par Flo » 09 janv. 2019, 20:53

Ha voilà nos réponses se sont croisées.
Donc il faut ralentir domoticz au boot, enfin le démarrer plus tard.
Domoticz sur Raspberry. Rfxcom. Zwave. Xiaomi Gateway. Yeelight. Homebridge.

titis14
Messages : 120
Enregistré le : 22 juin 2018, 14:09

Re: Pas de communication Zwave après Mise à jour > v4.x

Message par titis14 » 10 janv. 2019, 10:12

Flo a écrit :
09 janv. 2019, 20:53
Ha voilà nos réponses se sont croisées.
Donc il faut ralentir domoticz au boot, enfin le démarrer plus tard.
D'après des recherce on peut ajouter "sleep 120" pour 120 seconde, il faudrait l'ajouter à domoticz.sh mais le fichier de boot est ou ? dans update.rc c'est ça ? Le sleep il faut l'ajouter au tout début du script ?

Flo
Messages : 45
Enregistré le : 25 janv. 2018, 21:21

Re: Pas de communication Zwave après Mise à jour > v4.x

Message par Flo » 10 janv. 2019, 10:49

Salut,

pour un soucis avec les demarrages de mosquito le broker MQTT et domoticz, j'ai du faire redemarrer domoticz apres 100 secondes, j'ai procédé comme cela :
J'ai édité le /etc/rc.local qui est exécuté après tous les /etc/rcX.d et ajouté cette commande ou pi est le user et 100 le nombre de secondes a attendre (il doit être > a 60 sinon cela ne fonctionne pas toujours, pour mon cas du moins) :

Code : Tout sélectionner

sudo -u pi sleep 100; sudo service domoticz.sh restart
Je ne sais pas si c'est le moyen le plus propre, mais c'est simple et fonctionnel.
Domoticz sur Raspberry. Rfxcom. Zwave. Xiaomi Gateway. Yeelight. Homebridge.

titis14
Messages : 120
Enregistré le : 22 juin 2018, 14:09

Re: Pas de communication Zwave après Mise à jour > v4.x

Message par titis14 » 10 janv. 2019, 11:26

Avant de faire une bétise et de sauvegarder, comme ça c'est bon ? Merci
domo.jpg
domo.jpg (160.28 Kio) Vu 690 fois

Flo
Messages : 45
Enregistré le : 25 janv. 2018, 21:21

Re: Pas de communication Zwave après Mise à jour > v4.x

Message par Flo » 10 janv. 2019, 11:56

Oui, mais le user n’est pas pi ?
Domoticz sur Raspberry. Rfxcom. Zwave. Xiaomi Gateway. Yeelight. Homebridge.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre