DS18B20 NEUVE ET HS ?

Discuter de tout et de rien, c'est ici
Répondre
RaspOlivier
Messages : 78
Enregistré le : 10 déc. 2016, 09:40

DS18B20 NEUVE ET HS ?

Message par RaspOlivier » 31 déc. 2018, 14:28

Bonjour,

J'ai installé aujourd'hui des sondes DS18B20 que j'ai acheté fin 2016 sur ebay (lot de 10).
Lorsque je les raccorde, elles chauffent toutes et font tomber la tension à moins de 2 v.
Ce ne sont pas des modèles P et le raccordement d'une sonde ne faisant pas partie de cette série ne pose pas de problème.

Avez-vous déjà rencontré ce cas ?

Merci.
Modifié en dernier par RaspOlivier le 08 janv. 2019, 07:00, modifié 1 fois.
La curiosité est un joli défaut ...

Quand ça ne fonctionne pas, il faut trouver pourquoi et réparer.C'est seulement après que l'on peut jeter l'esprit tranquille ...

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


vil1driver
Messages : 4969
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: DS18B20 NEUVE ET hs ?

Message par vil1driver » 31 déc. 2018, 15:52

Salut,

A vu de nez, problème de polarité
MAJ = VIDER LE CACHE(<-Clicable)


Domoticz v4.10078 (ubuntu server) OpenZwave v1.4-3229 (zwave+ sigma designs) rfxtrx433 fw1015T1

433mhz : thgn800, ms13e2, phenix, Di.O, zk1pa, creasol sender
868mhz : fgms-001, fgfs-101, dsd37-zweu, ZW098


modules.lua

RaspOlivier
Messages : 78
Enregistré le : 10 déc. 2016, 09:40

Re: DS18B20 NEUVE ET HS ?

Message par RaspOlivier » 31 déc. 2018, 18:28

Salut Vil1driver et merci pour ta réponse,

Si c'est un problème de polarité, il est interne au boitier, j'ai même pris le risque de faire une rotation de 180°sur la plaque de montage rapide et autant cela ne chauffe plus, je n'ai pas non plus de présence de la sonde.

Sur une 18b20 étanche qui fonctionne et à l'ohmètre:
Avec la pointe rouge sur le fil noir j'ai 13 M-ohms entre le fil noir(-) et le fil jaune(data) (idem entre le noir et le rouge(+)) et rien entres les autres broches.

Sur la sonde au format TO92, j'ai 36M-ohms entre les pattes 1 et 3 avec la pointe rouge de l'ohmètre sur le + du 18b20 (patte 3).
J'ai du mal à croire que ce composant est réellement un 18b20 lol.
Je vous rassure, c'est bien marqué DALLAS 18B20 dessus !
La curiosité est un joli défaut ...

Quand ça ne fonctionne pas, il faut trouver pourquoi et réparer.C'est seulement après que l'on peut jeter l'esprit tranquille ...

fking
Messages : 113
Enregistré le : 03 nov. 2017, 10:19
Localisation : Liverdun (54)
Contact :

Re: DS18B20 NEUVE ET hs ?

Message par fking » 03 janv. 2019, 10:06

Oui, c'est un problème de polarité. Je me suis fait avoir une fois, le brochage trouvé sur le Web était faux. Le 1820 chauffe dans ce cas, et après, désolé de te le dire, c'est poubelle. Même en les rebranchant correctement, ils ne donnent plus rien.
Fais le ou ne le fais pas , essayer ne veut rien dire.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


RaspOlivier
Messages : 78
Enregistré le : 10 déc. 2016, 09:40

Re: DS18B20 NEUVE ET hs ?

Message par RaspOlivier » 05 janv. 2019, 14:00

Salut,

... et 8 DS18b20 au recyclage ...

T'avais pas noté le brochage à tout hasard ?
La curiosité est un joli défaut ...

Quand ça ne fonctionne pas, il faut trouver pourquoi et réparer.C'est seulement après que l'on peut jeter l'esprit tranquille ...

fking
Messages : 113
Enregistré le : 03 nov. 2017, 10:19
Localisation : Liverdun (54)
Contact :

Re: DS18B20 NEUVE ET hs ?

Message par fking » 07 janv. 2019, 11:01

https://datasheets.maximintegrated.com/ ... S18B20.pdf

Avant de jeter, refais un branchement avec les bonnes polarités, et vois ce que ça donne. J'y crois pas trop, je me suis fais avoir avec 2 capteurs, les deux étaient cuits. Mais on ne sait jamais...
Fais le ou ne le fais pas , essayer ne veut rien dire.

RaspOlivier
Messages : 78
Enregistré le : 10 déc. 2016, 09:40

Re: DS18B20 NEUVE ET hs ?

Message par RaspOlivier » 07 janv. 2019, 18:41

Bonjour,

Le brochage que tu met en PJ est le bon et celui que j'ai utilisé.

C'est en le suivant que cette série de DS18B20 chauffent (et crament très probablement).

J'en ai commandé d'autres de toute façon mais j'aurais bien voulu connaître la raison de ce problème. ;)
La curiosité est un joli défaut ...

Quand ça ne fonctionne pas, il faut trouver pourquoi et réparer.C'est seulement après que l'on peut jeter l'esprit tranquille ...

totof60
Messages : 320
Enregistré le : 29 avr. 2016, 09:31

Re: DS18B20 NEUVE ET hs ?

Message par totof60 » 07 janv. 2019, 20:17

Attention , tu vas recommander des sondes mais ne sont elles pas des contrefaçons ?

viewtopic.php?f=24&t=5001&p=42527&hilit=Ds18b20#p42527
Domoticz V4.9788
sous raspbian-Stretch, Homebridge,RfLink
Raspberry pi3, Google home mini
plein de truc wifi !! de l'esp-01 jusque le nodemcu en passant par le wemos et même du DIY

RaspOlivier
Messages : 78
Enregistré le : 10 déc. 2016, 09:40

Re: DS18B20 NEUVE ET HS ?

Message par RaspOlivier » 08 janv. 2019, 06:55

Bonjour et merci totof pour le lien, j'avais recherché avant de créer mon post mais pas trouvé de topic concernant un problème avec une DS18B20.

Je n'avais pas pensé à de la contrefaçon mais du coup c'est très probable que ce soit le cas :( .
Je vais aller vérifier que je ne les ai pas commandé au même vendeur, lol.

Comme quoi il est important de tester immédiatement le matériel que l'on commande à prix réduit ;)
La curiosité est un joli défaut ...

Quand ça ne fonctionne pas, il faut trouver pourquoi et réparer.C'est seulement après que l'on peut jeter l'esprit tranquille ...

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre