Impossible de se connecter à domoticz

Posez ici vos questions d'utilisation, de configuration de Domoticz, de bugs, de conseils sur le logiciel lui même dans son utilisation et son paramètrage Concernant le Raspberry ou les scripts de toute nature des forums spécifiques sont ouverts
Répondre
emylive
Messages : 38
Enregistré le : 21 mars 2017, 22:43

Impossible de se connecter à domoticz

Message par emylive » 08 nov. 2019, 11:10

J'ai domoticz installé sur raspberry 3 model b.
Lors de la connexion à domoticz sur un navigateur local impossible de me connecter ( ce site est inaccessible)
Par contre je me connecte en shh au raspberry sans aucun problème.
si je fait

Code : Tout sélectionner

pi@raspberrypi:~ $ sudo service domoticz.sh status
● domoticz.service - LSB: Home Automation System
   Loaded: loaded (/etc/init.d/domoticz.sh; generated; vendor preset: enabled)
   Active: active (exited) since Fri 2019-11-08 10:59:35 CET; 5min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 440 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/SU

Nov 08 10:59:34 raspberrypi systemd[1]: Starting LSB: Home Automation System...
Nov 08 10:59:35 raspberrypi domoticz.sh[440]: 2019-11-08 10:59:35.476  Status: D
Nov 08 10:59:35 raspberrypi domoticz.sh[440]: 2019-11-08 10:59:35.484  Status: B
Nov 08 10:59:35 raspberrypi domoticz.sh[440]: 2019-11-08 10:59:35.485  Status: S
Nov 08 10:59:35 raspberrypi domoticz.sh[440]: domoticz: Domoticz is starting up.
Nov 08 10:59:35 raspberrypi domoticz[458]: Domoticz is starting up....
Nov 08 10:59:35 raspberrypi domoticz[462]: Domoticz running...
Nov 08 10:59:35 raspberrypi systemd[1]: Started LSB: Home Automation System.
lines 1-14/14 (END)
Si je tape la commande sudo netstat -antp j'obtiens cela

Code : Tout sélectionner

pi@raspberrypi:~ $  sudo netstat -antp
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      461/sshd
tcp        0      0 192.168.1.45:22         192.168.1.33:62670      ESTABLISHED 805/sshd: pi [priv]
tcp        0      0 192.168.1.45:22         192.168.1.33:61988      ESTABLISHED 710/sshd: pi [priv]
tcp6       0      0 :::22                   :::*                    LISTEN      461/sshd
Je m'attendais à trouver 192.168.1.45:8080, le problème vient il de là? j'ai fait une réinstalle complète de domoticz et je suis avec une freebox
Merci pour votre aide
Domoticz+Xiaomi gateway

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


emylive
Messages : 38
Enregistré le : 21 mars 2017, 22:43

Re: Impossible de se connecter à domoticz

Message par emylive » 08 nov. 2019, 13:24

Je continue mes investigations
avec la commande wget localhost:8080
j'ai cela

Code : Tout sélectionner

pi@raspberrypi:~ $  wget localhost:8080
--2019-11-08 12:52:59--  http://localhost:8080/
Resolving localhost (localhost)... ::1, 127.0.0.1
Connecting to localhost (localhost)|::1|:8080... failed: Connection refused.
Connecting to localhost (localhost)|127.0.0.1|:8080... failed: Connection refused.
J'ai redémarrée ma Freebox mais cela n'a rien solutionné.

Une aide ou une piste à m'apporter?
Domoticz+Xiaomi gateway

lost
Messages : 413
Enregistré le : 12 nov. 2016, 11:01

Re: Impossible de se connecter à domoticz

Message par lost » 08 nov. 2019, 15:06

emylive a écrit :
08 nov. 2019, 13:24

Code : Tout sélectionner

pi@raspberrypi:~ $  wget localhost:8080
--2019-11-08 12:52:59--  http://localhost:8080/
Resolving localhost (localhost)... ::1, 127.0.0.1
Connecting to localhost (localhost)|::1|:8080... failed: Connection refused.
Connecting to localhost (localhost)|127.0.0.1|:8080... failed: Connection refused.
J'ai redémarrée ma Freebox mais cela n'a rien solutionné.

Une aide ou une piste à m'apporter?
Sur le PI lui même en local, la commande devrait charger le index.html du site. Connection refused semble signifier que la partie serveur web de Domoticz n'a pas démarré. Sinon, une règle firewall (iptables ou surcouche ufw...) qui bloquerait le 8080, y compris du localhost (mais laisserait passer le 22 du ssh)??? Pas courant.

Le port par défaut, 8080, n'a pas été modifié au moins?
Au pire, du PI, vérifier via "nmap -A localhost"

On devrait y trouver (entre autres):
8080/tcp open http-proxy

Si le 8080 par défaut est modifié, le http-proxy sera ailleurs...

Sinon, il faudrait modifier le script de démarrage de Domoticz afin de logguer dans un fichier (pour ma part, c'est fait en permanence dans un tmpfs en ram, afin de préserver la SD, vidé une fois par semaine par un cron qui fait un "resize -s 0 <fichierLog>", ce qui fonctionne même sur un fichier ouvert).

Car sans cela, on est aveugle: Les logs partent sur une profondeur limités dans la BDD et ne sont alors lisibles que depuis... l'interface web! Sauf à attaquer en direct le contenu de la BDD, travailler sur une copie par précaution, faite après arrêt du service.

Une raison pourrait être un autre service qui s'accroche au port 8080 avant le démarrage de Domoticz et, premier arrivé premier servi, quand Domoticz veut faire s'y accrocher (bind) c'est refusé car la place est prise!

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


Répondre