Philips Hue mauvais Niveau d'allumage

Vous avez des questions concernant les scripts dans Domoticz, posez vos questions ici, quelque soit le langage nous tenterons des réponses pertinentes ...
Répondre
MowokS
Messages : 46
Enregistré le : 21 mars 2018, 23:17

Philips Hue mauvais Niveau d'allumage

Message par MowokS »

Bonjour à tous,
J'ai investi dans un petit système Philips Hue pour remplacer mes ampoules Xiaomi Philips afin de passer au Zigbee.
Ça fonctionne beaucoup mieux pour mon usage.
Je constate cependant que parfois, rarement même, ma commande

Code : Tout sélectionner

commandArray['sdb hue']='Set Level: 100 %'
donne un allumage à 1%, sans erreurs apparentes dans les logs.
Je ne vois pas d'où peu provenir cette erreur.
Si quelqu'un à une petite idée...
Bien à vous.
Modifié en dernier par MowokS le 30 mai 2020, 13:27, modifié 1 fois.

MowokS
Messages : 46
Enregistré le : 21 mars 2018, 23:17

Re: Philips Hue mauvais Niveau d'allumage

Message par MowokS »

Je me permet un petit up, mon problème étant toujours d'actualité bien que je sois passé sur la dernière version stable de domoticz...

vil1driver
Messages : 5478
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: Philips Hue mauvais Niveau d'allumage

Message par vil1driver »

Salut,

Et si tu enlèves les : et le %
MAJ = VIDER LE CACHE(<-Clicable)
/!\Les mises à jour de Domoticz sont souvent sources de difficultés, ne sautez pas dessus
modules.lua

Un ex domoticzien

MowokS
Messages : 46
Enregistré le : 21 mars 2018, 23:17

Re: Philips Hue mauvais Niveau d'allumage

Message par MowokS »

Merci pour ta réponse Vil1driver.
Ma première approche était sans les : et % .
Avec l’apparition du problème de niveau de luminosité j'ai donc décidé de respecter l’état qui est affiché dans les logs des ampoules soit:

Code : Tout sélectionner

commandArray['sdb hue']='Set Level: 100 %'
Dernièrement je me suis dis que je pourrais essayer avec une commande

Code : Tout sélectionner

local full = 'curl --request PUT --data "{\\"on\\": true, \\"bri\\":254}" http://IpDuPont/api/MonIdentifiantHue/lights/1/state'
os.execute(full)
Le problème de luminosité se reproduit de la même façon aleatoirement.
Avec du recul, je constate que seule mes 3 ampoules Philips parfois s'allument à 1%, je n'ai jamais constaté ce problème sur les petites ampoules Osram Zigbee connectées au pont Hue. Je les solicite moins, probabilité ou bug sur les philips ou problème avec domoticz, je n'arrive pas à cerner la cause.
Bien à vous

MowokS
Messages : 46
Enregistré le : 21 mars 2018, 23:17

Re: Philips Hue mauvais Niveau d'allumage

Message par MowokS »

Je tente un changement de canal Zigbee sur le pont, c'est probablement un problème lié au pont plutôt qu'à domoticz.

Répondre