[Résolu] Envoi mail OK ou pas selon 192. ou 127.

Routage de ports, récupération de météo, accès depuis votre smartphone bref tout ce qui permet à Domoticz d'être conecté à Internet se passe ici.
RaspOlivier
Messages : 86
Enregistré le : 10 déc. 2016, 09:40

[Résolu] Envoi mail OK ou pas selon 192. ou 127.

Message par RaspOlivier »

Bonjour à tous,

Je lance un enième sujet sur la configuration des emails DOMOTICZ (V3.5877) qui me semble un peu différent.

L'envoi d'emails fonctionne quand j'appelle DOMOTICZ via chrome à l'adresse 127.0.0.1 mais pas quand j'y accède avec son IP sur ma freebox.

Qu'en pensez-vous ?

Merci.
Modifié en dernier par RaspOlivier le 12 déc. 2016, 20:24, modifié 1 fois.
La curiosité est un joli défaut ...

Quand ça ne fonctionne plus, il faut trouver pourquoi et réparer.C'est seulement après que l'on peut jeter l'appareil l'esprit tranquille ...

rapinou
Messages : 119
Enregistré le : 17 nov. 2016, 01:44

Re: Envoi mail OK ou pas selon 192. ou 127.

Message par rapinou »

Bonjour,
Quelle IP ? Réseau local ou extérieure ?
RPI 3 - Raspbian 8 (Jessie) - Domoticz V3.5877

patrice
Messages : 1639
Enregistré le : 22 sept. 2014, 21:51

Re: Envoi mail OK ou pas selon 192. ou 127.

Message par patrice »

Bonjour
Je ne comprends passer le lien que tu fais entre chrome et email. Peux-tu détailler ?

Envoyé de mon PULP 4G en utilisant Tapatalk
Raspberry Pi model B+, RFXComm,8 interrupteurs Chacon, 5 ds180b 1-Wire, 3 douilles Chacon, 1 contact de porte Chacon, 1 module variateur,module emetteur 54700, Aeon Stick Z-wave, 1 MultiSensor Aeon, accés à distance.
aka thegritche@domoticz forum

RaspOlivier
Messages : 86
Enregistré le : 10 déc. 2016, 09:40

Re: Envoi mail OK ou pas selon 192. ou 127.

Message par RaspOlivier »

c'est sur mon réseau local en 192.168.0.20.

Pour chrome, j'ai juste précisé au cas où.
La curiosité est un joli défaut ...

Quand ça ne fonctionne plus, il faut trouver pourquoi et réparer.C'est seulement après que l'on peut jeter l'appareil l'esprit tranquille ...

Neutrino
Messages : 1395
Enregistré le : 10 juil. 2015, 15:42
Localisation : Challans (85)
Contact :

Re: Envoi mail OK ou pas selon 192. ou 127.

Message par Neutrino »

Bonjour RaspOlivier et bienvenue.
Il va falloir être un peu plus précis.
Comment envoies tu tes mails, via un script, via le bouton test ?
Quelle ta configuration ? (hardware, OS)
Quelle ta configuration dans l'onglet email ?
Une erreur remonte dans les logs ?
Ma maison à plein d'IP ! :mrgreen:
SAV Bonjour. Vous avez vidé le cache ?

RaspOlivier
Messages : 86
Enregistré le : 10 déc. 2016, 09:40

Re: Envoi mail OK ou pas selon 192. ou 127.

Message par RaspOlivier »

Bonsoir et merci,

En fait, j'ai fait l'install sur une carte neuve en suivant ces tutos :
https://easydomoticz.com/domotique-comm ... nux-debian
puis :
https://easydomoticz.com/2490-2/

J'ai configuré l'onglet Email suivant ce 2ème tuto et c'est lors du test des paramètres que j'ai un message comme quoi il y a un pb d'identifiant (problème qui apparait quand je suis sous domoticz à 192.168.0.20 alors que si je fait un copier-coller des paramètres sur un onglet à 127.0.0.1 cela fonctionne (avec les 3 ports proposés))

J'accède à domoticz via chrome sous windows 7
Domoticz est installé sur un Raspberry Pi
La config mail est faite avec le smtp de free (et est bonne je pense puisque fonctionnelle sur un navigateur à l'adresse 127.0.0.1)

Extrait du log

2016-12-10 14:25:19.105 Error: SMTP Mailer: Error sending Email to: !
2016-12-10 14:25:19.105 Error: Failed to send email notification :
2016-12-10 14:25:19.105 Error: Notification sent (email) => Failed
2016-12-10 14:25:19.123 Active notification subsystems: email (1/12)

Je pense plus à un problème de droits ou quelque-chose du genre (mais je suis débutant alors ...).

Je ne sais pas si il y a un rapport mais j'ai voulu laissé ce point de côté pour paramétrer les GPIO du Rpi en suivant :
https://easydomoticz.com/les-gpio-dans-domoticz/

et du coup même la commande sudo apt-get update bloque :
$ sudo apt-get update
Err http://mirrordirector.raspbian.org jessie InRelease

Err http://mirrordirector.raspbian.org jessie Release.gpg
Ne parvient pas à résoudre « mirrordirector.raspbian.org »
Err http://archive.raspberrypi.org jessie InRelease

Err http://archive.raspberrypi.org jessie Release.gpg
Ne parvient pas à résoudre « archive.raspberrypi.org »
Lecture des listes de paquets... Fait
W: Impossible de récupérer http://mirrordirector.raspbian.org/rasp ... /InRelease

W: Impossible de récupérer http://archive.raspberrypi.org/debian/d ... /InRelease

W: Impossible de récupérer http://mirrordirector.raspbian.org/rasp ... elease.gpg Ne parvient pas à résoudre « mirrordirector.raspbian.org »

W: Impossible de récupérer http://archive.raspberrypi.org/debian/d ... elease.gpg Ne parvient pas à résoudre « archive.raspberrypi.org »

W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Cdt.
La curiosité est un joli défaut ...

Quand ça ne fonctionne plus, il faut trouver pourquoi et réparer.C'est seulement après que l'on peut jeter l'appareil l'esprit tranquille ...

Neutrino
Messages : 1395
Enregistré le : 10 juil. 2015, 15:42
Localisation : Challans (85)
Contact :

Re: Envoi mail OK ou pas selon 192. ou 127.

Message par Neutrino »

Quand tu dis accès via 127.0.0.1, c'est que tu as un domoticz sur ton windows 7 ?
J'ai l'impression qu'il y a plusieurs problèmes, on va procéder par étape.
J'ai l'impression que ton pi ne se connecte pas à internet.
Que te donnes les commandes

Code : Tout sélectionner

ping bbc.co.uk
et

Code : Tout sélectionner

ifconfig
?
Ensuite, l'onglet Email de ton Domoticz sur 192.168.0.20 est-il bien configuré comme sur ton 127.0.0.1 ?
Ma maison à plein d'IP ! :mrgreen:
SAV Bonjour. Vous avez vidé le cache ?

vil1driver
Messages : 5317
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: Envoi mail OK ou pas selon 192. ou 127.

Message par vil1driver »

Neutrino a écrit :Quand tu dis accès via 127.0.0.1, c'est que tu as un domoticz sur ton windows 7 ?
Ou une interface graphique sur son pi ;)
Le diable est partout..
MAJ = VIDER LE CACHE(<-Clicable)
/!\Les mises à jour de Domoticz sont souvent sources de difficultés, ne sautez pas dessus
modules.lua

Un ex domoticzien

RaspOlivier
Messages : 86
Enregistré le : 10 déc. 2016, 09:40

Re: Envoi mail OK ou pas selon 192. ou 127.

Message par RaspOlivier »

Bonjour,

alors effectivement ping ne donne rien :
$ ping bbc.co.uk
ping: unknown host bbc.co.uk

et ifconfig donne ça (j'ai remplacé certaines valeurs par des * ne sachant pas si il vaut mieux éviter de diffuser ces informations) :
$ ifconfig
eth0 Link encap:Ethernet HWaddr **:**:**:**:**:**
inet adr:192.168.0.20 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: ****::****:****:****:****/** Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:11966 errors:0 dropped:0 overruns:0 frame:0
TX packets:5736 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:1670790 (1.5 MiB) TX bytes:1183788 (1.1 MiB)

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::*/*** Scope:Hôte
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Ne devrais-je pas avoir l'adresse de la box dans Broadcast ? EDIT 11/12/16 Apparement non

Le fichier /etc/dhcpcd.conf est configuré ainsi :
interface eth0
static ip_address=192.168.0.20/24 # -- changez ici pour votre adresse ip
static routers=192.168.0.254 # -- changez ici pour votre box
static domain_name_servers=192.168.0.254 # -- changez ici pour vos DNS EDIT 11/12/16 : 8.8.8.8 ne marche pas mieux

Autre symptôme : Domoticz depuis 127.0.0.1 est à l'heure alors que l'accès par 192.168.0.20 ne l'est pas (+ de 8h de décallage)
et la version renvoyée par 127.0.0.1 est V3.5837 alors que 192.168.0.20 est V3.5877 !!

J'avais effectivement un domoticz sur mon windows mais je viens de le désinstaller et celà ne change rien.

EDIT 11/12/16 :

Après redémarrage de l'ordinateur, le DOMOTICZ à l'adresse 127.0.0.1 m'affiche un beau OFF-LINE.
Etait-ce le DOMOTICZ installé sur WINDOWS ?

Du coup j'imagine que je n'ai en fait qu'un seul problème et c'est qu'un paramètre quelquepart m'empêche de me connecter au net.

Je vais creuser un peu de ce côté.

Merci pour vos aides.

EDIT 11/12/16 : Le Rpi ne se connecte plus a internet une fois domoticz installé et redémarré
Modifié en dernier par RaspOlivier le 11 déc. 2016, 19:34, modifié 1 fois.
La curiosité est un joli défaut ...

Quand ça ne fonctionne plus, il faut trouver pourquoi et réparer.C'est seulement après que l'on peut jeter l'appareil l'esprit tranquille ...

vil1driver
Messages : 5317
Enregistré le : 30 janv. 2015, 11:07
Localisation : Rennes (35)

Re: Envoi mail OK ou pas selon 192. ou 127.

Message par vil1driver »

Sais tu ce qu'est 127.0.0.1 ?

Ça pointe vers la machine sur laquelle tu la tapes..


depuis le début tu mélanges 2 installations de domoticz différentes, sur des machines différentes.
MAJ = VIDER LE CACHE(<-Clicable)
/!\Les mises à jour de Domoticz sont souvent sources de difficultés, ne sautez pas dessus
modules.lua

Un ex domoticzien

Répondre